cjwelle

firefox (Archived) Evernote Webclipper stopped working for Friefox on Mac 10.8

11 posts in this topic

Since the latest update to Evernote 3.3, my web clipper in Firefox is no longer working.

When attempting to clip a page the Evernote app opens, but no note is created.

I am on a MBP running 10.8

Evernote Version 3.3.0 (300201)

Firefox 14.0.1

With Web Clipper 5.1.0.252437

The clipper in chrome does work.

Any help is appreciated.

Thank you,

Chris

1 person likes this

Share this post


Link to post

Same problem for me with similar configuration.

After the update to version 3.3 the clipper don't works.

Cliccking on the clipper button evernote start (if is not already loaded) and bring to front, firefox show the HUD with the scissors but evernote don't create a new note!

On the Console.app this is the log of the operation:

03/08/12 23:31:47,358 firefox[34085]: Clip information:

03/08/12 23:31:47,359 firefox[34085]: filename: /Users/user/Library/Caches/TemporaryItems/evernote-mac-clips/clip-tmp-27/firefox-clip.html

03/08/12 23:31:47,359 firefox[34085]: title: Evernote Webclipper stopped working for Friefox on Mac 10.8 - Evernote Web Clippers - Evernote User Forum

03/08/12 23:31:47,359 firefox[34085]: url: http://discussion.ev...fox-on-mac-108/

03/08/12 23:31:47,360 firefox[34085]: encoding: UTF-8

03/08/12 23:31:47,360 firefox[34085]: isClipAndGo: NO

03/08/12 23:31:47,360 firefox[34085]: Sent notification to evernote app: {

clipAndGo = NO;

encoding = "UTF-8";

file = "/Users/user/Library/Caches/TemporaryItems/evernote-mac-clips/clip-tmp-27/firefox-clip.html";

sourceURL = "http://discussion.ev...x-on-mac-108/";

title = "Evernote Webclipper stopped working for Friefox on Mac 10.8 - Evernote Web Clippers - Evernote User Forum";

}

03/08/12 23:31:47,889 sandboxd[37003]: ([36991]) Evernote(36991) deny file-read-xattr /Users/user/Library/Caches/TemporaryItems/evernote-mac-clips/clip-tmp-27/firefox-clip.html

03/08/12 23:31:47,931 sandboxd[37003]: ([36991]) Evernote(36991) deny file-read-data /Users/user/Library/Caches/TemporaryItems/evernote-mac-clips/clip-tmp-27/firefox-clip.html

The temporary file exist and is valid but evernote can't read it!

Share this post


Link to post

Hi all,

We've looked into this and can confirm this serious bug. This will most likely affect all user on Mac client 3.3 who clips directly to the local Mac client.

Here's the workaround you can do:

1) Change your Web Clipper setting to 'Send clips to Web'

- Goto Tools > Add-ons and find the Web Clipper in the Extensions tab.

- Open up the preferences (mac) options (windows)

- And switch to 'Send to Web'

A visual guide to the setting:

https://skitch.com/b...x-clipper-issue

Sorry for the inconvenience.

Share this post


Link to post

Thanks, but I am not clear if it is a fixable bug or the functionality of the clip to the local client will no longer be possible. For me it is the best feature ever.

Share this post


Link to post

Hi Sbarex,

It is fixable and we are working on it. I will post a new version here as soon as we have verified the fix. And clipping to local client will be restored to what it was before Mac 3.3 came out.

Share this post


Link to post

I am having the same issue. I don't understand the work around posted. Please fix this! I love Evernote and have highly recommended it to others. Not useful to me now.

Share this post


Link to post

Hi all,

Actually, I have exactly the same issue when right clicking on files in the finder and choosing Open with... Evernote...

According to the console, it is related to sandoboxing. Something about Evernote not having the rights to read the file you right-clicked on.

Will this issue be fixed soon also ?

Thanks,

Patrick

Share this post


Link to post
Guest
This topic is now closed to further replies.