Jump to content

Archived

This topic is now archived and is closed to further replies.

mynameisjon

android (Archived) Package File Invalid

Recommended Posts

So I've tried all the fixes posted, but nothing works.

I've cleared Play Store cache/data and uninstalled updates, disabled auto-restore app data, rebooted, no joy.

Wiped data from evernote, did the above steps, rebooted, no joy.

All 3 of my devices cannot update to the latest version, and the previous version which was supposed to have this error updated fine.

Galaxy S2

Galaxy Nexus

Motorala Xoom

Share this post


Link to post

Can you please provide the client version you were previously using before you tried to upgrade to the latest client. We have received several reports regarding Package File Invalid and we are busy investigating this further.

Share this post


Link to post

http://www.thespicyg...is-invalid.html

This sometimes happens, and it doesn't matter what rom you are using.

you can first try to Go into Settings > Applications > Manage Applications > Market/Play store > delete the cache and data.

[if rooted]

If this does not work, redo the steps above but right after reboot into recovery. Format/clear the cache partition, and in Advance options menu, Clear the Dalvik cache. Reboot, and try the market again. [/if rooted]

If this doesn't work... you're just gonna have to reflash the system. reboot again.

If this doesn't work.... wipe everything.

Share this post


Link to post

It does not work for me either. I have tried all the various sources of deleting cache and data but nothing works for me.

Samsung S2

ICS 4.0.3

I am not hoping to wipe out all my data, besides this error applies to Evernote app only, I downloaded other apps with no issues. Please advise.

So I've tried all the fixes posted, but nothing works.

I've cleared Play Store cache/data and uninstalled updates, disabled auto-restore app data, rebooted, no joy.

Wiped data from evernote, did the above steps, rebooted, no joy.

All 3 of my devices cannot update to the latest version, and the previous version which was supposed to have this error updated fine.

Galaxy S2

Galaxy Nexus

Motorala Xoom

Share this post


Link to post

Well, the version that was released prior to the one you just put out.

Also, note that asking users to wipe their phone just to install your app is not an acceptable solution, especially when yours is the only app that has such a problem.

Share this post


Link to post

I'm facing the same issue after flashing my Sony Xperia Arc LT15i to ICS 4.0.4.

All other apps do not have this issue, and I've tried the clear Play Store cache/data method.

In my case, it can be considered as a fresh install since I wiped out all the old data.

Share this post


Link to post

Hi All,

The application installs correctly for most users, including users with those devices.

We've already had similar problem in the past, here were the steps I recommended to fix the problem, please let me know if that works for you.

@Chris Lim, apparently you followed some similar steps on your end, I am investigating further to find other work around.

We want to publish a new update as soon as possible. Last time, it enabled all devices to re-init the installation.

http://www.android-a...ile-is-invalid/

Fix the Google Android Market (“Package File is Invalid”):

  • Make sure Android Automatic Restore is turned off (Settings -> Privacy)
  • Go to “Settings -> Applications -> Manage Applications
  • Tap to show “All” Applications
  • Scroll down to the Market App and tap it
  • Tap “Clear Cache” and “Clear Data”
  • Click “Uninstall Updates”
  • Exit everything and reboot your device
  • Your Error should now be fixed

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...