Jump to content
mehuge

chrome (Archived) HELP: Clipper injects Clearly HTML into my pages

Recommended Posts

I was investigating why I was getting what looked like injected html for evernote clearly in my pages having uninstalled the clearly extension. I was most puzzled by this. Turns out its evernote clipper doing it! I am left wondering why the web clipper is injecting html into pages I am not clipping from?

I am developing a web application, so sit in the inspector a lot of the time, and when experiencing an issue with a scrolling div got distracted by this extra html wondering if it was responsible for the anomalies. It turned out it wasn't but thats besides the point. I don't want extra html in my pages when I am developing, but I do want to run the web clipper because its very useful.

This is a recent change. Is it intentional? Is there a way I can turn that particular behaviour off?

The injected HTML in question is:

<style id="_clearly_component__css" type="text/css">#next_pages_container { width: 5px; hight: 5px; position: absolute; top: -100px; left: -100px; z-index: 2147483647 !important; } </style>

<div id="_clearly_component__next_pages_container"></div>

Can't imagine why that would need to be injected before the web clipper button is pressed.

Share this post


Link to post

In version 5.4 of the Chrome Clipper we added the article detection from Clearly to the Clipper, to do a better job of detecting where on the page an "article" is for clipping purposes. We load the clearly script on page load (which creates these elements) instead of when the clipper button is pressed simply because it's easier from an extension developer's perspective. There is currently no method for disabling this except to disable the entire clipper. I'll investigate whether we can change this behavior for the next version of the Chrome Clipper.

  • Like 1

Share this post


Link to post

I see this behavior too, getting something like

#next_pages_container { width: 5px; hight: 5px; position: absolute; top: -100px; left: -100px; z-index: 2147483647 !important;

at the bottom of every page - even XML!

That just makes no sense - the extension should really check the content-type of the page and only include this snippet for HTML pages.

Share this post


Link to post

Agree, it needs to be less intrusive, and just because its easier to develop shouldn't be reason enough to load it unnecessarily every time a page or app is loaded. And its just a plain bug the way it is visible in view source and rendered xml.

Share this post


Link to post

This is highly unwanted behavior and it craps up all my webpages where I've dome styling or scripting to 'div' tags. '_clearly_component__next_pages_container' is also gets selected in above process and gives undesired results.

Same will going to happen on clients' PC if he has clipper installed. If having this is so necessary, at least give the custom tag which is not HTML.

Till then, I'm uninstalling the clipper and asking my clients to do so as well.

Share this post


Link to post

This extra unwanted html is suddenly showing up in my drupal based site. I have to clear it out after each edit or it shows up as text in the articles. Any thoughts on why now as opposed to last week, or last month, since I have had clipper that long? Is there any choice besides uninstalling Clipper?

Share this post


Link to post

This is still happening with the newest Safari Clipper (v5.6). In my experience, it happens most often to text entered in WYSIWYG text fields that are driven by CKEditor. Not only that, but if I edit the text and save it multiple times, the Clipper will inject multiple _clearly_component__css code blocks, compounding the problems I'm having. This has rendered the Clipper unusable for me, as I spend a lot of time developing and using CMS-driven websites.

Share this post


Link to post

This happens in Safari due to a limitation of the Clearly code we're using and the way that safari lets you load code from extensions. I will try and get this changed in the next release. It should not happen in the Chrome Clipper for version 5.5.1 or later. If you're seeing this behavior in Chrome, make sure you have the latest version of the clipper installed.

Share this post


Link to post

Oh dear, I just noticed this code appending itself to every CKEditor text field I edit and being displayed as content on my sites as well. I guess I have no choice but to disable Clipper until this issue is resolved. A real shame since I really like the clipper.

Share this post


Link to post

Would also love to get my hands on a new clipper version for Safari (I use Safari 6 by the way). Currently I can't use the clipper because of the code it injects in the CKeditor (and therefor in the content I publish using this editor).

Share this post


Link to post

This happens in Safari due to a limitation of the Clearly code we're using and the way that safari lets you load code from extensions. I will try and get this changed in the next release. It should not happen in the Chrome Clipper for version 5.5.1 or later. If you're seeing this behavior in Chrome, make sure you have the latest version of the clipper installed.

Is there any fix planned for this issue that affects many sites? Would appreciate any updates, thanks.

Share this post


Link to post

The fix for this in Safari has been made and it is currently in testing. It will be available in the next release, which should be out soon.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...