Jump to content
jbignert

chrome (Archived) Chrome Evernote Web Clipper 5.4 Beta

Recommended Posts

Hi all,

Here is a new Beta version for Chrome Web Clipper. We hope to have fixed these issues:

1) Save button does nothing issue

2) Cannot sign in and getting timeout error message

3) Tag autocomplete is now much faster

4) Tags and comments when clipping URLs are no longer dropped.

Get the build here:

UPDATE - 5.4 is now release to public.

Please take it for a test drive and report any issues back on this thread.

  • Like 2

Share this post


Link to post

Looks good from quick test on Linux/Chromium 18.

Comments and tags saved with Save URL.

Only glitch is icon is black now instead of green.

Share this post


Link to post

Green used to be the new black. Now I guess black is...

  • Like 1

Share this post


Link to post

4) Tags and comments when clipping URLs are no longer dropped.

thumbs up on issue #4!

Environment:

  • Windows 7 SP1 64bit
  • Chrome v18.0.1025.168 m
  • Web Clipper v5.4 Beta

thank you kindly.

n.

Share this post


Link to post

Still seeing problems with inappropriate tag suggestions.

Some times the suggestions are spot on, at other times they are out to lunch.

e.g. All my clips from this forum have the tag "App_Evernote" but I have yet to see that tag as a suggestion. For some reason the suggestions are usually "news, tech, OS_Linux". Those tags have only a single occurence in discussion.evernote.com clips, but, do have a large number of occurences in clips from other sources.

Share this post


Link to post

Hmmm. Just got a suggestion of "App_Evernote, tech, OS_Linux" when clipping the previous post. DIIK whats going on.

Share this post


Link to post

@Owyn We updated some things in the APi for smart filing recommendations with the web release 5/9. Do you experience worse recommendations now than before?

Share this post


Link to post

@Owyn We updated some things in the APi for smart filing recommendations with the web release 5/9. Do you experience worse recommendations now than before?

Not dead sure, but, it feels about the same. Saw instances of this in the alpha test as well.

....

Was wondering if you meant that 5.4 was released as stable. I checked and the store still has 5.3.2 as stable. Re-reading I guess you meant that changes were made at the service which impacted this function.

Share this post


Link to post

@Owyn, correct, the back end parts of smart filing releases with web. Thx for the feedback.

Share this post


Link to post

The 5.4 clipper is now available from the store.

Note that you need to remove the beta clipper, if installed, before installing the stable clipper.

Share this post


Link to post

@Owyn, correct, the back end parts of smart filing releases with web. Thx for the feedback.

Hmmm. Looks like something may have changed for the better as of last nights update.

Got just "App_Evernote" as suggestion when testing newly installed stable clipper.

Share this post


Link to post

I have the following issues with the web clipper:

1. The most aggravating thing with the recent versions of the web clipper is the length of time it takes for the notebook list to come up. Even disabling the smart filing feature doesn't bring up the notebook list immediately like it used to. There should be a local cache of the available Evernote notebooks (and tags) in the extension so that these fields get populated immediately while clipping. It should poll the Evernote account in the background to keep the list up to date.

2. Occasionally after extensive sessions of clipping, the extension stops working. To get it working again I have stop it using the Chrome task manager and after it restarts, it works again.

3. [At least sometimes] When it updates, my setting for the extension are forgotten/reset.

[i posted a similar review of the web clipper in the Chrome Web store before deciding it would be more fruitful to post it here.]

Issue #1 is the most pressing one since it significantly reduces the efficiency and speed of clipping web pages.

Anish

Share this post


Link to post

Hi Anish, let me try and address some of your issues:

Issue 1) I spent most of today working on this. The notebook list comes up about five times faster now (except for immediately after you log in) when you have smart filing enabled, and immediately if you have it disabled. If your notebooks have changed since the last time you used the clipper though, it may take a couple seconds before new notebooks show up in the list. This improvement will be released with the next version of the web clipper.

Issue 2) I haven't seen this issue before, but I will try and look into it and see what I can do before the next release.

Issue 3) This was a problem in 5.3.x clippers, but should be fixed in 5.4 (the update should have kept your 5.3.2 settings). Going forward, this is something we intend to keep up to date in future clippers as well.

  • Like 1

Share this post


Link to post

With the new release of Web Clipper, my current version of Google Chrome won't launch my gmail and igoogle home pages on startup unless the Web Clipper Extension is disabled. As soon as I disable the extension and relaunch the browser, my home pages load just fine. With the extension active, launching the browser gets me two tabs, each with "loading" and the spinning icon.

Any suggestions? I use the heck out of Evernote and losing the Extension is going to seriously compromise my use of the application.

Thanks!

Share this post


Link to post

I am having a problem with 5.4 Build ID: 251294. For example, I have a website that had a table in it and when it clipped copied everything that was there except the table which is what I wanted. Today I clipped a website with a coupon in it. It clipped everything but the coupon. I never had this problem before. What is the problem?

Share this post


Link to post

Noticed that Event Logs are now abbreviated and automatic. Change may have occurred in 5.3.x.

Found one very good use case for the logs. Intermittent internet disconnects and reconnects are shown in the log. I used the logs to document a problem report to my ISP.

e.g.

10:56:41 GMT-0400 (EDT) (LOG) /background.html: Went offline. at /js/main/Extension.js:53:55

10:57:42 GMT-0400 (EDT) (LOG) /background.html: Went online. at /js/main/Extension.js:56:9

Share this post


Link to post

@rbci:

Welcome to the forums.

Need to see specific URL to look at clipping problems.

Share this post


Link to post

Here is one of the sites. The table does not copy. Settings is set at Preserve All Styles

http://www.idahorid....regionv/program

Reproduced with Settings set to preserve styles for text and action of Save full page.

Select all and Save selection also fails.

Workaround is to select all, copy, and paste into note.

Tested on Linux/Chromium 18.

Share this post


Link to post
Noticed that Event Logs are now abbreviated and automatic. Change may have occurred in 5.3.x.

We did this in 5.3, we took out some of the verbosity of the old logs because it was a *lot* of mostly-not-very-useful information, and made them record automatically so that if a user ran across a problem, he'd already have logs saved for it and wouldn't have to figure out how to try and get the same problem to occur again.

  • Like 1

Share this post


Link to post

Here is one of the sites. The table does not copy. Settings is set at Preserve All Styles

http://www.idahorid....regionv/program

I looked at this and I know why it doesn't clip -- the actual table with the main content of the page is embedded in an iframe. For those that aren't familiar with iframes, an iframe is basically a little webpage within a webpage. The two different pages look like they're part of the same page, but for most other purposes, they're treated as if they were two separate pages running in two separate tabs. This keeps code from one page from interacting with the document in the other page (and vice versa) for important security reasons: if you visited (for example) "hackedsite.com" and the hacker had added code to load an iframe on that page, he could try loading up something like "paypal.com" or "bankofamerica.com" in the iframe - this would happen with all the regular permissions that your browser has (for example, you might already be logged in at these sites). If communication was allowed between the two different pages, the hacker could use his hacked page to read info (like your bank account details) out of the iframe he caused your browser to load.

So that's not allowed. But that also means that when our extension code is running in a webpage, and it tries to read the contents out of an iframe to clip a note, it runs into the same problem. For this reason, we currently skip iframes when clipping notes. Browser extensions *do* have special privileges that regular webpages don't have, and so it is technically possible to get information out of an iframe into a browser extension, but it's a fairly complex procedure. This is something we'd like to add to the clippers in the future, but currently, we just don't have iframe support for this reason.

  • Like 1

Share this post


Link to post

ISSUE: The web clipper does not allow you to scroll down to see how much of the webpage/article is being clipped

ISSUE: Right click web clipper does not save the webpage

ISSUE: Before if I selected part of a webpage to clip but than hit escape or whatever, when I pressed the web clipper again, it would remember the information of the area I previously selected, the tags I previously entered, etc. Now it does not.

SUGGESTION: Copy and paste tags - especially a string of tags.

SUGGESTION: Copy notes. Somethings I want to break up a note so I just want to delete different parts. I would love to be able to copy and paste. Also, that will allow me to duplicate the: notebook and tags and have blank notes prepared in advance.

Share this post


Link to post

Using 5.4 clipper in Chrome 20.0:

When I click on a link in my email, chrome opens but does not load the page until I hit ENTER in the address bar. If I disable the clipper, I do not have this issue.

Share this post


Link to post

When the web clipper extension is enabled Chrome will not load the start page on load. The page will load if I click the Home button which is set to the same page. I've tried this on multiple computers now. If I disable the extension, Chrome works perfectly.

I see this was reported earlier in post #14 but never acknowledged.

Share this post


Link to post

How about adding some color back? All these gray icons will get lost in the Google's gray browser frame. I guess since it would be right next to Feedly (green), it would blend in anyway. I am a MSU Spartan so I wouldn't mind. Perhaps you can make the color editable.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...