Jump to content
doobop

mac (Archived) BUG: Highlighting mask is offset in search results

Recommended Posts

I was wondering if anybody else had noticed this issue:

when I am searching for a bit of text among my notes (using the search field at the upper right corner), I get the results back where the found bit of text is highlighted by Evernote (by overlaying everything else with a grey semitransparent layer) to help my eyes find the hits. Good idea! The problem is just that the highlighting openings in the mask (i.e., the open spaces in the gray semitransparent layer) are not highlighting the found bit of text, but are offset by up to about 1 cm (half an inch) - see the attached screenshot where I looked for the word "test" - all highlighting windows are about 1 cm BELOW the found instances of "test".

Any idea where this problem stems from? Is it a local problem or is it a bug?

Any pointers are appreciated!

Thanks!

-J.P.

OSX 10.7.3, MacBook Pro Intel Core 2 DUo 2.66 GHz (mid-2009), Evernote for OSX 3.0.6

post-53691-0-19392000-1330099940_thumb.p

Share this post


Link to post

Thanks for the screenshot. Are is this a PDF that we're looking at? We usually do a decent job at highlighting, but sometimes if the document has been cropped, this gets thrown off. Also some scans seem to come in weird, but I'm not sure why yet

  • Like 1

Share this post


Link to post

Good point indeed!

Most of my entries into Evernote are via the "print" menu and then using "save pdf to Evernote" (no croping as such occurs). Since most of my documents are entered this way, I have been seeing this mask off-set behavior a lot, while, indeed, documents entered differently (either directly or forwarded as e-mail) do not seem to suffer from this behavior!

Does this help a bit!?

Thanks!

Share this post


Link to post

I am using a Epson Artisan 810 to scan my files and I get the same issue. Some of the search just shows the highlighted box as it found a word I was searching for but theres no text under it, just the white box.

Also, In the note info most of my pdf's will show " PDF HAS NOT BEEN INDEXED " Even know they have been synced.

Any thoughts on whats going on?

Thanks :blink:

Share this post


Link to post

Here's another conversation, one I started, just about search results in text (not PDF). But the problem is the same: that Evernote highlights text a few lines below the true location of search matches. Since I've experienced this with text, it can't just be an issue of OCR or, as dlu mentioned, cropping.

Share this post


Link to post

I'm having the same problem and it's a deal breaker for me - searching largish PDF documents is basically the reason I'm using Evernote. Gotta be a way to fix this.

Share this post


Link to post

I have been complaining about this for a while as well. I can't understand why this isn't given higher priority.

"Find things fast" is one of Evernote's key promises! This should be treated as a major bug.

Here is the thread I started with some feedback from Evernote.

http://discussion.ev...itioned-too-low

  • Like 1

Share this post


Link to post

While we are on the issue of highlighting search results, I think it would be much better to highlight ONLY the search results with a background of yellow (or user-selectable color) and leave the other text background unchanged.

The dark grey background applied to the other text in the Note makes it very hard to read the underlying text, which one often needs to do when looking at search results in order to put the search results in context of the surrounding text.

Thanks.

Share this post


Link to post

I agree. The current implementation leaves a lot to be desired. Highlighting the search term in yellow might get confusing with text the user may have highlighted in yellow. Maybe highlighting in an "aqua" type button would do the trick. How about an Evernote-green aqua button, or maybe a handwritten-looking loopy circle thing?

Share this post


Link to post

I have this same problem, and have had it for a while. It is still a bug in 3.1.

Anyway, some additional info:

For me, it happens with every searchable, inline PDF. However, it only happens when I use the the global search box in the upper right hand corner rather than just using the find function within a note. Also, it never happens for the current PDF that is selected, even if I used the global search box.

So, for example, if I have ten notes in a notebook, each with pdfs, and currently have the first one selected, then, when I do a search, any results in the first pdf are aligned properly, but as I cycle through the results (using command-G) and hit a result in a different note, then the alignment of the boxes is off. It also happens if I click on any of the other notes that match the result other than the one selected when I did the search.

However, if I get to a search result (by clicking or cycling through) where the alignment is off, and then do a local search (command-f) for the same result, then the boxes are aligned properly.

Hope that helps you reproduce the bug.

Share this post


Link to post

Welcome to the forums, Luke.

Thanks for sharing the bug here, since it helps those of us experiencing the problem get a sense of what's going on with other people—and what might be going on with our computers. But make sure also to file a support ticket explaining all that, so Evernote hears about it quickly and collects the information in the best place.

Share this post


Link to post

Let me throw this out. It's only a gut feeling but it seems that there may be an issue, for me at least, of my ScanSnap making a searchable PDF that then gets fed into Evernote. It "feels" like the ScanSnap OCR may be throwing off the Evernote OCR, but as I said, it's only a feeling and I can't nail it down. Anyone else?

Share this post


Link to post

I have this same problem, and have had it for a while. It is still a bug in 3.1.

Anyway, some additional info:

For me, it happens with every searchable, inline PDF. However, it only happens when I use the the global search box in the upper right hand corner rather than just using the find function within a note. Also, it never happens for the current PDF that is selected, even if I used the global search box.

So, for example, if I have ten notes in a notebook, each with pdfs, and currently have the first one selected, then, when I do a search, any results in the first pdf are aligned properly, but as I cycle through the results (using command-G) and hit a result in a different note, then the alignment of the boxes is off. It also happens if I click on any of the other notes that match the result other than the one selected when I did the search.

However, if I get to a search result (by clicking or cycling through) where the alignment is off, and then do a local search (command-f) for the same result, then the boxes are aligned properly.

Hope that helps you reproduce the bug.

Great detective work. I hope this helps them nail this one down. I read in the release notes that this bug was fixed... guess not. :(

Share this post


Link to post

I, too, am having this happen and it's extremely frustrating, especially when the highlight is very far from the actual text it's supposed to be highlighting. I used to use Evernote Desktop on 2 different macs in two different locations... I found that Mac #1 always worked perfectly. Mac #2 is where the highlight box would show up in the wrong place. It worked some of the time, but it didn't always. It was nowhere near as consistent as Mac #1 was. I no longer use Mac #1, and unfortunately Mac #2 is the buggy one.

I understand that forums are where power users tend to show up, and I also understand the importance of keeping a balance between all types of users, so that everyone is happy. However, if Evernote isn't doing what it's supposed to be doing, regardless of how much a user uses it, it needs to be addressed. I've been using Evernote for YEARS, and I am a premium member who relies on Evernote every day of my life. I don't often post here, but this bug is bugging me and slowing down my efficiency as I work. I felt compelled to add my name to the list of people who are experiencing it.

I hope Evernote can reproduce it themselves, so they can find a fix, or at least, find a user who is and look at a screenshot or video, or gather as much info as they can from those of us who do experience it. I'd like to know they are making a legitimate effort at fixing it. The longer it goes, the more frustrating it becomes. Evernote is such an amazing app, and has made such a huge difference in my daily life, that I hope those who created it to make our lives easier, are able to fix a problem that is getting in the way of the very purpose of the app.

Share this post


Link to post

Still not fixed in 3.1.2 (255119).

Re: peterfmartin

Thanks for the suggestion. I did actually submit a ticket, and it ended with: "The developers are aware of the bug."

I'm sure they will get to it when they can, but as always, bugs and tasks must be prioritized, and we have no idea what other tasks / fixes are scheduled and have higher priority. The more people that post here complaining about it should increase its priority, however.

Share this post


Link to post

Re: peterfmartin

Thanks for the suggestion. I did actually submit a ticket, and it ended with: "The developers are aware of the bug."

Yeah, that sucks.

The more people that post here complaining about it should increase its priority, however.

I hope.

  • Like 1

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...