Jump to content
Josh N

windows [Bug] Audio Playback Problem

Recommended Posts

I ran into a problem today with playing back .m4a files within Evernote.

When I click the play button, the icon changes to 'paused' but the progress slider does not move and no sound is played. Additionally, the track length is shown as 0:00 after pressing play. The same m4a file plays fine in Mac Evernote.

Additionally, every sound file in Evernote thereafter shows the locked pause button where the play button should be. Even if I record an audio note in Evernote, it will not be able to be played back.

I discovered a temporary fix: to relocate the Evernote local files to a new, empty folder. This resets the pause buttons to play buttons for all audio files in Evernote. I converted the .m4a files to .mp3, and the .mp3 files play fine, as do .wav files. These are the only formats I've tested.

iTunes is my default application for all three file types.

Log:

Evernote for Windows 4.5.2.5904 (209040) Public

OS: Windows 6.1.7601 Service Pack 1

User: [deleted]

Memory: 60.3MB

Created: 2012/01/18 22:38:45

---

Log opened on 2012/01/18 22:36:48 (UTC-8:00)

22:36:48 [4044] Changed Evernote files location to: D:\Evernote Data

22:36:49 [4044] Opened database: D:\Evernote Data\Databases\xxx.exb (8.3MB Fixed)

22:37:28 [4044] Reloaded external editor for resource 527/0, file"D:\Evernote Data\Databases\Attachments\01.16.2012 613p.m4a"

22:37:28 [4044] External file "D:\Evernote Data\Databases\Attachments\01.16.2012 613p.m4a", resource 527/0, is unchanged

22:37:39 [4044] Started audio playback, file: C:\Users\xxx\AppData\Local\Temp\enaudio\Evernote 20120118 22.28.23.wav

22:37:43 [4044] Stopped audio playback, file: C:\Users\xxx\AppData\Local\Temp\enaudio\Evernote 20120118 22.28.23.wav

22:37:48 [4044] Could not start audio playback: cannot play file exception, file: C:\Users\xxx\AppData\Local\Temp\enaudio\01.16.2012 613p.m4a

===

No log information is produced after pressing the locked pause button.

This guy sounds like he has the same problem: http://discussion.evernote.com/topic/21324-audio-note-playback-problem/

Share this post


Link to post

I am having the exact same problem. Did you have any luck figuring this out?

(I'm also a Premium Member.)

Share this post


Link to post

I was able to resolve this issue by installing codecs for windows media player. Not sure what the exact codec needed was. I just googled "windows media player codec" and installed the media player codec pack from cnet.

 

Note: be careful. Its one of those free installs that will want to install advertisement malware on your system if you just blindly click next next next. I was Ok I just made sure i watched what I was accepting to install and said no tot he ads.  

Share this post


Link to post

One of our employees recorded something and attached it to a note in EN.  I can play back the audio fine from my iPhone and my Mac but on the Windows client it's the same situation as the OP. I get this in my log: 

 

18:48:55 [3380] Could not start audio playback: cannot play file exception, file: C:\Users\username\AppData\Local\Temp\enaudio\recording.m4a

 

I can right click on the attachment from EN and do a "Save As" and then double click the file from the desktop. It plays just fine in Windows Media Player. No extra codecs needed beyond whatever I had from the default set that comes with Windows and whatever extra ones I got by installing iTunes.

 

Is there a fix for this?

Share this post


Link to post

Same problem here... on 2 different PCs, Win7-64 and Win8.1u1. Please fix this bug, this thread is 2 years old!

 

01:03:17 [8736] Could not start audio playback: cannot play file exception, file: C:\Users\ALAREN~1\AppData\Local\Temp\enaudio\01.m4a

 

The file is there and with a double click it opens in media player, i can change default player to quicktime or anything, the file is played.

Share this post


Link to post

×
×
  • Create New...