mac (Archived) Solved Mac crashes and missing notes sync problem

2 posts in this topic

My Evernote on Mac had been working beautifully until one day it must have had a conflict or something and just crashed the entire app. I couldn't even open the application on my Mac. It loaded but it wouldn't load any of my notes and all I got is a spinning icon which eventually led to an annoying "Application Not Responding" and the only thing I could do was Force Quit the application.

Thankfully all my notes were still intact on the web server, so I wasn't too worried about losing data, because I know it worked on the web client and also on my Android app, so I knew it was just a problem with my Mac.

I didn't do anything further since I wanted to upgrade my OS X 10.5.8 Leopard to the latest OS X 10.7 Lion anyway, so I thought might as well wait until the upgrade is done. I did that, and updated the software, hoping that it would just work itself out. Unfortunately it didn't, Evernote still kept crashing on my Mac upon opening.

After reading around how to refresh/rebuild the local database and to force sync to the web server, the suggested solution was to go to ~/Library/Application Support and rename or move the Evernote folder e.g. to Desktop. I did that and this time Evernote didn't crash on open and it did attempt to sync to the web server, but strangely a lot of my notes were missing.

After further reading around, I tried someone's suggestion to empty the trash and rename or move the ~/Library/Application Support/Evernote folder again like above to force the web sync. This time it worked, I got all my notes on my Mac now and everything seems to be working fine again.

I'm glad I was able to solve this problem. I thought I'd share my experiences perhaps it could shed some light to others facing the same problem.


Share this post

Link to post

Thank you, this just helped me fix my issue :).

BTW, in Mac OSX Lion, ~/Library is hidden, probably because of a general unfamiliarity with its content. To access, simply open Finder, press Command+Shift+G, type in ~/Library and enter.

Share this post

Link to post
This topic is now closed to further replies.