Jump to content
brihanrohan

Tapatalk integration

Recommended Posts

I have been able to browse this forum on Tapatalk for android before, but recently it has stopped working. Says "Server error" every time. Anyone know why?

Share this post


Link to post

Because I haven't been able to get it installed on the forum yet. Been some unexpected roadblocks that I'm presently working through.

  • Like 1

Share this post


Link to post
Tapatalk is in now, I think.

Nah. Not yet. Just tested and search on "Evernote" brings up one result which I suspect is the old forum. Anyway, following the result gets a "Cannot connect to forum" error.

I think Geoff is still fighting his way through the Tapatalk + IPBoard swamps.

Share this post


Link to post

Owyn's right. I'm still pulling a server error after trying some things over the weekend. This is a priority this week. Thanks for your patience!

Share this post


Link to post

Alright, we now have Tapatalk running on the forum. Tell your friends.

Special thanks to Heather (Support Maven) for pushing this through!

Share this post


Link to post

Alright, we now have Tapatalk running on the forum. Tell your friends.

Special thanks to Heather (Support Maven) for pushing this through!

giggity!

Share this post


Link to post
Alright, we now have Tapatalk running on the forum. Tell your friends. Special thanks to Heather (Support Maven) for pushing this through!

just a note... its the address that starts with "discussion.evernote.com"

Share this post


Link to post

First time i got an error...

second time it stayed on "Receiving from server" for a while... and still on that screen

Then it said "invalid access (or something) or admin has diabled tapatalk access"

Share this post


Link to post

"You have entered either an invalid username/password or your administrator has restricted access via Tapatalk"

Share this post


Link to post

Seeing it now. Looking into this, thanks James. Tapatalk ain't playin well with the SSO.

You can view ok right?

Share this post


Link to post

Seeing it now. Looking into this, thanks James. Tapatalk ain't playin well with the SSO.

You can view ok right?

Yep... although are all the threads there? I have to verify I feel like some are missing...

Share this post


Link to post

This is exciting... "Your account will automatically be unlocked in %s minutes"

Quite exciting :). Looking into this with Invision as well--along with the missing forums...

Share this post


Link to post

Quick update on Tapatalk. It appears we'll need to work on a custom solution to play well with the SSO. Still developing, but AFAI can tell there are no out of the box solutions or quick fixes for this one. :/

Share this post


Link to post

Hi,

I also now have Tapatalk installed on my iPad, and I can see this forum as a guest. When I try to log in though I get "You have either entered an invalid username/password or your administrator has restricted access via Tapatalk HD.

The second time I try it tells me that "Your account will automatically be unlocked in %s minutes", which isn't very nice :)

It would be very nice to be able to sign in and post from the iPad. Can you sort it soon-ish please.

Owen

Share this post


Link to post

I have Tapatalk on my Kindle Fire and I also get the error, "Your account will automatically be unlocked in %s minutes" when I try to log in. I can browse the forums but I can't log in.

Share this post


Link to post

This is correct. Unfortunately Tapatalk doesn't work well with custom logins, so we're unable to do anything about this at the moment. In the near term, and if you're an IOS user, I'd suggest using Invision's native application (not sure if it's optimized for iPad or not). It's only for IOS.

We're working on a long-term solution that involves Tapatalk and Invision, but for now Tapatalk is view only. Deepest apologies, we spent a ton of time trying to get it to work, but alas, it did not play well with the SSO.

Share this post


Link to post

@gbarry

No complaint, just a question. I tried to log into EN forums with Tapatalk, not knowing it doesn't work, and afterwards I got a message on my pc saying that my account was suspended. I am able to log in today from a different location, so I can only assume my home IP was banned? If this is true I was wondering if it is temporary, or if I needed to do something to have it fixed.

Thanks

Share this post


Link to post

If that was yesterday, that might have been to do with some work that was being done on the site, rather than anything to do with your home IP.

Share this post


Link to post

@gbarry

No complaint, just a question. I tried to log into EN forums with Tapatalk, not knowing it doesn't work, and afterwards I got a message on my pc saying that my account was suspended. I am able to log in today from a different location, so I can only assume my home IP was banned? If this is true I was wondering if it is temporary, or if I needed to do something to have it fixed.

Thanks

The account suspension was an unclear message used by our host while your DNS was updating. Let us know if it hasn't resolved itself yet. It should have.

  • Like 1

Share this post


Link to post

Any update on the status of the 'long-term solution' for Evernote Forums and Tapatalk? And if it's going to be a longish time to resolution, maybe update the error message at attempted login to explain the conflict?

Thx.

Share this post


Link to post

I was able to access Evernote forum with Tapatalk (Android), but when I tried to log in, I got a "Failed to connect to forum..." message. Anyone here has the same problem?

Share this post


Link to post

This is correct. Unfortunately Tapatalk doesn't work well with custom logins, so we're unable to do anything about this at the moment. In the near term, and if you're an IOS user, I'd suggest using Invision's native application (not sure if it's optimized for iPad or not). It's only for IOS.

We're working on a long-term solution that involves Tapatalk and Invision, but for now Tapatalk is view only. Deepest apologies, we spent a ton of time trying to get it to work, but alas, it did not play well with the SSO.

Looks like Invision realeased iPad app yesterday. I tried it just now and I can't log in with Invision, is this a problem with custom logins as well?

Share this post


Link to post

ok, so I actually logged in with a built-in browser in Invision but the app is kind of glitchy. It gets stuck if you reply in landscape orientation and you have to close it manually. Works fine in portrait though.

I'm sticking with mobile Safari anyway.

Edit: they fixed the landscape bug today...

Share this post


Link to post

You can view with but not comment using Tapatalk. We unfortunately can't get Tapatalk to work with our forum registration.

There's an IOS and Android app on the way from Invision, that work well with our forum software and should be a decent alternative to Tapatalk. We'll reup with them in a few months to see if there's anything custom we can do--so far they've been reticent on taking on custom jobs.

Share this post


Link to post

What problems are you having with replies? I use Tapatalk with my IPB forum without any problems.

Just bought the IPS app. As I suspected, it's pretty bad :( Doesn't help that I also can't login with the IPS app, either.

Which user name/password should I be using? The same one as for my main Evernote account? I've tried that, plus the one I had for the old forum, and neither work. When I log in here on my laptop, I'm using my main Evernote account setting, but they're not accepted by the new IPS app.

Share this post


Link to post

Our forum uses a special Single Sign On registration with your Evernote account--it's not a traditional IPB forum registration, and Tapatalk doesn't support custom registrations for its supported forums.

We worked on the old IPS app, I'll download it now and see what's up.

Share this post


Link to post

So I've successfully logged into the IPB App by hitting the upper right hand menu button, then "Register", then the little right hand button with 4 squares, then "Sign In". Enter your Evernote Account info, hit Sign In, and you should be successfully logged in. Hit "Done" and then when you're back to Home screen, drag down to reload the page.

Getting to the appropriate sign in page is pretty obtuse, and looks to be a hold over from their previous app. But it works. I'll bring up with them to see if there's a way to get SSO setups a little easier access, directly from the main registration page.

The app can be found in the app store under "IPB Communities", or here: http://itunes.apple.com/us/app/ips-communities/id521920635?mt=8

FYI, it's 1.99 USD.

Share this post


Link to post

Wow, how did you manage to work that out, lol! Yes, that works but hardly intuitive!

Not really surprised. IPB make brilliant forums, but their iOS apps are terrible. The last one was worse than awful. Joke is, I believe it's written by a third party, so you'd assume someone at IPB actually said, yeah, this is good, let's get it released.

Anyway, I'm in, and thanks for the help gbarry :)

Share this post


Link to post

Wow, how did you manage to work that out, lol! Yes, that works but hardly intuitive!

Not really surprised. IPB make brilliant forums, but their iOS apps are terrible. The last one was worse than awful. Joke is, I believe it's written by a third party, so you'd assume someone at IPB actually said, yeah, this is good, let's get it released.

Anyway, I'm in, and thanks for the help gbarry :)

No problem :) I had this inkling the old registration process would be somewhere on their app, that they wouldn't have scrapped it entirely when they pulled it from the store for development on the new one. So I just sniffed it out.

It gets worse - when you log in to the iOS app, it logs you out of the site!

At least that makes a modicum of sense, unlike the login process. It's kicking you out of your other login instance. Though oddly, that didn't happen appear to happen with my account. :/

Share this post


Link to post

Any idea why a pop up saying "this forum supported on tapatalk. download the app now", or something to that extent, shows up when you pull up the evernote forum on iPad? I downloaded the talkatap app only to read the evernote forums, and now it won't even work. Of course, after I paid for the app I found this forum thread.

Share this post


Link to post

I haven't seen this. It's generating an ad for you to purchase when you're browsing in SafarI?

We can only offer read only functionality on Tapatalk right now--login is prevented by our current SSO setup. I definitely do not want to be driving our users to purchase something that isn't working on our forum.

Share this post


Link to post

bump

This is happening to me. I even registered a new email address and I get the messages mentioned above

Share this post


Link to post

I haven't seen this. It's generating an ad for you to purchase when you're browsing in SafarI?

We can only offer read only functionality on Tapatalk right now--login is prevented by our current SSO setup. I definitely do not want to be driving our users to purchase something that isn't working on our forum.

Yes it prompted me while browsing the Evernote forum in Safari on the iPad. Even after I downloaded Tapatalk, it continued to prompt me when I reopened the Evernote forum.

Share this post


Link to post

Quick update on the Invision mobile app. We're working with them to get SSO logins to work as part of the core registration/login process, rather than the big workaround detailed above.

Share this post


Link to post

Quick update on the Invision mobile app. We're working with them to get SSO logins to work as part of the core registration/login process, rather than the big workaround detailed above.

Did that project get sorted out or still in the works?

Share this post


Link to post

Still in the works. In fact, you could say it took a step back b/c I had to kill the Tapatalk integration entirely for the moment. The service was spamming users to buy the app on our site, who upon purchase would realize we didn't have full functionality to comment. Since Tapatalk could provide me no good way to kill the ads while retaining service, we pulled it.

Would love to have TT up and running on the site, but they don't do custom work for custom logins (like our SSO) and I presently don't have a resource to code up a working integration between the two. I love TT though, so it's definitely on the docket, but it's unfortunately a bit shelved at the moment.

  • Like 1

Share this post


Link to post

Thanks for the update. I appreciate gbarry's efforts but wish the Tapatalk folks would step up their efforts. EN on Android is such a win, but I do like referencing the forum from my smartphone for knowledge on the go and Tapatalk works pretty well on many other forum sites for me.

Still in the works. In fact, you could say it took a step back b/c I had to kill the Tapatalk integration entirely for the moment. The service was spamming users to buy the app on our site, who upon purchase would realize we didn't have full functionality to comment. Since Tapatalk could provide me no good way to kill the ads while retaining service, we pulled it.

Would love to have TT up and running on the site, but they don't do custom work for custom logins (like our SSO) and I presently don't have a resource to code up a working integration between the two. I love TT though, so it's definitely on the docket, but it's unfortunately a bit shelved at the moment.

Share this post


Link to post

Still in the works. In fact, you could say it took a step back b/c I had to kill the Tapatalk integration entirely for the moment. The service was spamming users to buy the app on our site, who upon purchase would realize we didn't have full functionality to comment. Since Tapatalk could provide me no good way to kill the ads while retaining service, we pulled it.

Would love to have TT up and running on the site, but they don't do custom work for custom logins (like our SSO) and I presently don't have a resource to code up a working integration between the two. I love TT though, so it's definitely on the docket, but it's unfortunately a bit shelved at the moment.

Thanks for the update. I appreciate gbarry's efforts but wish the Tapatalk folks would step up their efforts. EN on Android is such a win, but I do like referencing the forum from my smartphone for knowledge on the go and Tapatalk works pretty well on many other forum sites for me.

I'm on iPhone, do either of you know of any good alternatives? I saw that the IP.Board app in the app store had some pretty negative reviews.

Share this post


Link to post

Haven't read through the whole thread, but I would love to see something sorted out - I get a note that the TT plugin installed on the EN forum is too old to run Board Express. However, if there are major issues with getting the connection to work, I will continue using the desktop version ...

Share this post


Link to post

Haven't read through the whole thread, but I would love to see something sorted out - I get a note that the TT plugin installed on the EN forum is too old to run Board Express. However, if there are major issues with getting the connection to work, I will continue using the desktop version ...

More importantly, TT is still notifying that there's a plugin running on here? Pretty sure we disabled that because it wasn't working with the SSO.

Share this post


Link to post

The message I get is:

Cannot connect to forum

This forum is either restricting access from Tapatalk HD or the installed Tapatalk HD plugin is not working. Please contact your forum administrator.

Share this post


Link to post

Any movement on this?  Tapatalk and evernote together is like peanut butter and chocolate.

And marshmallows.

 

Please, Evernote, we want to be able to access the Evernote forums via Tapatalk (on Android, in my own particular case).

Share this post


Link to post

Any movement on this?  Tapatalk and evernote together is like peanut butter and chocolate.

And marshmallows.

 

Please, Evernote, we want to be able to access the Evernote forums via Tapatalk (on Android, in my own particular case).

+1

:)

Share this post


Link to post

TT doesn't support Single Sign On systems--so this is on the backburner until we can point some resources at building an integration with TT that works with an SSO.

Share this post


Link to post

Any update. I really want to use Tapatalk for this forum.

As gberry says:

TT doesn't support Single Sign On systems--so this is on the backburner until we can point some resources at building an integration with TT that works with an SSO.

So either Evernote has to ditch heir single sign-on feature for the forums (which isn't likely to happen), or Tapatalk needs to figure out how to deal with SSOs.

Share this post


Link to post
Guest

Has TT come back with a solution? They are loosing out on a big forum so I would imagine it is not in their interest to let this go...

Share this post


Link to post

×
×
  • Create New...