Jump to content
saturnine23

windows (Archived) "Session Completed" hang after e-mailing some notes

Recommended Posts

Hi all,

First post. Sorry if this has been asked before, but a quick forum search didn't turn up any results.

I experience a bug in Evernote (Win XP SP3) sometimes when e-mailing notes. (Note that I'm talking about using the "Send By E-mail" feature accessible by hitting the "E-mail" button, or right-clicking on a note and finding "Send By E-mail" under the "Share" context menu.)

Sometimes -- and I can honestly never tell if it's gonna do it or not -- Evernote hangs after the send, with a wide progress bar on the screen that reads "Session Completed". If I close that progress bar (which is in a small window of its own), I find that behind it the original "Send By E-mail" dialog is still open. However, it's not refreshing -- there's usually a big white band of nothing where the progress bar used to overlap. If I "x" out of that window, I get an error box from Windows saying that Evernote has stopped responding. Pressing "End Now" in that dialog kills the Evernote program window, but the elephant icon stays active in the System Tray, and a new Evernote program window opens as normal if I click on the elephant.

Stranger still, even when the "Send By E-mail" feature works correctly, I get a weird glitch. Upon a successful send, Evernote will randomly hand off focus to another program currently running on the start bar. For example, if I had calculator running in the background, then upon hitting "send" in the E-mail dialog box, Evernote would suddenly be backgrounded and calculator, which may have even been minimized, will suddenly pop to the foreground.

I should note that in both of the above cases, the e-mail actually sends successfully, though in the Evernote crash scenario, I have occasionally experienced mild data loss if the autosave didn't write my latest note changes to disc.

Has anyone else experienced this bug? Are the developers aware of it?

Thanks for such an amazing piece of software.

-Dan

Share this post


Link to post

Moved to the Windows forum, you may get a bit more traction there.

It's an interesting enough situation that you may want to file a support ticket (link in my signature). They'll be able to pinpoint the issue and then turn it over to our developers as a bug with some additional information in tow.

Share this post


Link to post

I'm also experiencing this issue - 4.5.2 (although it's been happening for several versions). Win 7, 64 bit. Hangs on "session completed". When you close that box, the email dialog box says "not responding". When you attempt to close the email box, you get an app hang (Close this program?)

-Jeff

Share this post


Link to post

I also have this "session completed" and app hang with Windows XP SP3 and Evernote 4.5.2.5904. I have also had this problem with earlier versions of Evernote too.

When this happens, what should we do? End Evernote task in the task manager? :)

Did anyone open a support ticket yet?

-Rob

Share this post


Link to post

I also have this "session completed" and app hang with Windows XP SP3 and Evernote 4.5.7.7146. The error is intermitant. I have not yet upgraded to 4.5.8.

Was there any resolution when this was posted previously in 2011, early 2012?

I looked in the Windows forum and found no additional mentions of the issue.

Thanks,

Jeff

Share this post


Link to post

I also have this "session completed" and app hang with Windows XP SP3 and Evernote 4.5.7.7146. The error is intermitant. I have not yet upgraded to 4.5.8.

Was there any resolution when this was posted previously in 2011, early 2012?

I looked in the Windows forum and found no additional mentions of the issue.

Thanks,

Jeff

We haven't reproduced this internally, do you know of any specifics that cause the issue or is it random?

Share this post


Link to post

We haven't reproduced this internally, do you know of any specifics that cause the issue or is it random?

 

Used the email function myself today for the first time and experienced exactly the same issue. Note: the email itself sent just fine for me, but Evernote hung and I had to close the window and reopen it from the system tray icon.

 

Evernote 4.6.2.7927

Win XP SP3

Share this post


Link to post

I had the same issue today using XP and Evernote 4.6.1.7860. I have used the email function before and not had this happen. As far as I know, I did nothing differently this time (except the note I was sending had a jpg attachment; I think previous ones I've sent have been clipped webpages). I had to kill Evernote in the task manager and then quit in the system tray, then restart. Which was a pain.

 

However, my email did get sent.

Share this post


Link to post

I have the same problem (Windows 7, 4.6.3.8096), except that the email doesn't even get sent. If I select "CC me on this email", I receive the email, but the actual recipient doesn't, so I have to forward the CCed email. This didn't always happen, but after the first time, it never worked properly again. The first time was a few months ago, I believe, but I may be wrong.

Share this post


Link to post

This has been happening for quite some time now - I first noticed it (and posted, I think) about 18 months ago.  There doesn't appear to be any resolution, obviously.  I did find, unlike @ntrisky, that the email was always sent.

 

Perhaps the issue the developers have had with this issue is that - for me at least - it doesn't happen every time so it must be tricky to replicate.

Share this post


Link to post

The same Problem just now. I've sent an email to add@getpocket.com and now it hangs. 

Windows 8, last version of Evernote. And  there is still nothing in getpocket.

Share this post


Link to post

I see this problem intermittently on my Win XP installation but not Mac or iOS. It doesn't seem to matter who the shared person is or what type of note I am sending--can be text, a graphic, etc.

Share this post


Link to post

Same problem every time on Windows 7 32bit and latest Evernote version. Mail is sent and received ok though.

Share this post


Link to post

I just had this happen as well.  I'm on Windows 7 64-bit.  Evernote version 4.6.7.8409 (268917) Public.  This is the first time I've tried this feature.  Just like everyone else, I received my email, but the "session completed" window hangs and causes the entire Evernote application to become unresponsive.

Share this post


Link to post

The Evernote email feature stopped working completely. After initially sending a few notes successfully, it now crashes every time and will not send the note! Restarting Evernote and even Windows did not improve this.

 

Windows 7 64-bit.  Evernote version 4.6.7.8409 (268917) Public

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...