Sign in to follow this  
Followers 0
Xavier_

blackberry (Archived) Evernote for BlackBerry 3.3 Beta 4 revision 342

14 posts in this topic

Hi All -

We've published a prerelease update to Evernote for BlackBerry v. 3.3.342.


  • [*:2qaf5e3n]notebook and tags not appearing when creating a note fixed
    [*:2qaf5e3n]high battery consumption fixed
    [*:2qaf5e3n]duplicated notes fixed
    [*:2qaf5e3n]added upgrade process form older versions
    [*:2qaf5e3n]added improved messaging
    [*:2qaf5e3n]added localisation in foreign languages

Known issue:

When creating a snapshot or audio note offline, the media won't appear/play if you open the note immediately. however, it will be uploaded, and will appear once synced.

The header syncing process is long and I can observe 2 cycles. It needs to be investigated, but I guess the message may be wrong.

You can download and install the new version from the following link.

Please let us know if you experience any crash, data loss, blocking issue so we can fix it asap.

Thanks for your help, enjoy your beta testing.

BlackBerry v. 5.0 (Bold, Tour)

http://update.evernote.com/prerelease/E ... ernote.jad

BlackBerry v. 5.0 (Storm/Storm2)

http://update.evernote.com/prerelease/E ... ernote.jad

BlackBerry v OS 6.0 Torch 9800

http://update.evernote.com/prerelease/E ... ernote.jad

BlackBerry v OS 6.0 Style and other 6.0.x devices

http://update.evernote.com/prerelease/E ... ernote.jad

BlackBerry v OS 7.0 Bold (and other OS 7.0 devices)

http://update.evernote.com/prerelease/E ... ernote.jad

Share this post


Link to post

I'm using the OS 7.0 version for the Bold on my Torch2. And I'm still running into an old problem. Evernote is saying I have 51 notes but only the latest 10 are shown in the list. The rest are blank slots. And, in a way, the problem is getting worse. Revision 337 showed 12, now it's 10. If I use filescout to browse the Evernote folders on my sd card, I count 15 files, not the 10 or 12 I see in Evernote or the 51 reported as the total.

Space shouldn't be a problem. I have 10 gig free on a 16 gig card, And I have both data service and wifi turned on when I'm at home, so access to the cloud files shouldn't be an issue. How do we fix this?

Share this post


Link to post
I'm using the OS 7.0 version for the Bold on my Torch2. And I'm still running into an old problem. Evernote is saying I have 51 notes but only the latest 10 are shown in the list. The rest are blank slots. And, in a way, the problem is getting worse. Revision 337 showed 12, now it's 10. If I use filescout to browse the Evernote folders on my sd card, I count 15 files, not the 10 or 12 I see in Evernote or the 51 reported as the total.

Space shouldn't be a problem. I have 10 gig free on a 16 gig card, And I have both data service and wifi turned on when I'm at home, so access to the cloud files shouldn't be an issue. How do we fix this?

Hi kraski,

Did you tried to scroll the list to the empty items? Evernote does not load all notes when it shows notes list. First it loads 10 notes and next when you scroll to empty space, it will load next 10 notes.

Share this post


Link to post
I'm using the OS 7.0 version for the Bold on my Torch2. And I'm still running into an old problem. Evernote is saying I have 51 notes but only the latest 10 are shown in the list. The rest are blank slots. And, in a way, the problem is getting worse. Revision 337 showed 12, now it's 10. If I use filescout to browse the Evernote folders on my sd card, I count 15 files, not the 10 or 12 I see in Evernote or the 51 reported as the total.

Space shouldn't be a problem. I have 10 gig free on a 16 gig card, And I have both data service and wifi turned on when I'm at home, so access to the cloud files shouldn't be an issue. How do we fix this?

Hi kraski,

Did you tried to scroll the list to the empty items? Evernote does not load all notes when it shows notes list. First it loads 10 notes and next when you scroll to empty space, it will load next 10 notes.

Yes, I did. But, if one of the features of 3.3 is that a copy of all the notes are supposed to DL to the sd card in my phone, then why wouldn't there be 51 instead of 15? And, if it's working as intended, the list ought to fully populate from the onboard files without my waiting. After 3 minutes, still no change.

Share this post


Link to post
Yes, I did.

Did it show next 10 notes to you?

But, if one of the features of 3.3 is that a copy of all the notes are supposed to DL to the sd card in my phone, then why wouldn't there be 51 instead of 15?

Because if you have not 51 but 5100 notes it will be hard to load all these notes to the note list. It will affect on note list performance. So, we load notes from Sd Card in chunks of 10 notes. It is by design for the moment.

After 3 minutes, still no change.

As I said previously, to see next 10 notes, you need to scroll the list to these empty notes.

Share this post


Link to post
Yes, I did.

Did it show next 10 notes to you?

But, if one of the features of 3.3 is that a copy of all the notes are supposed to DL to the sd card in my phone, then why wouldn't there be 51 instead of 15?

Because if you have not 51 but 5100 notes it will be hard to load all these notes to the note list. It will affect on note list performance. So, we load notes from Sd Card in chunks of 10 notes. It is by design for the moment.

After 3 minutes, still no change.

As I said previously, to see next 10 notes, you need to scroll the list to these empty notes.

OK. I guess I was unclear. I scrolled to the first set of blank listings, let the phone sit there, gave up when nothing happened after 3 minutes. Most of my notes are not that long. Even if it downloaded in 10 note increments, it shouldn't take that long to display. And perhaps I misunderstood the intent of local storage. I thought someone had said that the idea was to allow access to all notes even if data and wifi access was unavailable. Has that changed? Perhaps based on some unforseen limitations?

Share this post


Link to post

Kraski,

This is most likely a bug. We'll look into that, thanks for reporting the issue.

Share this post


Link to post
Kraski,

This is most likely a bug. We'll look into that, thanks for reporting the issue.

Just an update. I logged out, waited, then logged back in. I let the db repopulate, waited 10 minutes while it was doing that, then went into the notes list. After the first 10 showed, I scrolled down to the next batch. I got diverted so it was 15 to 20 minutes before I looked again. The next 10 still hadn't displayed. The logs have been sent.

Bill

Share this post


Link to post
Kraski,

This is most likely a bug. We'll look into that, thanks for reporting the issue.

Just an update. I logged out, waited, then logged back in. I let the db repopulate, waited 10 minutes while it was doing that, then went into the notes list. After the first 10 showed, I scrolled down to the next batch. I got diverted so it was 15 to 20 minutes before I looked again. The next 10 still hadn't displayed. The logs have been sent.

Bill

Update #2. I just got a message box thanking me for sending in the log. It's 10:30am my time 10/18. I sent the logs about 14 hours ago. And where I was still having display issues, that has suddenly cleared up and I'm getting everything displayed in increments of 10 notes. So, I'm now leaning toward the issue being server side or some residual from RIM's BIS outage. If the problem returns, I'll let you know.

Share this post


Link to post

I'm seeing the same behavior here. I did a search for a term which resulted in 22 hits. It's filling in the blanks in chunks of 10, and I can see that it's transmitting data, but it's taking forever for the last two lines to fill in. Since it has to rebuild the cache every time I log in to the app, and it takes so long to build the cache, maybe caching wasn't such a good idea? ;-) :-P

Share this post


Link to post
Kraski,

This is most likely a bug. We'll look into that, thanks for reporting the issue.

Just an update. I logged out, waited, then logged back in. I let the db repopulate, waited 10 minutes while it was doing that, then went into the notes list. After the first 10 showed, I scrolled down to the next batch. I got diverted so it was 15 to 20 minutes before I looked again. The next 10 still hadn't displayed. The logs have been sent.

Bill

Update #2. I just got a message box thanking me for sending in the log. It's 10:30am my time 10/18. I sent the logs about 14 hours ago. And where I was still having display issues, that has suddenly cleared up and I'm getting everything displayed in increments of 10 notes. So, I'm now leaning toward the issue being server side or some residual from RIM's BIS outage. If the problem returns, I'll let you know.

I'll take that back. It worked as expected once, then back to not working right several hours later.

Share this post


Link to post

@kraski,

We are working on your case. For now, can you try this to change your network connection type:

1. go to menu\setting, change network connection from "Automatic" to other type, like wi-fi.

2. menu\sync again and see if your notes're showing up

Thanks

Ah Fan

(P.S. in addition, in order to have the note fully downloaded into your phone, you need to open that note first. It may take long the first time but it will be very fast the second time to open it. Give it a try)

Share this post


Link to post
@kraski,

We are working on your case. For now, can you try this to change your network connection type:

1. go to menu\setting, change network connection from "Automatic" to other type, like wi-fi.

2. menu\sync again and see if your notes're showing up

Thanks

Ah Fan

(P.S. in addition, in order to have the note fully downloaded into your phone, you need to open that note first. It may take long the first time but it will be very fast the second time to open it. Give it a try)

I tried each setting, only automatic gets what appears to be a successful sync. I even tried resetting the phone between syncs. Where I have my wifi router located, I'm never more than 15' from the signal source. So, automatic and wifi should both have worked well. Data can vary, so I'm not surprised that TCP/IP and BIS were problems at close to the same time. And, in all cases, still only the first 10.

Share this post


Link to post

@kraski,

We have updated the behaviour for note loading in the new release available soon on the App World.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0