Jump to content
luckman212

windows (Archived) BUG: notebooks menu in Search Explanation Toolbar

Recommended Posts

He's back! Your favorite Coleoptera!

EjSsm.png

Fogbugz ID# 291412

Starring in: Switching Notebook from "All Notebooks" to a specific notebook via Search Explanation Toolbar does not actually update results

(tested with Win v4.5.1.5352.173426 Public)

repro:

-make any basic search e.g. "tag:foo tag:bar"

-save this search

-select "All Notes" to reset the search

-now, click to run the saved search

-now, via the "notebook" drop-down menu in the Search Explanation toolbar, choose another notebook

bug:

the drop down menu will not "stick" with your selection, and the search results are not updated.

extra credit strangeness:

-on the left hand panel, the notebook selection will appear to have changed, but it actually hasn't

-selecting another notebook A SECOND TIME will actually do what it's supposed to do

Share this post


Link to post

This should be fixed in the upcoming release.

Thank you for reporting!

/Peter

Share this post


Link to post
You mean in the 4.5.2 release? Which release is this fix targeted for?

Any release with revision 176956 or higher.

/Peter

Share this post


Link to post

Appears to work correctly in 4.5.1.5396 prerelease. Thanks, Everfolks.

Share this post


Link to post

This is NOT fixed -- who closed this bug as fixed? Did anyone actually test it? I'm on 4.5.1.5432 (194665) and it behaves exactly as before.

Share this post


Link to post

YES, I tried YOUR EXACT SCENARIO, and IT WORKS. Just like IT WORKED the LAST TIME I TRIED IT.

[attachment=0]images.jpg[/attachment]

Now running Version 4.5.1.5427 (178863) Prerelease.

(BTW, did you look at your saved search to see whether the notebook was specified in it?)

Share this post


Link to post

Bump -- this bug is still not 100% fixed as of 4.5.2.5568 Public. While my original step by step is working, this slightly modified one is still broken:

repro:

-make any basic search e.g. "tag:foo tag:bar"

-save this search

-select "All Notes" to reset the search

-now, click to run the saved search

-now, via the left-panel navbar, click on a different notebook (e.g. anything besides "All Notes")

bug:

the notebook you clicked on will not "stick" with your selection, and the displayed search results are not updated properly.

Clicking AGAIN on the notebook seems to do what you had originally wanted.

Share this post


Link to post

The same happens to me.

I'm running Evernote for Windows 4.5.2.5798 (205835) Prerelease.

1.) Run a saved search

2.) To select a new notebook requires two clicks.

The first click puts red dotted lines around the selected notebook, but the results are actually all my notes

The second click actually pulls the correct notebook's notes.

I don't notice this because I keep the Left Panel hidden (F10) most of the time.

Share this post


Link to post

Bump -- this bug is still not 100% fixed as of 4.5.2.5568 Public. While my original step by step is working, this slightly modified one is still broken:

repro:

-make any basic search e.g. "tag:foo tag:bar"

-save this search

-select "All Notes" to reset the search

-now, click to run the saved search

-now, via the left-panel navbar, click on a different notebook (e.g. anything besides "All Notes")

Clicking on a notebook in the left panel in this case should just reset the filter to all notes in that notebook. If you want to apply the search parameters to a different notebook, you need to select a notebook from the notebook dropdown that lives on the Search Explanation panel underneath the search control.

Share this post


Link to post

Jeff that's fine but then clicking on a "baz" notebook on the left after running the "FooBar" search should switch to the "baz" notebook and remove any search params- effectively showing all notes in the "baz" notebook. What EN does now instead is very counterintuitive:

-the first click is basically ignored, although it does reset the search back to "All Notes"

-the 2nd click does what you expect it to do

Share this post


Link to post

img10.png

Is this on the radar to be fixed? I don't know how much more clearly I can spell it out. My post #11 above details the exact step-by-step to reproduce this annoying bug. Another bug that has gone almost a year and a half without being fixed. Just tested it again on 4.6.1.7860 and it's the same as before.

Share this post


Link to post

I still don't see a #11 as a bug -- the behaviors appears to be by design, and it makes some sense. Clicking in the left notebook panel sets the search context (notebook, stack, All My Notes, Business notebooks or All Notebooks), and otherwise clears any search criteria (tags, text search, updated date, etc). If you want to keep the same search criteria and change context, then you do it from the dropdown in the search info pane. Both operations are useful. Since it's by design, it's not a bug.

I don't see the behavior described in #14: I run a saved search, or just type a search into the search info control, and then click on a notebook (or stack or whatever) in the left notebook panel, and it does what I describe, on the first click.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...