Jump to content
cjdeheer

mac (Archived) BUG: Local Mac DB always shows wrong search results

Recommended Posts

I've had this problem regularly, and the only solution seems to be to remove my /Library/Application Support/Evernote folder and redownload my entire Evernote db.

Here's what keeps going wrong: The number next to each tag shows the correct number of matching notes, but when I click on the tag (with All Notebooks selected), the actual number of displayed notes is lower than the number of matching notes. When I log in to the Web client, everything works as it should.

It's crazy making to not be able to trust that Evernote is showing me all the notes it's supposed to. I've contacted tech support, and removing the local db is the only solution they have to offer me, but since the problem always recurs, it has to be a bug.

Anyone else having this problem?

Share this post


Link to post

I've had the same problem. It's been mentioned before in this thread: Search function not working properly.

I haven't seen any response from Evernote employees, but I think they read all the threads even if they don't comment, so I hope it'll be fixed in an update soon.

Share this post


Link to post

You may want to file an Evernote support case for your issue.

I make extensive use of tags and just tested the actions you described.

In all cases EN worked correctly for me, showing the same number of Notes when I click on a tag as the number shown in parenthesis beside the tag.

I am running the latest Mac beta: EN Mac 2.2 Beta 3

Mac OS 10.6.7

MacBook Air

So there may be something specific to your setup/install that is causing the problem.

I have found the EN support team to be very prompt and helpful.

Good luck.

Share this post


Link to post

EN Support confirmed that there is a bug. For me, it was just a couple of notes that weren't showing up. I found them in the web EN, made a small edit (like adding a blank line at the end) and after syncing, they showed up again in the Mac EN app. It's not ideal, but might work until the bug gets fixed.

Share this post


Link to post

Changing the notes in web EN does in fact make them show up in Mac EN after syncing. But this is such a pervasive problem for me that it's not a practical solution. EN support said they are aware of the bug and thought it was corrected in the most recent release (v2.2.1), but I'm continuing to have the problem, even after totally uninstalling EN, removing my local EN folder/db, reinstalling, and then syncing from the web. At that point, everything works fine, but as I add or re-tag notes, the problem creeps back for any notes created or modified since recreating the db.

Ugh.

Share this post


Link to post

I'm *still* experiencing this bug, and it's a totally crippling problem. I have some tags that I use daily for a GTD workflow (waitingfor, toread, todo, etc.), and I'm only getting partial results when I search on any of those tags. Obviously, seeing a partial list of my to-dos renders the workflow useless.

Evernote, please fix this bug!

Share this post


Link to post

I'm having the same issue. This is an urgent problem that renders tagging in Evernote essentially useless. This needs to be set as a top priority and fixed immediately.

Share this post


Link to post

This bug really limits the functionality of Evernote. I have a lot of notes and rely on being able to tag and search to find them. I agree that this should be set as a top priority. (If new features are shipped before this bug is fixed I would be pretty annoyed.)

Share this post


Link to post

Does anyone know if there's an ETA for fixing this issue? I know the Evernote team is busy working on the Lion version and new Safari extension, but for the vast majority of us still using stable software, having just the basic Evernote functionality working is a top priority. Hope to see this issue fixed soon.

Share this post


Link to post

How disappointing!

This critical bug has been around for months and the latest release (3.0.0) apparently still does not fix it. I even wiped out my database to download it again, but for no avail. Notes added after syncing may not show up in searches.

Look, Evernote, the new features in your latest release are nice candy. But nobody cares about candy if your product does not satisfy its basic promise. And that is, we actually want to be able to find notes we entered. If this cannot be done reliably, your system is useless.

As a paying customer (paid in full for a year - bad idea!) and also having mailed your support about this issue a long time ago, it's fair to expect that critical bugs are fixed within reasonable time. I'm afraid, but if I don't see a follow-up release within the next three weeks that addresses this particular issue, I will switch away from Evernote and not recommend it for further use. Do you really want us to refer to your product in reviews as Neverfind? It's just scary to entrust important data to an unreliable medium!

Share this post


Link to post

I just raised this issue again internally. I believe upgrading to the latest version had fixed this for some users, but clearly not all.

Share this post


Link to post

It didn't fix it for me, either. It's mind boggling to me that a product whose core promise of value is making notes searchable can't find notes -- after several MONTHS.

Share this post


Link to post

In this particular case, it seems like there may be several causes for the same issue to occur. The good news is that this isn't happened to all of our users, and the problem is getting smaller, not bigger.

So while we've reduced the number of issues with new releases, it looks like there might be a few outlying issues that that we still need to delve into.

Share this post


Link to post

I'm *still* having this problem. Unbelievable. I use Evernote in my business, and it's a serious problem that Evernote only provides a partial list of results.

Share this post


Link to post

Responded to you in the 3.0.3 RC thread. We're taking another look at it, but may need your activity logs again.

Share this post


Link to post

Incredibly, this problem is *still* happening in v3.1.0 beta 1.

I removed any remnant of Evernote from my computer (i.e., user library > Application Support > Evernote, plist files, application) and then reinstalled and downloaded fresh database. Then I assigned a tag to a note and moved it to a different notebook. When I go to that tag, the number next to the tag is 34 and the number of displayed notes is 33. Aaargh!

To convey the seriousness of this problem, imagine you collect all your tax documents in Evernote, and while gathering documents for your accountant, you search tag:tax tag:2011 -- and Evernote only shows you *some* of your notes, without your even realizing there is missing information. Not good, right?

Share this post


Link to post

I discovered a new twist on this bug. I did a search in Evernote Mac for -tag:* to find all untagged notes, and I got 139 results. Most of them are untagged, but several of them do have tags. I had just recreated my entire local database 3 days earlier. When I perform the same search at Evernote Web, I get the exact same number of results, BUT MANY OF THE NOTES ARE DIFFERENT FROM WHAT EVERNOTE MAC FOUND! So apparently there are in fact 139 untagged notes, but Evernote Mac displays a different group of notes (most of them are the same, but many of them are different).

How is it possible that one release after another occurs, but such a fundamental problem doesn't get corrected?

  • Like 1

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...