Jump to content
pmanrubia

mac (Archived) Can't synchronize notes: content is not valid

Recommended Posts

I have a problem when synchronizing new notes: I get the following message: Content is not valid.

I'd appreciate any help

Thanks in advance

Share this post


Link to post

Crazy!

Setup: Evernote 2.0.5, Mac OS X 10.5.8

* I have a note that is all "text", created purely in Evernote and some cut paste from Coda or terminal. Character count is 947 characters.

* I started getting the synch error, with note of "content is not valid".

** error example: http://www.trufflelabs.com/sites/www.trufflelabs.com/files/EvernoteError-ContentIsNotValid.png

* The key line in the activity log of note is:

** 2011-03-17 09:13:44 0x188f82d0 [ENAppController] ERROR: EXCEPTION: EDAMUserException(errorCode:11,parameter:"Error processing document: Invalid a href attribute:(null)")

** The item that caught my attention is "Invalid a href attribute:(null)"

I deleted my note, synched, then line by line recreated the EverNote note.

* The line that caused the issue is

** 'AltDelicious' => 'http://delicious.com/tag/%s',

** This is a line from from a Drupal Tattler PHP file that I was capturing for some notes.

Actually, what seems to cause the issue is not the characters in the line but the action that put the line into the EverNote note.... If I cut and paste the line from Coda or TextEdit, EverNote inserts the line and parses the link into a hot link. EverNote reports an error since the http reference (the link) in the line is not valid.

If I hand type the line (not cut/paste) then EverNote is not parsing the line and the synch works just fine.

Steps to fix this type of issue

* Synch note

* On report of "content is not valid" error look at the activity log.

* If the log reports "Error processing document: Invalid a href attribute:(null)" then look for links in the note.

* Right click on link and select "Link>Remove"

* This will make the link just plain text (not an active link)

Observation

* The Paste Without Formating function does not insert links without formating; ie, EverNote still parses a pasted link and sets it up as an active link within the note.

Share this post


Link to post

Thanks for the report, I have reproduced this error with the odd URL pasting, and filed an internal bug.

Share this post


Link to post

I have been experiencing the same issue for the past few weeks... Manly on my iphone and ipad...

Have been using Evernote since 2009 and this is the first time the tool is becoming truly annoying...

Is there a resolution yet?

Share this post


Link to post

I have been experiencing the same issue for the past few weeks... Manly on my iphone and ipad...

Have been using Evernote since 2009 and this is the first time the tool is becoming truly annoying...

Is there a resolution yet?

You may have the same error, but it may not be the same problem/cause. You should open a support request -- see the link in my signature.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...