Jump to content
romelden

ANSWERED Is Evernote ready for macOS Catalina?

Recommended Posts

Hello EN team,

We (most of the EN users) are really suffering from Evernote in the last 2 macOS upgraded.  Even this Safari upgraded.  Actually, Apple announced stopping 32 bit apps support years ago.  But YOU did nothings.  And how about this Catalina upgrade?  Will it missing some functions, or missing pdf attachments again?  What is the beta release from Apple for?

Please noticed that Evernote no more the unicorn of note taking apps anymore.  STOP disappointing those users still standing with you. 

Steven

  • Like 2

Share this post


Link to post

Catalina released. But EN team do not have any official announcement on this.  
Am I safe to use my evernote after my Mac upgrade?

Share this post


Link to post
1 hour ago, romelden said:

Catalina released. But EN team do not have any official announcement on this.  
Am I safe to use my evernote after my Mac upgrade?

No Evernote issues with Catalina (so far)

Some extensions were dropped with the Safari upgrade, including the Evernote Web Clipper

Share this post


Link to post

My MAC just did the Catalina upgrade. When I open Skitch and do a crosshair screenshot, it takes a picture of my screensaver image not what I've crosshaired. Anyone experiencing this or know how I can fix it? Thx!

  • Like 1

Share this post


Link to post

When I cross-hair something on my screen to save the image, Skitch is taking an image from my second monitor of my screen saver image, not what I have cross-haired. Does anyone know how I can fix this?

I just figured out that it's a permission setting in Settings! Fixed.

Share this post


Link to post

Once I updated to macOS Catalina, and I tried to use Skitch, it now does not allow me to take a screenshot of anything but the desktop. Is this some weird permission issue?

Edited by Ustice
Accidentally sent without finishing

Share this post


Link to post

Found the fix!!! 

 

Update security and privacy, screen recoding and allow Skitch .. Phew, thought I had lost my favourite Mac tool

Update 

 

 

Share this post


Link to post

After a day of using after upgraded, EN seem ok and no big problems (not every feature used or check). Hope it will be okay. 
I am using EN in China (Don’t ask me why don’t use China version), but there is many problems. For e.g., template cannot be saved or get. And ever the web version, the password field didn’t pop up after input username at user page. 
Hope it can be fixed in future. 
 

thanks

Share this post


Link to post

Hi @dianeincanada I have the same problem currently - but I can't see where to change permissions. I can't find anything under System Preferences -> Extensions. Please let me know where you  changed your permissions. Thank you.

Screenshot_11_10_19__12_41_am.jpg

Screen Shot 2019-10-11 at 12.42.59 am.png

Share this post


Link to post

Replying to myself here as my post got moved and I couldn't find it. I followed the instructions and it fixed my problem

Share this post


Link to post

Hello, I am unfortunately unable to click on the Skitch app under screen sharing and have re-downloaded Skitch four times. Any suggestions? I am unable to take any screenshots, when I select "Screen Snap" in Skitch, nothing happens; I do not see the desktop or anything.

 

I just upgraded to Catalina as well.

 

Thank you!

F3427940-3C8F-4C79-B0F3-CCE4B9B49A74.jpeg

Share this post


Link to post
23 hours ago, jfrenette196 said:

Hello, I am unfortunately unable to click on the Skitch app under screen sharing and have re-downloaded Skitch four times. Any suggestions? I am unable to take any screenshots, when I select "Screen Snap" in Skitch, nothing happens; I do not see the desktop or anything.

 

I just upgraded to Catalina as well.

 

Thank you!

F3427940-3C8F-4C79-B0F3-CCE4B9B49A74.jpeg

Following this - my issue as well!! 

Share this post


Link to post

Skitch is working for me under Catalina:

  • Downloaded from the EN website
  • Logged into my account, which created a Skitch Notebook in my Evernote. But it did not show in the systems settings security page. So I tried something:
  • I closed Skitch and moved the apps icon from Downloads (where it had stayed) into the Programs folder of my Mac. Reopened, then (!) it showed in system settings, security.
  • In system settings of Catalina, in Securitiy I authorized Skitch as posted above by Shane. To allow this, the lock has to be opened (admin user), and Skitch has to be closed temporarily.

Initially Skitch did not show, which was caused by the fact that it stayed in the Downloads folder. Maybe this is because it is not delivered as a DMG-file, it is a ZIP. When you open it, the app starts, but is not transferred to the Programs folder.

  • Like 1

Share this post


Link to post

When I go to the System Preferences and Security & Privacy and then it asks you to select the apps or sw you would like to enable to screen record. I do not have any items popup in that window. 1820668771_ScreenShot2019-10-25at11_02_33AM.png.e60fd5d6353d0c1993818b7d48835908.png

Share this post


Link to post

I upgraded to Catalina yesterday, and the Evernote app will not open. I click the dock icon, the icon bounces for a while and then stops. 

  • Activity Monitor shows Evernote used 0.01 CPU seconds, and there is no current activity.
  • Click and hold the dock icon. The popup menu says "Application not responding" and offers a Force Quit option.
  • I've tried twice from the dock, and went to the app store and did an Open from there with the same result.
  • I have EN version 7.13 installed, which I believe is the latest version.
  • All other apps are working correctly, except for mSecure, which has exactly the same problem.

Any suggestions would be appreciated. I am using the web version for now.

  • Like 2

Share this post


Link to post
44 minutes ago, Jack Madomo said:

I upgraded to Catalina yesterday, and the Evernote app will not open. ... Any suggestions would be appreciated. I am using the web version for now.

Is this the app-store version, or direct download   
I have no problem with the direct direct download

I don't spend a lot of time troubleshooting my devices   
My ultimate solution is to delete the app, database, ...associated files    
then reinstall.  The app AppCleaner is recommended for this

Share this post


Link to post

Thanks for responding. I solved my problem.

I had the app store version so I just moved the app to the Trash and re-downloaded it from the App Store. It started and connected to the database with no problem.

I had quit the app before I upgraded the OS, so I'm not certain why the existing version wouldn't open. But I'll file that with all the other unresolved mysteries of daily life.

Share this post


Link to post

We should all keep in mind that Apple is delivering Catalina updates without counting the OS index up. It is still 10.15 for me, but I know from contacts to Apple support that they have upped the OS to fix some issues.

So maybe meanwhile one of this minor OS fixed installed, and helped solve some problems.

Share this post


Link to post
18 minutes ago, PinkElephant said:

Apple is delivering Catalina updates without counting the OS index up

I was wondering about this; my Mac updated yesterday from 10.15 to 10.15   
On the plus side, the update ran quickly with no issues 🙂

Share this post


Link to post

Yes, it seems to be no full downloads, but snippets of code that fix something. Even the support guys could not check whether it had loaded, they asked me to restart with cmd-r to rebuild the OS instead.

Share this post


Link to post
18 hours ago, Jack Madomo said:

I upgraded to Catalina yesterday, and the Evernote app will not open. I click the dock icon, the icon bounces for a while and then stops. 

  • Activity Monitor shows Evernote used 0.01 CPU seconds, and there is no current activity.
  • Click and hold the dock icon. The popup menu says "Application not responding" and offers a Force Quit option.
  • I've tried twice from the dock, and went to the app store and did an Open from there with the same result.
  • I have EN version 7.13 installed, which I believe is the latest version.
  • All other apps are working correctly, except for mSecure, which has exactly the same problem.

Any suggestions would be appreciated. I am using the web version for now.

I'm having EXACTLY the SAME problem! :( HELP!

 

Share this post


Link to post

Catalina is much stricter with security and certificates than the previous OS versions.

So maybe you can find an issue when checking the Macs system preferences, especially the security settings. One thing could be the allowance to read/write the systems disk drive.

If not, the best way is probably to completely uninstall the EN app, using the AppCleaner app. Make sure you check everything related to EN.

Then restart the Mac, and reinstall EN using the version directly from the EN website. After it is on your Mac again, log in and sync your notes back from the EN server.

Caution: If you have local notebooks, they will be lost when doing the uninstall. If this is the situation, maybe you have to roll back to Mojave, export your local notebooks into an ENEX file and try it again.

P.S. I have upgraded to Catalina, no problem, reinstalled the WebClipper, no problem ... sometimes no one can tell what works, and why.

Share this post


Link to post

PinkElephant,

Permissions may have been the issue. Remarkably when I upgraded to Catalina, EN Web Clipper was installed on Safari and worked fine, but I believe it doesn't store anything locally. When I trashed the installed version of EN and downloaded a fresh copy from App Store the permissions would have been handled behind the scenes.

 

Share this post


Link to post

Maybe it is it - fortunately it needs permissions only once per app.

From my observation, permissions for some apps are asked for actively, whereas for other apps there is no such request. They simply stop working.

When you check, you find the app, but the checkmark next to it is missing. When checked off, and sometimes after a restart, things go back to normal.

Share this post


Link to post

Hi all,

it looks like that after getting the newest iOS, my Evernote (7.13, latest) doesn't reflect to system Dark mode. Is there anyone who realized something similar? 

Regards,

Akos

Share this post


Link to post

Thank you for this thread.  However, it is not easy to follow for average computer users.  

1. What the heck is skitch?  is this the web clipper?  The name of the elephant?  *edited to add:I figured this out: it's another app/extension for evernote.  Please make it clearer to anyone with my issue with the safari evernote clipper itself.  It was only clipping the the desktop picture.  I did see pop ups for the extension asking for permission to access the screen and these were checked. There was no mention of having to dig into settings to make the extension work properly.  Also the lovely elephant next to the address bar that could provide even more value to me (clipping articles without the sidebars) was not showing.

2. As directed here, I went to settings>privacy and security>screen recordings and only evernote showed as requesting permission.  Once I clicked that, (and closed and opened evernote) the safari clipper worked!!!! 

3. Please PIN THE EVERNOTE STAFF SOLUTION to the top of thread!!

Cheers

Edited by WriterOrganizing
figured some things out after posting

Share this post


Link to post

Skitch is a tool to annotate pictures and pdf files. It used to be an independent app, but was taken over by EN and sort of integrated into EN.

Web Clipper is a tool to draw content from the web and save it as a EN note.

With MacOS 10.15 Catalina many apps need to be  authorized again or newly to make them work. This is due to the stricter security settings that come with Catalina. I think in an environment with new threats is is good than Apple is locking up the OS. I am nearly through with allowing all that is to be allowed, things are becoming quiet and performance is back.

Share this post


Link to post

Found that Web Clipper for Safari can be download from App Store.  

It work ok.  Still looking for a new function, capturing the hold webpage...... just like the new screen capture function on iPhone.

Thanks.

Share this post


Link to post

Evernote crashes 100 percent of the time on Catalina for me. No response from support on my ticket.

Share this post


Link to post

@ArneG Did you try to completely uninstall (with AppCleaner) and reinstall from scratch ?

EN will then rebuild the database from the server. Take care to make backups of all local notebooks, because they will not be on the server copy.

Share this post


Link to post

Here is a list of what I've done:

  • I'm on a fresh install of Catalina
  • Installed
  • Uninstalled - deeply
  • Reinstalled from app store
  • uninstalled -deeply
  • reinstalled from web download
  • in all cases when I first start the app it loads until I enter my credentials - then hard crash as it tries to sync
  • If I disable all network connections it loads until I re-enable network - then hard crash again.

Round and round.  

Share this post


Link to post
37 minutes ago, ArneG said:

Uninstalled - deeply

What's involved in "Uninstalled - deeply"

Share this post


Link to post

Has anyone figured this out?  I'm on 10.15.2 and EN 7.13, and it crashes as soon as I log in and it commences the sync.  Looks like this has been a problem with Catalina for months. I wasn't having the issue on my prior MBP with Catalina but on my new MBP 16" it's been a no-go regardless of what I try, including multiple reinstalls.  Really frustrating and I've seen no indication that Evernote is aware of or doing anything about it. 

  • Like 1

Share this post


Link to post

With my installation (Catalina 10.15.2) on my MBP 15, no issue at all. I don’t think it dislikes running on a shiny new 16“.

First I would do a complete uninstall of the EN app using AppCleaner. There are files further down the list that are not checked by default - I had problems I uninstalled once (under Mojave) when I did not check these for uninstall as well. Warning: All local notebooks will be deleted as well, so make a backup before (if you have any).

Then restart the Mac, and reinstall, using the version from the EN web site.

https://evernote.com/intl/en/download

The version from the AppStore should be the same, but it runs on the Mac in a sandbox, which created problems when I used it.

After installing, grant it all the rights needed in Catalinas security / privacy settings. Good luck.

Share this post


Link to post

Thanks. Yes, I've done the full uninstall and reinstall a few times, trying both the AppStore and, most recently, the website version.  I use Clean My Mac to full uninstall, which I have to believe cleans everything out just as deeply.  

Do you know exactly what rights it needs?  I see that it already has Files and Folders access (documents folder) from the install, but should there be anything else?

Share this post


Link to post

Oh - hmm. Normally it should ask and get everything it needs on installation.

If you go to the Privacy and security settings in the Macs system settings, and to the rightmost tab, there are several categories in the left column, and in each position it shows the related programs allowances in the right column. Click on each of the categories in the left one, and check all in the right one. I have restricted some other apps, but with EN, Skitch and the Web Clipper I have checked all and every entries. WebClipper settings are in the Safari settings, but it works the same.

Are you running any sort of additional security software on your Mac, like Anti-virus or extra Firewalls ? I once tried Kaspersky on my Mac, but it created nothing but hot air (from the fan when pushing up system load), so I uninstalled it - which in itself is no easy operation. This sort of SW can really mix things up.

Share this post


Link to post

That's an excellent point.  I just switched from Sophos to Avast, and Avast was messing with my email app.  When I get home I'll try turning off Avast. 

When I install EN, I get no security requests. That file access just happened on its own.  If Avast is not the issue, I'll add EN to the other security categories, though they mostly seem unnecessary, like screen monitoring, at least without Web Clipper, Skitch etc. being used. But certainly worth a shot. 

Will report back once I've tried these fixes.  Thanks.

Share this post


Link to post

Thanks for getting back on this.

The only security software Apple itself says will not interfere is Malwarebytes.

Antivirus software on the Mac creates more problems than it may prevent. After my Kaspersky-Experience I have read about the issue. Because Security software needs root access, it opens a new, severe risk on the Mac. Root access is normally closed for all apps except system-only. This may be even more true with Catalina, where the System partition on the disc is specially protected, set to read-only unless the system itself updates.

Share this post


Link to post

Very interesting and good to know.  Really hoping that Avast is the problem and will happily delete it if so!

Share this post


Link to post
On 11/10/2019 at 10:04 AM, DTLow said:

What's involved in "Uninstalled - deeply"

Dr. Cleaner Pro full uninstall - wipe all residual files and junk.

Reboot

 

  • Thanks 1

Share this post


Link to post
On 12/12/2019 at 12:45 AM, PinkElephant said:

With my installation (Catalina 10.15.2) on my MBP 15, no issue at all. I don’t think it dislikes running on a shiny new 16“.

First I would do a complete uninstall of the EN app using AppCleaner. There are files further down the list that are not checked by default - I had problems I uninstalled once (under Mojave) when I did not check these for uninstall as well. Warning: All local notebooks will be deleted as well, so make a backup before (if you have any).

Then restart the Mac, and reinstall, using the version from the EN web site.

https://evernote.com/intl/en/download

The version from the AppStore should be the same, but it runs on the Mac in a sandbox, which created problems when I used it.

After installing, grant it all the rights needed in Catalinas security / privacy settings. Good luck.

I've done all of these steps - multiple times.  No joy.  

At this point I think I'm going to have to find a way to extract all my notebooks and find a different solution.  

Share this post


Link to post

AmeG, are you on a new 16" MBP as well by any chance? And are you running any anti-virus?

Share this post


Link to post

No.  I'm on a 15" MBP - Early 2013 - Running Catalina - fresh install. AntiVirus One installed but not running - or running - doesn't make a difference.

Screen Shot 2019-12-13 at 9.16.51 AM.png

Share this post


Link to post

Thanks for the suggestion - just tried this approach - No Joy.

 

 

 

Share this post


Link to post

Currently I am running out of ideas.

Any chance to try Apple support ?

Another option would be to go for 1 month on EN Premium, thus being able to get their support to work on this.

Share this post


Link to post

Here is another answer from the forum (Nick is EN staff), but this is related to clean out a prior beta installation of EN. Click to read the full posting:

 

  • Like 1

Share this post


Link to post

Thanks PE! I went to that thread and figured I should specifically use AppCleaner instead of Clean My Mac so that I could see the potential deletion folders discussed in the thread.  Did so and made sure to select all the unchecked folders (which were the same as Nick's screencap).  I then simply reinstalled using the 7.14 beta (if it makes a difference - it didn't when I just tried using it instead of 7.13 without using AppCleaner) and IT WORKS AGAIN!  You rock.  Much appreciated for all your suggestions. 

ArneG, hopefully this works for you as well.

  • Thanks 1

Share this post


Link to post

Okay, also new to my Catalina and new computer experience is that I suddenly have a notification badge (red 1) on EN in the dock that I cannot get rid of for the life of me.  I've never had a badge on EN before. I don't use reminders.  Any idea whether this is just a 7.14 bug?  Thrilled to have EN back but man badges trigger me!

Share this post


Link to post
21 hours ago, PinkElephant said:

Currently I am running out of ideas.

Any chance to try Apple support ?

Another option would be to go for 1 month on EN Premium, thus being able to get their support to work on this.

Figured it out - I logged into the web version and reviewed all settings and noticed that under connected services I have the google one sign-on enabled but I'd been signing on with my original username (my gmail address) and password.  So I went off wifi and logged out - reconnected to wifi and logged in with google and no crash.

Seems stable so far.

 

  • Thanks 1

Share this post


Link to post

Great to hear, ArneG.  

As for my badge issue (again, on 7.14 beta), a note to anyone else who runs across this that I seem to have gotten rid of it by closing the app, removing it from the dock, and restarting. That was a weird one.  Notifications were even turned off for EN and EN Helper.

 

  • Thanks 1

Share this post


Link to post

Not sure why I'm the only one who upgraded to Catalina and can't even OPEN evernote. When I try, I get a popup that says "Evernote needs to be updated. The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information."

 

Share this post


Link to post

If this would be true, the forum would be full of posts like this, and I would be running ghostware on my Mac.

Where did you get your installer from ? There are 2 sources: 1) The official Mac AppStore 2) The direct download from the EN Website. Both versions are identical, but I recommend the direct download. The version from the AppStore runs in a sandbox which causes problems.

If you get the said warning, you are likely trying to install an older version with 32bit-code. They may be available  for Mac users still on older OS versions, but will not work with Catalina. So make sure you get the latest version.

Share this post


Link to post

 I had this problem and it was sql lite related.
Go to Users/<user>/Library/Group Containers and delete the *****.evernote.***** folder.
It will kill the settings you have, but the notes will be reloaded upon next launch

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...