Jump to content
  • 0
Iriska

Evernote for Windows 6.21 GA

Idea

Today we released Windows 6.21 GA. It's available here!
 
What’s in 6.21 GA?
Fixed:
- If you opened a notebook by double-tapping your touchscreen, all the notes in it would be duplicated. Admittedly this was a bit of an overreaction, so we fixed it.
- The app was changing some characters in your hyperlinks, which meant they wouldn’t work on other Evernote clients. But it should be smooth surfing now.
- In Work Chat, names with Japanese and Korean characters would sometimes be changed to Kanji or question marks. That was no help to anyone, but thankfully    it’s a thing of the past.
- We took care of a few other issues that were causing the app to crash.

Share this post


Link to post

41 replies to this idea

Recommended Posts

  • 1

Evernote, do I understand it correclty????

You are fully aware that the beta crashes and still, you are releasing it as GA!!!!

This is a total disrespect to your users, not to mention, that you are even not checking the fact, that the links originally points to a previous version. Do you call it QA???

That's a shame.

Share this post


Link to post
  • 1
3 hours ago, Dave-in-Decatur said:

What AndreasM said:

What Iriska, speaking for Evernote said (with relevant line highlighted):

So, no, Andreas, that would be the exact opposite of what Evernote is saying. That is a shame.

In the post by Don Dz following Iriska's post, Don Dz says:

"The crash I reported above, I can now reproduce consistently, all it takes is to type quickly the following key combinations at the note list:  Ctrl-A, Alt-F, then E once or twice. and more....."

So what crashes did they fix???

It is a shame, that I as premium user paying for the subscription more than for MS Office 365 am still on version 6.7.6 because I don't trust Evernote.

Share this post


Link to post
  • 1

Just wondering if there is any plan at all to address the drop down arrow in tables.  Sort of leaves the impression no one cares....

ScreenClip.png.a31c3397904d33dcb4bc08f8b65fbe9f.png

  • Like 1

Share this post


Link to post
  • 0

Thanks!  My pre-release version was super-crashy (technical term ;)).  Hope you found all the issues...

Share this post


Link to post
  • 0
16 hours ago, Iriska said:
Today we released Windows 6.21 GA. It's available here!
 
What’s in 6.21 GA?
Fixed:
- If you opened a notebook by double-tapping your touchscreen, all the notes in it would be duplicated. Admittedly this was a bit of an overreaction, so we fixed it.
- The app was changing some characters in your hyperlinks, which meant they wouldn’t work on other Evernote clients. But it should be smooth surfing now.
- In Work Chat, names with Japanese and Korean characters would sometimes be changed to Kanji or question marks. That was no help to anyone, but thankfully    it’s a thing of the past.
- We took care of a few other issues that were causing the app to crash.

Seems to be a link to 6.19....

Share this post


Link to post
  • 0
6 minutes ago, CalS said:

Seems to be a link to 6.19....

I went through 'check for updates' in the app,  and I got 6.21 that way...(I just checked!)

Share this post


Link to post
  • 0
2 minutes ago, gazumped said:

I went through 'check for updates' in the app,  and I got 6.21 that way...(I just checked!)

Good to know.  I just thought I would point out the link above needs to be fixed.

Share this post


Link to post
  • 0
Just now, CalS said:

Good to know.  I just thought I would point out the link above needs to be fixed.

Totally agree!

Share this post


Link to post
  • 0

The link is now fixed and is pointing to 6.21 GA. Thanks for reporting!

Share this post


Link to post
  • 0
23 minutes ago, Iriska said:

The link is now fixed and is pointing to 6.21 GA. Thanks for reporting!

Cool.  Looks like it has the same version as the previous beta?  So no changes from there?

Share this post


Link to post
  • 0

I am experiencing occasional crashes when attempting to use menu File/export.  I first noticed it in a script, but was able to reproduce once manually.  It doesn't always happen, but it never happened before.  Basically the program disappears, the taskbar icon becomes unresponsive for a bit, then becomes functional again.

Share this post


Link to post
  • 0
6 hours ago, CalS said:

Cool.  Looks like it has the same version as the previous beta?  So no changes from there?

That's correct.

  • Thanks 1

Share this post


Link to post
  • 0

The crash I reported above, I can now reproduce consistently, all it takes is to type quickly the following key combinations at the note list:  Ctrl-A, Alt-F, then E once or twice.

Since this is part of an export script, I thought the fault was with the script, but I can manually reproduce the crash consistently if I type the above fast enough.

Seems related to some kind of delay in the animation between Ctrl-A and Alt-F.

I can add sleep lines on the script to make it work, but I assume Evernote itself should not be crashing in this case.

EDIT:  I would be curious to know if others cannot reproduce this as described, so that maybe I need to open a support ticket.

Share this post


Link to post
  • 0

What AndreasM said:

39 minutes ago, AndreasM said:

Evernote, do I understand it correclty????

You are fully aware that the beta crashes and still, you are releasing it as GA!!!!

This is a total disrespect to your users, not to mention, that you are even not checking the fact, that the links originally points to a previous version. Do you call it QA???

That's a shame.

What Iriska, speaking for Evernote said (with relevant line highlighted):

On 9/24/2019 at 6:38 PM, Iriska said:
Today we released Windows 6.21 GA. It's available here!
 
What’s in 6.21 GA?
Fixed:
- If you opened a notebook by double-tapping your touchscreen, all the notes in it would be duplicated. Admittedly this was a bit of an overreaction, so we fixed it.
- The app was changing some characters in your hyperlinks, which meant they wouldn’t work on other Evernote clients. But it should be smooth surfing now.
- In Work Chat, names with Japanese and Korean characters would sometimes be changed to Kanji or question marks. That was no help to anyone, but thankfully    it’s a thing of the past.
- We took care of a few other issues that were causing the app to crash.

So, no, Andreas, that would be the exact opposite of what Evernote is saying. That is a shame.

Share this post


Link to post
  • 0

Hmmn.  Whatever was done to fix crashes appears to have been only partially successful - I had one last night after several hours of activity;  it may have been related to cut-and-paste activity that I was trying to complete in a new note when everything went quietly away...

On the -vaguely- positive side,  it's a relatively painless operation to kill the taskbar services and restart,  and I'm getting really good at Fatal Error reports.  🤨

Share this post


Link to post
  • 0
15 hours ago, AndreasM said:

So what crashes did they fix???

As a previous employee, I'll just say it would be crashes that they could actually reproduce. Not all crashes reported here can be. (And some crashes that are seen in-house can't be either. It's _really_ hard to banish those gremlins when they keep disappearing!)

 

3 hours ago, gazumped said:

and I'm getting really good at Fatal Error reports.

Please, keep those coming. If crashes aren't reported, there's no way they can be fixed...

  • Like 2

Share this post


Link to post
  • 0

This version keeps crashing on me and the syncing is too slow. Can someone point me to the previous version so that I may install it? I thought I had 6.19, but I couldn't find it here.

Share this post


Link to post
  • 0

The following bug is still happening in the GA: 

Another user posted a discussion about what appears to be the same issue:  

 

Share this post


Link to post
  • 0

Interesting.... Evernote wouldn't stop syncing. I changed a tag on 6000 notes so I put it down to that. Over 1 hour to sync all files, then when the log showed it was at 100% evernote stopped responding. I restarted, and again with the sync for an hour.  I waited out the not responding and Evernote came back after a good 5 min. Then it starts syncing again!  And that's when  I noticed this from my log - notably the stuff about a business account:

21:32:34 [INFO   ] [24020] [23660] Performing business search [timmins]
21:32:34 [ERROR  ] [24020] [23660] 0% Business user account has been deactivated, host: www.evernote.com
21:32:35 [INFO   ] [24020] [4048] 91% * rsrc={f3baef37-15d5-4ff0-b409-ce54d5601c65}, note={3a27635d-e329-499d-9d94-e1e4c8941076}
21:32:35 [INFO   ] [24020] [4048] 92% Updating server note "Algonquin Place Street", resource count: 1, content: 0 B
21:32:35 [INFO   ] [24020] [4048] 92% * guid={52569758-560c-4055-8f3a-076107e0bed5}
21:32:35 [INFO   ] [24020] [23660] Performing business search [timmins]
21:32:36 [ERROR  ] [24020] [23660] 0% Business user account has been deactivated, host: www.evernote.com

The only explanation I have is that I created a new "work" notebook and I have a "personal" notebook, so maybe that is confusing Evernote?  Or, I tried business briefly 2 years ago. Not sure how that could cause any of this though considering all other versions of Evernote since then do not show "Business Account" stuff in the logs.

Share this post


Link to post
  • 0
5 hours ago, lisec said:

This version keeps crashing on me and the syncing is too slow. Can someone point me to the previous version so that I may install it? I thought I had 6.19, but I couldn't find it here.

You can find 6.20 here 

 

  • Like 1

Share this post


Link to post
  • 0

More details on what I posted above: 

 

Share this post


Link to post
  • 0

Are these problems solved in the 6.21.2 ?

Share this post


Link to post
  • 0
1 hour ago, eric99 said:

Are these problems solved in the 6.21.2 ?

6.21.2 is the GA, so, not yet.  There was no 6.21.1 GA, only beta.

Not everyone is seeing the problems reported, but tech support has privately acknowledged what I reported and are working on a solution.

Share this post


Link to post
  • 0

I have a base note I use for monthly processes.  It has a table in it wherein the first column contains a note link to a note with instructions for a specific task.  The other columns are months of the year for documenting the complete date.  

Prior to this release when I clicked on a link in the first column I would go to the note represented by the link, as one would expect.  Since this release when I click on the link the base note flashes and I stay in the base note, I do not get transferred to the target note.  If I Shift + Click the link the target note opens in its own window.  If I open the base note in its own window and click a target link things work as expected.  If I cycle EN, clicking a link works right the first time but not after that, whichever link I click in the base note.  I have a shortcut to get to the note in the form of a search.  If I change context to all notes and then click a target link things work fine.

IAC, this never happened before this release.  I've fixed my problem by making the shortcut the a note shortcut vs a search shortcut.  Still, a problem however fringe was introduced with this release.  And I'm not getting the time back it took to fix it for myself.

EDIT:  Looks like the problem may occur when clicking on any link located in a table.

Share this post


Link to post
  • 0
On 9/30/2019 at 1:29 PM, Don Dz said:

More details on what I posted above: 

 

We're investigating this further. Thanks for the report! 

  • Thanks 1

Share this post


Link to post
  • 0

Better description of the problem I describe above detailed here.

 

  • Like 1

Share this post


Link to post
  • 0
hace 8 horas, CalS dijo:

Better description of the problem I describe above detailed here.

 

Right. I've posted the same problem with links on that topic. Just after installing 6.21.2

Share this post


Link to post
  • 0

This also occurs if you are using a link in a different program and you have a search of some sort in EN at the time. 

As in clicking on a link in a the reminder email.  If in a search in the main EN window you do not transfer to the target note, you get some other note that is in the current search results.

Bad bug in my view.

Share this post


Link to post
  • 0

Oops - another crash today.  Just started up and ran a Windows batch file to open some apps,  tried to move a note to another notebook and 'poof' the window went away again.  Completed the Fatal Error screen.  Kill tray apps / start Evernote again... and we've been going now for hours without a problem.  🤫

Checked for updates just in case,  but this is the latest version...

Share this post


Link to post
  • 0
1 minute ago, gazumped said:

Oops - another crash today.  Just started up and ran a Windows batch file to open some apps,  tried to move a note to another notebook and 'poof' the window went away again.  Completed the Fatal Error screen.  Kill tray apps / start Evernote again... and we've been going now for hours without a problem.  🤫

Checked for updates just in case,  but this is the latest version...

Yeah I had a couple of crashes in the last couple of days.  Really not doing anything of note at the time, switching notes or whatever.

Share this post


Link to post
  • 0

Bug / Curiosity with tables and horizontal rules:

In an Evernote table, the horizontal rule (Ctrl+Shift+-) isn't supported, for whatever reason, so in general if you try to add one to a table cell by using the toolbar too, hotkey or copypasting from elsewhere, it won't be added. However, if the cursor location is in a list (numbered or bulleted), a rule *will* be added, with a white background, and the UI has some problems moving past it when using the arrow keys (e.g.: Ctrl+Shift+_, ArrowLeft, ArrowLeft will not move back over the rule). The UI navigation problem persists even if you remove the list elements before and after the rule.

I rate this as "interesting, but probably mostly harmless, so don't do that".

Share this post


Link to post
  • 0

Minor bug: several items in the Format menu don't work in a brand new note until you have typed something (they do work via hotkey or edit toolbar: Insert table, checkbox, hyperlink.

This has been around through several version, but I recall when it wasn't present.

Share this post


Link to post
  • 0
On 10/9/2019 at 1:28 AM, pepemacias said:

Right. I've posted the same problem with links on that topic. Just after installing 6.21.2

I have the same problem as well. Additionally I have shortcuts to tags. If I click this shortcut for the tag and I click on a link in a note with this tag the screen flickers but it stays on the same note. The expected behavior would be seeing the linked note.

I also have one note which contains this tag but also has a direct shortcut. This note has the same problem, even when clicking on the shortcut to the note itself (so not the tag) it won't redirect me to another note. 

Share this post


Link to post
  • 0

Hmmn.  Another crash today.  Was in process of adding a small file to a note when suddenly the note wasn't there...  Filled in the usual forms...  <_<

Share this post


Link to post
  • 0

Wow another crash.  How lucky can one person be...  was using page up/ page down to scroll my note list rapidly up and down (don't ask) and it seemed like the pressure was too much.  I won't do that again...  Report filed!

Share this post


Link to post
  • 0
On 9/28/2019 at 5:00 PM, Don Dz said:

The following bug is still happening in the GA: 

Another user posted a discussion about what appears to be the same issue:  

 

I'm running EN Windows on Win10 Home. EN Internal Links behavior has changed with the recent version change. I used to click an "Internal link" and EN would immediately take me to a new list showing the linked note. Now, when I click an internal link, EN continues to apply the note filters (green arrows) which filters out the note if they lack criteria to display based on filters.

2019-10-17 14_57_22-Clipboard.png

2019-10-17 15_00_53-95-Mtg & Task notes - jose.sabas@ucsf.edu - Evernote.png

Share this post


Link to post
  • 0

Clicking internal links in a note that's in its own window doesn't work anymore with this version.

It does work when you click the same link in the same note, but in Evernote's main window instead.

Share this post


Link to post
  • 0

When clicking internal links in a note that's in its own window, the work around is to press [Shift] key while clicking the link. It will open the linked note in a new window.

Share this post


Link to post
  • 0

20191027 Another crash - at least it's been 10 days or so of daily use since the last one...

 

Share this post


Link to post
  • 0
On 10/9/2019 at 6:34 AM, CalS said:

This also occurs if you are using a link in a different program and you have a search of some sort in EN at the time. 

As in clicking on a link in a the reminder email.  If in a search in the main EN window you do not transfer to the target note, you get some other note that is in the current search results.

Bad bug in my view.

@Iriska

Hey there.  Is anyone working this bug?  It is a major PITA if note links are a part of one's work flow.  Thanks.

  • Like 2

Share this post


Link to post
  • 0

I assume a new beta is coming out "any day now" . . . .:ph34r:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...