Jump to content

Recommended Posts

Hello! When attempting to tag a note I run in to what I would consider to be a bug... I guess I want to report that / find out if it's actually a bug or if it was an oversight. -

As probably a lot of Evernote users do, I have a lot of tags and I can't always remember what they are. So, when I tag things it kind of goes like this -

  1. start a new note
  2. press F3 or click on "Add tag..." to tag the note
  3. I start to type what I think is the tag I need and suggestions begin to pop up
  4. I realize after checking the popup suggestions that the tag I need is not the list so I backspace the field clear
  5. Now that the field is empty, I begin typing the correct tag exactly so that it is the only suggested tag to popup in the suggested tag list
  6. I press tab or enter to select / auto-complete my tag per what is shown in the suggested tag list after only partially typing in my needed tag.
    1. Example - The tag I need might be "5 This Month". When I have typed in "5 This" the only tag I see in the suggested tags is the correct one "5 This Month" and it is highlighted blue as though it would be the tag selected in an auto-complete scenario when pressing tab or enter.
  7. Instead of actually auto-completing and using the tag that showed up in the auto-complete suggestion box a new tag gets created named what I had partially typed in to the tag field. Per my example, It would have created a new tag named "5 This"

This is pretty frustrating because now, I have an incorrectly tagged note that looked like it would tag correctly and I have to clean it up and re-tag it correctly. To clarify, this only happens if I have started to type out a tag and then clear the field to type a new tag name. In order to prevent this from happening I have to correctly type the tag in the first time which is cool and all but realistically just doesn't happen all the time especially when using multiple tags. Or, I have to completely cancel tagging by clicking in to the body of the note before starting to tag the note with the correct tag.

Using Evernote for Windows 10 Version 6.20.2.8626 (308626) Public (CE Build ce-62.3.7750)

Share this post


Link to post

Hi.  Is this the sort of thing you mean?  I started to type 'bu' and got this set of options,  but backspaced and completed a new tag 'burrow'.  That worked fine for me using the installed version.  (The note hadn't synced when I snapped this screenshot,  so the new tag didn't show up in the list.)

.ScreenClip.png.5bb50cad3a126fc6627bc9a2217521d7.png

Share this post


Link to post
On 9/13/2019 at 1:20 PM, EvernoteUser18712 said:
  • I press tab or enter to select / auto-complete my tag per what is shown in the suggested tag list after only partially typing in my needed tag.
    1. Example - The tag I need might be "5 This Month". When I have typed in "5 This" the only tag I see in the suggested tags is the correct one "5 This Month" and it is highlighted blue as though it would be the tag selected in an auto-complete scenario when pressing tab or enter.
  • Instead of actually auto-completing and using the tag that showed up in the auto-complete suggestion box a new tag gets created named what I had partially typed in to the tag field. Per my example, It would have created a new tag named "5 This"

This happens when you back space to the tag you want and then hit enter.  The tag will note be highlighted at that point.  Type one more letter of the tag and it will be highlighted.  Workaround is to be sure the tag is highlighted before hitting enter if you backspace during tag selection. I would agree it is a bug, done it more than once myself.

20190916_094622.gif.26f7b240e5659c7164d37ba84387b7ac.gif

Share this post


Link to post
12 minutes ago, gazumped said:

Hi.  Is this the sort of thing you mean?  I started to type 'bu' and got this set of options,  but backspaced and completed a new tag 'burrow'.  That worked fine for me using the installed version.  (The note hadn't synced when I snapped this screenshot,  so the new tag didn't show up in the list.)

.ScreenClip.png.5bb50cad3a126fc6627bc9a2217521d7.png

Did you type out the entire word "burrow" on your second attempt? When you auto-completed, did you click it, Tab or Enter? Essentially yes, that's what I'm doing but instead of tagging correctly it just creates a new tag with the partially typed tag when I hit Tab or Enter to auto-complete with the suggestion after backspacing the field clear and starting to type again.

Does it work properly if you type in a different tag that may not have been in the initial list of suggestions? For example - Start typing "Bu" and then switch to say something that starts with an S?

Share this post


Link to post
3 minutes ago, CalS said:

This happens when you back space to the tag you want and then hit enter.  The tag will note be highlighted at that point.  Type one more letter of the tag and it will be highlighted.  Workaround is to be sure the tag is highlighted before hitting enter if you backspace during tag selection. I would agree it is a bug, done it more than once myself.

20190916_094622.gif.26f7b240e5659c7164d37ba84387b7ac.gif

Yes this is exactly what's happening. So I guess what's next? Is there a better way to report this or formally request it to be fixed? Or do we live with it?

Share this post


Link to post

I part-typed 'bu' then backspaced both characters and added 'burrow' as a complete new word,  plus 'enter' to create the tag.  Hadn't noticed any problems as noted by @CalS above,  but I'm not a big tag user!

Share this post


Link to post
1 minute ago, gazumped said:

I part-typed 'bu' then backspaced both characters and added 'burrow' as a complete new word,  plus 'enter' to create the tag.  Hadn't noticed any problems as noted by @CalS above,  but I'm not a big tag user!

I think that may be why you didn't see it. It appears to work properly if you type the full tag name, it just doesn't like the partial. Thank you for helping look in to this though!

  • Like 1

Share this post


Link to post
Just now, EvernoteUser18712 said:

Yes this is exactly what's happening. So I guess what's next? Is there a better way to report this or formally request it to be fixed? Or do we live with it?

Filing a bug report would be the next step.  I'm afraid I would not hold my breath, this has been around forever.    :(

Share this post


Link to post
1 hour ago, CalS said:

Filing a bug report would be the next step.  I'm afraid I would not hold my breath, this has been around forever.    :(

Sounds good. Thanks for your help CalS!

  • Like 1

Share this post


Link to post
On 9/13/2019 at 11:20 AM, EvernoteUser18712 said:

Instead of actually auto-completing and using the tag that showed up in the auto-complete suggestion box a new tag gets created named what I had partially typed in to the tag field. Per my example, It would have created a new tag named "5 This"

I get the same bug on my Mac

The latest UI on my iPad has this cleaned up.  
There's no indication of auto-complete - the tag box and suggestion list are completely separate

Share this post


Link to post
15 minutes ago, EvernoteUser18712 said:

Sounds good. Thanks for your help CalS!

You are welcome. 

Share this post


Link to post

I guess I never thought of the behavior you describe as a bug, more like a typo, so I just glance at my tag list for any stray not inside a stack.

But if fixing this bug will stop stray tags, all the better.

  • Like 1

Share this post


Link to post
13 minutes ago, Don Dz said:

I guess I never thought of the behavior you describe as a bug, more like a typo, so I just glance at my tag list for any stray not inside a stack.

But if fixing this bug will stop stray tags, all the better.

For me, you see the one and only tag name below the tag field though you don't see the full tag name in the tag field.  Just seems to me since it is the only tag visible it would be selected on enter.  Not a biggie for me since this doesn't happen often.  But guaranteed when I stumble on a "... where did that tag come from ..." this is the reason.

Share this post


Link to post
15 hours ago, CalS said:

For me, you see the one and only tag name below the tag field though you don't see the full tag name in the tag field.  Just seems to me since it is the only tag visible it would be selected on enter.  Not a biggie for me since this doesn't happen often.  But guaranteed when I stumble on a "... where did that tag come from ..." this is the reason.

Yeah that's what drives me crazy as well.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...