Jump to content
gdog

Bug: can't add photos of documents in the iPhone app

Recommended Posts

Adding photos of documents to notes no longer works on the iPhone (it has worked for many years just fine).

When I add pictures of documents they don't appear in the contents of the note. But they appear in the listing. This is true for both evernote for iOS and evernote desktop for Mac. See attached screenshots.

Tested on iPhone 6 and iPhone 8 with newest Evernote installed: 8.22.370013.

Evernote for Mac version 7.11 (457846 Direct), Editor: 69.1.8237 (1f0aea9).

The bug applies to photos added in the auto (document) mode. I can still add regular photos (from the roll or new from camera) to the note and save just fine.

evernote_desktop.jpg

IMG_5033.jpg

IMG_5032.jpg

Share this post


Link to post

Could it be that you have exceeded your less-than-generous update limit as a basic account user ?

Share this post


Link to post

I don't think so. I still have a few MB, besides the picture does not appear in the note contents when it's added, even before saving the note on the phone. So it's should not have anything to do with uploading to the server.

Share this post


Link to post

I have had the same issue for a few months. It says "You have 10 GB of 10 GB available". Should be enough space. It works fine if I use my iPad (iPad Pro V2 large version), while not from my iPhone8.

I removed the Evernote app from the iPhone, downloaded it again, logged in and let it sync. Then I created a new note - and the same as gdog above: I can see a thumbnail in the overview, but when I open it, there are no photos. It is also supposed to OCR the picture: And when I search for text, it doesn't show those newer notes where the photos cannot be opened. So they are not scanned either.

Share this post


Link to post
On 7/30/2019 at 7:56 PM, DITB said:

I have had the same issue for a few months.

Hi.  How big are the photos?  I find in Android that big pictures taken a few minutes earlier aren't immediately available on the device once the note has been saved for syncing - it looks like the device sensibly prioritises phoning home before showing me what I just created.  If you're saying that pictures don't save at all on the iPhone,  that's a different issue.  Maybe one of the iPhone users here can comment further.

Share this post


Link to post

No issue, and I am using less advanced I-devices. The only issue is that it may take some time until everything is safely uploaded and stored on the server.

But I do rarely put large (what is large ? 10MB ? 25 MB ? 50 MB ? ) pictures into notes, so maybe I miss a part of what is needed to jump off the syncing cliff. In the few occasions I did, it worked out fine, after allowing time for the sync. How long depends on the internet connection.

  • Like 1

Share this post


Link to post
On 8/1/2019 at 4:26 AM, gazumped said:

Hi.  How big are the photos?  I find in Android that big pictures taken a few minutes earlier aren't immediately available on the device once the note has been saved for syncing - it looks like the device sensibly prioritises phoning home before showing me what I just created.  If you're saying that pictures don't save at all on the iPhone,  that's a different issue.  Maybe one of the iPhone users here can comment further.

How big are they? I am using the camera function. Making a new note, adding a photo (it asks, from file or take a photo), and I take a photo of one or more forms that I need to keep track of.

It worked for ... at least a year I think, and suddenly I realise only the thumbnail is working. When I open the note - there is nothing. Even after weeks later, should be plenty of time for syncing.

I used my iPad - doing exactly the same - and all works fine.

Hence, I think there must be a bug in the current version of Evernote (maybe only some installs, or some iPhones?)

Using iPhone 8 and iPadPro2 (l12.9" or whatever, the larger one)

  • Like 1

Share this post


Link to post
29 minutes ago, DITB said:

Hence, I think there must be a bug in the current version of Evernote (maybe only some installs, or some iPhones?)

Have you submitted a support ticket   (user > support > submit support request)

You could also check at the activity log to see if there's an error message

Share this post


Link to post

Tested it both ways:

Open a new note in the EN app, tap on „plus“, choose take a photo, take it, tap on „safe“, go to the note, type a header, leave note.

The note is there, the picture is there, both as thumb and as full copy in the note. And it syncs within of a blink (on WiFi).

IPad Pro 10,5, iPhone 6S+, tested on both devices, checked on the same device and on the other. Everything as it should. 2x iOS 12.4, app 8.22.

Usually on i-devices, when it works on one of them, it will work on all of them. So your options seem to be:

- Complete uninstall and reinstall of the app

- Support ticket

  • Like 1

Share this post


Link to post

Guys, did you get any reply from support? I'm not a premium user so can't submit a ticket. But checked today and the problem still exists.

Do you know another app that scans documents just as well as Evernote does?

Share this post


Link to post
6 minutes ago, gdog said:

Do you know another app that scans documents just as well as Evernote does?

CamScanner / Adobe Scan / MS Office Lens...

Share this post


Link to post
19 minutes ago, gdog said:

Do you know another app that scans documents just as well as Evernote does?

I use Evernote's Scannable app

Share this post


Link to post

Same issue. Evernote support said it's a bug they are working on.  Workaround is to take pictures using the camera app, then adding them to a note.  

Share this post


Link to post

Thanks for the info! At least we know they are woking on it. Too bad they didn't notify us here by posting on this forum.

Share this post


Link to post

Funny bug, that picks the users he wants to irritate.

Seems I did some good works in my former life that still helps my karma to keep the little beasts at bay ...

By the way, most of my scanning is done with ScannerPro. A little with OfficeLens, and with the internal scanner of the EN app (not Scannable).

Share this post


Link to post

They gotta fix this soon it's driving me crazy 

  • Like 1

Share this post


Link to post

Exactly the same issue with me. Evernote version 8.23 on IOS 12.4.

If I use the built-in take photo function to upload something, it fails to actually upload anywhere. It shows it's uploaded in the IOS app temporarily, and shows the thumbnail, but opening it again fails to load the image. I've checked for the image on 2 different installs local installs on windows devices, and the browser.

Taking the image and uploaded the photo manually seems to work as a workaround

  • Like 1

Share this post


Link to post

A photo fix was mentioned in this release

 

Share this post


Link to post

I'v e got the same issue. I can take a picture via the Evernote app and see the thumbnail in the iOS notes list, but when I open the note on my phone, I cant see the image; like wise after syncing note and I try to open in mac app: no attached photo.

Share this post


Link to post

For some reason ... mine works again now. Maybe the bug was found and the app updated?

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...