Jump to content
AronsLaw

Incredible lag while typing and using notes - Mac

Recommended Posts

I have a new mac book air, and recently I've been experiencing a crazy lag while typing and using the evernote app on my mac. I can barely use it. Very frustrating. Anybody else have this same issue, or know what can be done to rectify it. Thanks.

 

Jeff 

Share this post


Link to post

How new is new ?

And have you activated file vault ?

My experience is from a MBPro, new and shiny. A little more horsepower than the air, but it was not working well for the first days.

With support from the apple hotline, we found out that there was a LOT of background activity related to syncing hundreds of GB with iCloud plus files moved from my Win-PC and building the encrypted structure on the SSD. Because EN in itself is a database, there are many transactions going on while you are typing. It is not a simple editor, grabbing letters from the keyboard as you go hacking away.

If there is this background stuff (check for a process called „mds“ in the activity monitor, another is „windowserver“), it takes away a lot of CPU power. The Apple support has the chance to run a diagnosis through the web, so use it.

It was not an EN issue, I had „beach balls of death“ in pages, safari and other apps as well, when EN was not even opened.

After the initial stuff was though, everything started to work fine, as expected.

Share this post


Link to post

I have the same problem now on a 2016 maxed out 13" MacBook Pro. I'm getting > 60% CPU utilization from Evernote and also Apple spell processes. I tried clearing the keyboard and spelling caches in macOS with no improvement. I can type for about 3-4 words followed by a 2s delay, CPU spike, and return of normal typing speed for a few seconds. Then the process repeats. I'm not having slow downs anywhere else. I tried to give up and use the web interface, but it destroys the formatting of my notes (fun). 

 

It doesn't appear to be related to syncing, as turning off wifi doesn't fix the problem like it did when I had this behavior in version 6. 

Share this post


Link to post

See my post above.

What OS ?

Updated recently ? OS and/or EN-app ?

File Vault running ?

etc.

When I look up EN in the activity monitor, it usually just takes appr. 1% of CPU. No lag at all when typing into a EN note.

Share this post


Link to post
6 hours ago, PinkElephant said:

When I look up EN in the activity monitor, it usually just takes appr. 1% of CPU. No lag at all when typing into a EN note.

I'm glad it's working for you. It was working for me until the most recent update so maybe that corrupted my database. 

 

It's affected every note I've tested so far including a blank new note. 

 

I do have File Vault active and I'm on High Sierra, but I haven't had this problem since early version 7. 

 

I'm currently on Evernote 7.10.  

 

I filed a ticket, but based on my recent experience with Evernote support that is unlikely to be revealing. The support experiences I've had thus far have been tantamount to "can't reproduce said issue / can't be happening / etc".

 

I'll have to nuke my database and download from the server when I have access to a faster connection speed. 

Share this post


Link to post

Updating can create the most stupid situations, I agree.

Have you updated through the App Store, or by direct install ? Both say they are 7.10, but the direct version seems to be more sound.

Did you try to fix your database ? Hold the option key when opening the Help-menu. Down the menu, in a submenu you will find options to rebuild aspects of the database. Sometimes this will fix things.

Share this post


Link to post

I'll try rebuilding the indexes, thanks for the tip. I'm using the direct Evernote website download version (always have). 

 

I wonder if there's some problem with either syncing (or attempt to sync even if wifi is off), or with spell check as the apple spell process seems to go up in CPU use at the same time. 

Share this post


Link to post

Interesting observation about the spell checking. I have it running as well, with no observable effect on resources usage.

Hope you can solve the problem by rebuilding the database.

Share this post


Link to post

Unfortunately no luck. I force re-synced using shift + option + sync and also Recreate Full Text Search Index and Recreate Spotlight Search Index and I'm still getting a typing delay. I get about 1 - 2 words written followed by the blue upper right hand side indicator for the note needing to sync illuminating. At the same time the Evernote CPU process jumps to > 60%, as does AppleSpell. Then the fans kick on. Eventually the note syncs and the process repeats. 


This is only happening on a MacBook Pro. My 2018 iMac is fine, so it suggests some local issue to that machine maybe. 

Share this post


Link to post

Evernote support suggested I fix this problem by “rebooting my phone”

I sent a log and screenshot. I don’t think they are even reading the emails anymore.

🤦‍♂️

Share this post


Link to post

Crossing my fingers... A clean reinstall of Evernote and downloading all notes from the server seems to have fixed the problem. I'm still getting ~40% CPU with typing fast, but I also see this occur with other apps at times and it's not heating up the machine anymore or causing delayed typing. Also the AppleSpell process isn't spooling up anymore. 

  • Like 1

Share this post


Link to post

I doubt you can type fast enough to create 40% CPU (not even 1% CPU with plain text). If you want to monitor it more closely, you can install something like System Toolkit on your Mac.

Probably File Vault is working on the new GBs that came in from the EN server. If this is happening, it should stop soon.

Share this post


Link to post

I"m still having this issue. It is incredibly annoying and ruining my productivity at work. Anyone have any solutions? 

Share this post


Link to post

Since I still have no problem, I still have no solution.

Tried Support on this (however mixed the experience seems to be ...) ?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...