Jump to content
robe070

6.17.7 Install error 110

Recommended Posts

When I attempt to upgrade to 6.17.7.8474 it gets install error 110.

Then this is displayed "boostrap.cpp:981 0x6E The system cannot open the device or file specified"

The same error occurs when I manually download the same version directly from evernote.com.

 

My current version is:

6.17.6.8292 (308292) Public (CE Build ce-62.1.7539)

I have upgraded many many times before.

EvernoteSetupMSI.log EvernoteSetup.log

Share this post


Link to post

So I looked in the log file and noted that it could not open evernote.msi. Strange, it was running it!

So I ran it directly and it failed.

Then I copied the file to a different location and it worked. Maybe an anti-virus issue or Docker Desktop may be interfering.

Now I know its machine specific, I'll do more investigation next time there is an update and an error occurs. Like stop Docker Desktop and the anti-virus checker.

  • Like 1

Share this post


Link to post

Hi.  Good job for finding your own fix.  The usual option is to re-install the existing version of Evernote (6.17.6) to ensure that all the files are in the expected locations,  then uninstall and reinstall the current version.  It happens,  very occasionally,  that the update fudges something up.  Computers.  🙄

Share this post


Link to post

Same situation with 6.18.4. Same solution.

I stopped Docker desktop and anti virus and it made no difference.

The workaround suggested is not the solution. I know MSIs. The log says it simply cannot open the MSI. Its not related to Evernote installed files. You can see it i the log file are uploaded last time.

Any other suggestions?

Share this post


Link to post

I have found this problem occurs because the Evernote installer assumes the Windows Temp file is in the default location (%USERPROFILE%\AppData\Local\Temp)  [for Windows 10]. If the user has moved that file, say to a Ram disk, the installation will fail.

The solution is to run the System control panel, choose "Advanced System Settings" or the "Advanced" tab, then click the "Environment Variables" button. Verify the Value for the "Temp" variable and make sure it is set to the default location. If you use a version of Windows other than Windows 10, do a search for your version to find the correct string to use, then select the "Edit" button to paste in the correct string.

After the installation has successfully completed, the user can restore the Temp file back to the Ram disk.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...