Jump to content
GTKZ

EVERNOTE IS FAILING TO SAVE

Recommended Posts

I use Evernote almost every day, and so far today it's failing to save any changes I make to my notes. I keep getting the "couldn't save note" red banner on top of the page.  I tried logging out and logging in and thought that helped, but a few minutes later I got the couldn't-save message again. Sometimes it works if i make ONE change, stop and let Evernote to save it, then make another change. I'm a writer with a deadline. Clearly, I can't work like this. Is there a bug? Anyone else? What to do?

I'm on a PC on Google Chrome, what I've always used.  I tried Microsoft Edge -- same thing. Even when it seems like it's saving, when I leave the Evernote tab to go to another tab and come back, the changes are gone. 

Share this post


Link to post

Moved to the web forum

Share this post


Link to post

Is there any way to  contact Evernote about this? I'm about to give up on this service. 

Share this post


Link to post
26 minutes ago, GTKZ said:

Is there any way to  contact Evernote about this? I'm about to give up on this service. 

All accounts  Twitter @evernotehelps  

Paid accounts  Contact Evernote Support

 

Share this post


Link to post
3 hours ago, GTKZ said:

I use Evernote almost every day, and so far today it's failing to save any changes I make to my notes. I keep getting the "couldn't save note" red banner on top of the page.  I tried logging out and logging in and thought that helped, but a few minutes later I got the couldn't-save message again. Sometimes it works if i make ONE change, stop and let Evernote to save it, then make another change. I'm a writer with a deadline. Clearly, I can't work like this. Is there a bug? Anyone else? What to do?

I'm on a PC on Google Chrome, what I've always used.  I tried Microsoft Edge -- same thing. Even when it seems like it's saving, when I leave the Evernote tab to go to another tab and come back, the changes are gone. 

Which version are you using?

Share this post


Link to post

The regular, free version. When the new one was introduced, it was such a mess that I went back to the original.

Share this post


Link to post

@GTKZ, can you provide details on the exact error you are receiving? Please provide the exact text, if possible. Also, if you are familiar with Chrome dev tools, you could open up the Javascript console and see if there are any errors there. 

Also, you might consider trying the latest web client again. That's the version that we are actively supporting. If you encounter issues in the older web client, we will be less likely to address the issue if not urgent. Though, if there's an issue saving notes, that would definitely be fixed. 

Share this post


Link to post

Thank you so much, Scott, for replying. Attached are screenshots that I hope will answer your questions. How do I switch to the new web client? I'm willing to try it again, hoping the initial problems were fixed. I love Evernote -- above other services -- and it's really messing me up not being able to use it. 

evernoteerror.png

javascriptconsole.png

Share this post


Link to post

Thank you so much, Scott, for replying. Attached are screenshots that I hope will answer your questions.

I found how to switch to the new version, and it seems to be saving,  but it freezes while it's saving. So ....

Share this post


Link to post

Hi @GTKZ. Thanks for the additional info. I'll follow-up with the team tomorrow when I'm back in the office. If you are able to, can you open the network tab of the dev tools and make sure the web client has fully loaded (network activity stopped). Then clear the network tab out and try editing the note. Then send a screenshot of that. It will help to see if one of the calls is maybe timing out. We'll be looking for something like "utility" or "notestore". Those will be the updates/syncs. If you do the same thing on the old client, the calls should also be "notestore".

Hoping this will help us figure out what is going on. Also, let me know if you are running any specific Chrome extensions. We sometimes see issues with them interfering with our calls. I think we're generally OK with most of the popular ad blockers since I know some devs use them. But, would be good to know just in case. Though, you indicated you saw something similar on Edge, which would lead me to look elsewhere, like network issues or firewalls. LMK if you have anything like that.

Share this post


Link to post

Hi @Scott T. Thank you for your help.

With some help, I discovered that my Windows 10 had failed to update to the latest version released last October -- #1809.  My computer was running #1803. After the update, the old version of Evernote began to work again. I found like a dozen saved files of the note I was working on ... I don't know, maybe every failed attempt to save showe up there.

Last night, after the update, the new Evernote version continued to take too long to save, which is why I've never liked it.  For example, if I type a word and quickly try to backspace-erase some letters, it freezes. Right now, it seems better, though is stillslow.

Attached are screenshots (first two) of dev tools console and network tabs (captured just now) of new Evernote version.  I've also attached the dev tools console screenshot (third image) for the old version, which I took just now as I was making revisions on the note and while  the system seemed to be working fine (but there's failure stuff in the console ... don't know what it means). Hope this helps. 

I work on Chrome with Ad Blocker and Ghostery extensions. 

mar28 newevernote.png

mar28 newevernote2.png

mar28oldevernote.png

Share this post


Link to post

Thanks @GTKZ. The only interesting thing in the screenshots is the last error in the first one. Other errors are ad blocker and I think the first is an expected warning. I'll double-check this with the dev team and get back to you when I have an answer.

Share this post


Link to post

One of the devs believes the Unchecked runtime.lastError comes from a Chrome plugin as well (see https://developer.chrome.com/apps/runtime#property-lastError). A suggestion was to try opening the Evernote website in a Chrome incognito window, since that should disable all plugins (unless you've explicitly allowed the plugin in incognito mode). That would help us determine if there is a plugin issue or not.

Share this post


Link to post

Attached are four screen shots. First two are not incognito, with the second one taken a few seconds after the first one after typing something and reloading. Third and fourth shots are incognito, wih the fourth one taken a few seconds after the first one, after typing something and reloading.

notincognito.png

notincognito2.png

incognito1.png

incognito2.png

Share this post


Link to post

Hi! Did you figure out what the error or what is causing it?

Share this post


Link to post
2 hours ago, GTKZ said:

Hi! Did you figure out what the error or what is causing it?

Hello, our development team is still investigating this. However, it appears to be caused by uploading larger images or attachments. These can take some time to upload through the browser. If you upload a larger image or attachment and then quickly start adding text or editing the note, it seems to cause this sync notice to appear. It may happen more frequently when the note is longer and/or has many images/attachments in it.

Until this fully gets resolved (no ETA at the moment, but it is a priority), please try to be very slow and deliberate when adding larger images and attachments before resuming editing. This should hopefully help mitigate collisions in the meantime. Thank you for your help with providing the above information and for your patience while the development team gets to the bottom of this.

Share this post


Link to post

Actually, I havent uploaded a single image into any of my notes. Not one.  It's all copy.  And when I copy and paste from online sources, I use  ctl + shift + v  to remove the format. So I don't see how that could be the cause. 

Share this post


Link to post

Thank you for these details, they are helpful while we continue to investigate this in all aspects.

Is the note you're pasting into by any chance a longer note?

Are there attachments of any kind?

Are bullet, numbered, or checklists present in your note and are you pasting into them?  

Share this post


Link to post

The note is long. I usually work on documents 1k to 10k long. This one is 4k. There are two short (5 bullets or less) bullet lists. I usually have more that that. No attachments. There are links to the websites I use for reference. In this note I have a few 2 x 2 tables, but the saving problem started before I started using those.  Attached are developer tools shots. The 2nd one, without errors, is incognito.

evernoteap3a.png

evernoteincognitoap3b.png

Share this post


Link to post

Got it, thank you. These details have been relayed to the developers while they continue to investigate this.

Share this post


Link to post

@GTKZ it looks like those errors in your newest console screenshots are reporting from the older version of Evernote Web. If you try the same note on the newer version of Evernote Web again (it looks like you tried this earlier at Scott's request to limited success but may have encountered other issues with the new version) do you still receive a message about not being able to sync your updates?

Once on the newer version of Evernote Web, please follow these steps if you continue to encounter the issue and please keep us posted.

Share this post


Link to post

Hey, does the error look like this?

 

Screen Shot 2019-04-08 at 12.02.23 PM.png( The Note )

Share this post


Link to post

@Jay-Bob  I don't like and don't use the new version of Evernote. It takes too long to save each update ... cursor freezes while saving. Slows me down way too much. 

 

@MatS14  Yes, that's what the error looked like when it was happening. I posted a screenshot of it earlier in the thread. 

Share this post


Link to post
1 hour ago, GTKZ said:

I don't like and don't use the new version of Evernote. It takes too long to save each update ... cursor freezes while saving. Slows me down way too much. 

When you mention it takes too long to save each update in the new version - can you please elaborate on when this happens? We're continually making updates to the new version and it should always be syncing/updating so you won't be seeing a green checkbox like you do in the old version because it isn't necessary.

In the new version, does this happen in a new note, or only in longer notes like the one you're referring when working in the old web version? 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...