Jump to content
rimboma

Drag and drop - attachments are placed randomly

Recommended Posts

The bug is still present for months now. What's worse the behavior may lead to a broken note as Evernote know no limits as far as placing dropped attachments. It may even nest it in the middle of a URL, making the operation of removing it from there rather risky. Sometimes when I drop two images one is placed randomly somewhere in the note, while the other is not placed anywhere in the note.

As usual, it used to work flawlesly!

Here's my previous post on the issue.

 

Possibly related:

 

irfan_20180725_083622.jpg

  • Like 1

Share this post


Link to post

The action has been somewhat improved (as somewhat mentioned in one of the recent changelogs). The thing is, for the drag&drop to work properly I have to place the text cursor where I need the image first. So still not satisfactory. Aaaaand it used to work fine.

Share this post


Link to post
On 2/4/2019 at 10:47 AM, rimboma said:

The thing is, for the drag&drop to work properly I have to place the text cursor where I need the image first

I found a simple workaround to this as it has been a real problem for quite some time. Just stick 30 or 40 blank lines in the note, close to where you want the attachment to go. Drag-and-drop the attachment somewhere in this blank area. It won't be anywhere close to where you dropped it but if you are really, really lucky it will be in that monster blank area. Then just delete the blank lines you don't need.

May not be a sensible way of curing the problem but it's faster than waiting for EN to fix it. I've got about 1500 notes I need to format so adding and then deleting 40-50 thousand blank lines is all I can do. As was said earlier by someone, EN likely won't be doing anything about it any time soon.

As well, when the attachment goes somewhere totally bizarre, just hit Ctrl-Z to remove it and try again. I found that after doing this a few dozen times it will usually attach where your cursor is, but you may have to try/retry a few hundred times. Eventually it will work. So what if it takes a week to enter a single note. Who's in a hurry?

  • Like 1

Share this post


Link to post
2 hours ago, OrbWeaver said:

I found a simple workaround to this as it has been a real problem for quite some time. Just stick 30 or 40 blank lines in the note, close to where you want the attachment to go. Drag-and-drop the attachment somewhere in this blank area. It won't be anywhere close to where you dropped it but if you are really, really lucky it will be in that monster blank area. Then just delete the blank lines you don't need.

May not be a sensible way of curing the problem but it's faster than waiting for EN to fix it. I've got about 1500 notes I need to format so adding and then deleting 40-50 thousand blank lines is all I can do. As was said earlier by someone, EN likely won't be doing anything about it any time soon.

As well, when the attachment goes somewhere totally bizarre, just hit Ctrl-Z to remove it and try again. I found that after doing this a few dozen times it will usually attach where your cursor is, but you may have to try/retry a few hundred times. Eventually it will work. So what if it takes a week to enter a single note. Who's in a hurry? 

I'm currently testing the cursor placement method as it would be much more efficient. I'll try your method if this fails.

Yes, Ctrl+Z is the way to go, especially that tumor-attachments may end up in the middle of a URL and open the URL when you even attempt to drag them anywhere.

Share this post


Link to post

This has presumably been fixed in the 6.18 beta, at least it's in the release notes.

Share this post


Link to post
3 hours ago, jefito said:

This has presumably been fixed in the 6.18 beta, at least it's in the release notes

Oops. No it hasn't. Just tried to attach an image (via "Attach File") and while I was at the very bottom of the note , EN thought it would look better a few paragraphs up in the middle of a sentence. Oh well, back to 6.16.4. It has the same problem but it's a bit less likely to misplace the attachment.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...