Jump to content
2019 Calendar Templates Read more... ×
Kruger2147

I'm a Premium member, but the forum still says I'm basic

Recommended Posts

I know it's a superficial issue, but subscribed to Premium a few days ago, and this forum still says I'm a Basic subscriber. How can I update this on the Forum?

Share this post


Link to post

I flagged your post for the administrators to look into.  Other users are reporting the same issue.

You could open a support ticket, but not with a Basic account ..... 😊

In the meantime, check your account settings and see if you're really using a Premium account

  • Thanks 1

Share this post


Link to post
18 minutes ago, DTLow said:

In the meantime, check your account settings and see if you're really using a Premium account

Confirmed that I have a Premium account.

Share this post


Link to post
1 hour ago, Kruger2147 said:

Confirmed that I have a Premium account.

Try signing out and back into the forum.

Share this post


Link to post
1 hour ago, CalS said:

Try signing out and back into the forum.

Didn't work.

Share this post


Link to post
1 hour ago, Kruger2147 said:

Didn't work.

Oh well, worth a try anyway.  Since you are Premium you can use chat or submit a trouble ticket.

Share this post


Link to post

@Kruger2147 Thanks for reaching out, and for bringing this to my attention!

I've confirmed that our records indicate that you are Premium, and I'm in the process of trying to determine why that isn't being properly reflected for your account in the forums.

I'll follow-up here once I have more information!

  • Thanks 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×