Jump to content
Daniel Stimpson

IFTTT Evernote Trigger fails with image

Recommended Posts

I'm having problems getting a trigger to work in IFTTT from Evernote.

The trigger works fine when I create a new note with text in the body, however if there is an image in the body I get an error in IFTTT stating 'There was a problem with the Evernote service'.

Has anyone got this working with images in notes?

Share this post


Link to post

The problem is not solved. What is going on? Does anybody have a solution?

On 12/3/2018 at 4:42 PM, Daniel Stimpson said:

I'm having problems getting a trigger to work in IFTTT from Evernote.

The trigger works fine when I create a new note with text in the body, however if there is an image in the body I get an error in IFTTT stating 'There was a problem with the Evernote service'.

Has anyone got this working with images in notes?

@Daniel Stimpson You have a premium subscription. What did Evernote Support Team told you?

Share this post


Link to post
On 1/11/2019 at 4:41 PM, nbck said:

The problem is not solved. What is going on? Does anybody have a solution?

@Daniel Stimpson You have a premium subscription. What did Evernote Support Team told you?

It is ongoing with them...

Share this post


Link to post

We have an open bug ticket for this issue. I just asked for an update on it.

Share this post


Link to post
On 2/5/2019 at 7:13 PM, Scott T. said:

We have an open bug ticket for this issue. I just asked for an update on it.

Any news on this yet?

Share this post


Link to post

@Balders Thanks for the ping about this. I apologize for not following up. Our developers looked into it and believe it to be an issue on IFTTT's side, likely with not handling specific image/file types or content we're sending back to them. We're not 100% sure, but that appears to be the case with our initial investigation. If you are able to reproduce this, you should reach out to IFTTT and report the issue. They should then be able to contact us to give us more specific technical details on which API is failing, what data they're sending, what data they're getting back, etc. We would then have a lot more information to work with. 

Separately, I'll see if I can reproduce the issue myself and reach out to IFTTT.

  • Thanks 1

Share this post


Link to post
29 minutes ago, Scott T. said:

@Balders Thanks for the ping about this. I apologize for not following up. Our developers looked into it and believe it to be an issue on IFTTT's side, likely with not handling specific image/file types or content we're sending back to them. We're not 100% sure, but that appears to be the case with our initial investigation. If you are able to reproduce this, you should reach out to IFTTT and report the issue. They should then be able to contact us to give us more specific technical details on which API is failing, what data they're sending, what data they're getting back, etc. We would then have a lot more information to work with. 

Separately, I'll see if I can reproduce the issue myself and reach out to IFTTT.

@Scott T. There is already a ticket with the dev team for this #2752464

  • Thanks 1

Share this post


Link to post

@Daniel Stimpson That's a IFTTT ticket number? If so, hopefully they can address this and reach out to us to work together to fix it. If that's an Evernote support ticket, not sure we can do anything without assistance from IFTTT staff.

I was able to reproduce this issue myself. I will see if I can get a dev contact at IFTTT that can help us out.

Share this post


Link to post

I'm still having this issue with notes that contains images. I could not find, where at IFTTT I can check the ticket number (2752464) that they created for this at IFTTT. Has anyone any news about this, or does anyone know where I can find this info at IFTTT?

Share this post


Link to post

Hi @mvdweer, it looks like that ticket number is for your support ticket with Evernote, not IFTTT. There are no updates from our end as the core cause appears to be with IFTTT. If you haven't already, it may be best to contact them directly for more specific information related to this.

Share this post


Link to post

IFTTT previously looked into the issue and believed they addressed the bug. A few days ago, we reached out to IFTTT again to let them know users are still encountering problems with the integration. They opened a new ticket and are investigating.

Unfortunately, Evernote doesn't control this integration. It was built entirely by the IFTTT team. Our business contacts are in touch, though, should there need to be any communication between the dev teams.

Share this post


Link to post
2 minutes ago, Scott T. said:

IFTTT previously looked into the issue and believed they addressed the bug. A few days ago, we reached out to IFTTT again to let them know users are still encountering problems with the integration. They opened a new ticket and are investigating.

Unfortunately, Evernote doesn't control this integration. It was built entirely by the IFTTT team. Our business contacts are in touch, though, should there need to be any communication between the dev teams.

Ok. I just got an answer to the question I asked them about this via Twitter (I couldn't find any other place to report the issue other than social media). This was the answer I got: "We encourage Evernote to reach out to our platform support team if they need help to diagnose this issue. They can get in touch with us by emailing platform-support@ifttt.com." 

Share this post


Link to post

@mvdweer Yes. Somebody reached out to me about the tweet which is why I came here to comment and provide the additional details regarding the recent contact. I tried to work on this myself, as I originally believed it was our integration. When I found it was their integration, I provided them details including how to reproduce the problem. I'll post a follow-up if I hear back from them.

Share this post


Link to post
4 minutes ago, Scott T. said:

@mvdweer Yes. Somebody reached out to me about the tweet which is why I came here to comment and provide the additional details regarding the recent contact. I tried to work on this myself, as I originally believed it was our integration. When I found it was their integration, I provided them details including how to reproduce the problem. I'll post a follow-up if I hear back from them.

Ok, thanks! If you need any information from me about this issue, I'm happy to share it of course. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...