Jump to content
A.Schouleur

Hyperlink to local file issue when accent in the path

Recommended Posts

Since update 6.16 (or 6.15), hyperlink to a local file with accent into the path does not work anymore.

Instead of having a %E9 (é) in the path, now it display � and the link does not open anymore.

Share this post


Link to post

Hi.  Which version of Windows do you have,  and have you tried re-creating the link?

Share this post


Link to post

Hi,

Thanks for your answer,

  • Tested on both Win7 and Win10.
  • Tested on local and network files
  • Link re-creation does not work
  • Link modification by replacing the  with %E9 does not work either.

Share this post


Link to post

Hi, I have the same problem; in the past, it used to work flawlessly but as OP pointed out after an update all my URLs linking to local files stopped working because of accents in the file path. It is very annoying. At the current time, the accent é is replaced with �, which makes the link to the local file broken. Thus I have to manually navigate to the file every time (and I have to access this file very frequently) and it is very time-consuming. Why can't EverNote go back to supporting accents in URLS? It shouldn't be too hard to fix!

I have Windows 10, tested on local files, link recreation does not work, link modification by replacing the � with %E9 does not work either. Please address thank you!

Share this post


Link to post

I am still having this issue, even after last Evernote update.

This is really annoying. It prevents me to deploy the new version in our company (Evernote Business users)

 

Share this post


Link to post

Same problem (in my case it the german Umlaut "ä" that's causing the problem) here. Please fix that, thanks.

2019_04_19_17_09_31_Alle_Notizbücher_sternenstauberinnerungen_googlemail.com_Evernote.jpg

Share this post


Link to post

Reported and not fixed since December 2018. As a result, I  have many dead links

Share this post


Link to post

Same issue, have latest EN 6.17.7.8474 (308474) Public (CE Build ce-62.1.7539) and Win 7.

Dear US people, there are characters used in the world other than in US. You should know by now.

Share this post


Link to post

And these characters aren't characterless! Hüsker Dü, Motörhead - come on, you clearly don't want us users not beeing able to link to a file in SUCH folders (-:

Share this post


Link to post

Depressing. There had been a time when it would have been fixed immediately.

Share this post


Link to post

Not fixed, not fixed, annoyed, angry etc.

I am missing one thing in all of the postings: Did anyone issue a support ticket on this ? And what was the result ?

Share this post


Link to post

Yes 

Result :

Quote

 

Thu, 16 May 2019, 01:38

My name is Jeff and I'm on the technical support team. I've received the escalation from Michael, I'm happy to continue assisting you.

I've reviewed the information you provided to catch myself up. I understand clicking on linked local files within Evernote for Windows that contain special characters like accents in the title no longer works.

I am able to reproduce this exactly as you've described it. I've gathered all of the very helpful information you provided and passed along to the development team for further review. While I don't have a time or date on when this would be resolved, please do know they are working diligently on a resolution. At the moment, I'm going to mark this ticket as answered while the development team continues to investigate the issue. We may reach out to you if we need more details.

Please continue updating Evernote whenever a new version is available. You'll receive an in-app message when the next update is available. Additionally, you can always select Help > Check for Updates.

 

 

  • Thanks 1

Share this post


Link to post

As a simple user, I tried to take a closer look at this local hyperlink issue that is annoying me since January. 

The way accents in local path names are encoded when processed with CTRL+K in Evernote seems to have changed. What I see however (or furthermore) is that the way  SPACES  of local path names are encoded when processed with CTRL+K, has changed since version 6.17 (or even 6.16).

Example :  regular file path "S:\AAA Ever Note.doc"
>>>> old encoding:   "file:///S:/AAA%20Ever%20Note.doc."     (space = %2520)
>>>> new encoding:       "file:///S:/AAA%2520Ever%2520Note.doc." (space = %2520)

Perhaps like some of you, I am working with thousands (!) of EN-hyperlinks to local files and folders. Changing them one by one would not only  be a wearing and tedious thing, but above all, one doesn't know if new changes ot this kind will be coming soon. 

I reported the issue in January 2019 and just communicated the above mentioned surely trivial  "finding" to the helpdesk, seeking for advice in general terms, and more specificely asking...

- if older versions of EN (like 6.15 I'm still using) will stay functional and supported (also from a security point of view) for some time?,

- if there is a way or a workaround to bulk change ALL the hyperlinks in EN at once....

......questions that I'm humbly submitting to you, dear Companions of Misfortune, begging pardon for amateurish language, reduandancy or even out-of-topicism.^^^

 

 

Share this post


Link to post
On 7/17/2019 at 3:02 PM, drrrumzzz said:

- if older versions of EN (like 6.15 I'm still using) will stay functional and supported (also from a security point of view) for some time?,

Hi.  Bug and security fixes come along all the time,  so while you could stick with 6.15 for a period of months,  it will be increasingly advisable to update as soon as you can.  If you leave it longer,  Evernote changes for new features not supported by your version may cause problems with your existing data.

On 7/17/2019 at 3:02 PM, drrrumzzz said:

if there is a way or a workaround to bulk change ALL the hyperlinks in EN at once....

Easy question - NO!

As suggested earlier in this thread,  I'd suggest you raise a support ticket to talk to Evernote Support - we're (mainly) fellow users on this Forum;  you may be able to get some information or assistance that will resolve or at least reduce this issue for you...

Support

Share this post


Link to post

New links are ok now, but same issue for all existing links

How can EN people introduce such incompatibility ?

Share this post


Link to post
9 minutes ago, flaneige said:

New links are ok now, but same issue for all existing links

How can EN people introduce such incompatibility ?

I think an update to the (third-party) editor changed the coding,  which they've now corrected for new links.  See my previous answer (July 19) about talking to Support for more techical background.

Share this post


Link to post
6 hours ago, flaneige said:

How can EN people introduce such incompatibility ?

Is this rhetorical? Because last I checked, software development is a human endeavor...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...