Jump to content
Sign in to follow this  
jqp

mac (Archived) Notes mistakenly identified as "today"

Recommended Posts

I'm getting confusing displays in the search window. The date that is displayed under the note title indicates "today" for a number of notes that were created several days ago. The date created and date updated fields for the notes are correct (and not today), and the notes are listed in correct date order. Moreover, a date-restricted search works correctly, i.e., if I search for notes created before yesterday the correct notes are shown, and in the correct date order, though the search window display identifes them as having been created "today." The incorrect date display is happening for some, but not all of my notes, and I can't immediately figure out any difference in the notes that may be causing this behavior.

Even stranger, a note I created today is correctly displaying as "August 6," which is today's date. Notes created days ago, however, are displaying as "today." So a note actually created today displays with the numeric date, but notes created several days earlier display with "today."

More odd behavior: if I check the "date updated" indicator (thereby automatically unchecking "date created") one of the notes changed from the correct date (August 2) to "today." The date created and date updated field for this note both correctly showed Aug. 2. And, after I edited the date updated field for this note to a different date, and then edited it back to August 2, it now correctly displays August 2 when I select "date updated" for the display. This trick doesn't seem to work, however, for other notes.

Incidentally, the date displays correctly for these notes on the iPhone.

Since everything else about dates appears to correctly use the date fields from the notes themselves, I suspect there's a bug in the way the Mac client assigns the "today" label in the search window.

Share this post


Link to post

Thank you for the report. Not able to reproduce it - just want to make sure i have the steps correct

Type a something in the search box

The resulting notes have the creation date of today?

Are you searching in a notebook or All notebooks - also is the criteria for all or any ?

More information will help reproduce the bug

Share this post


Link to post

I probably didn't explain myself well. On the Mac client, my Evernote client shows three windows. The left window contains a list of attributes that can be searched (e.g., notebooks, date, etc). The middle window shows a group of notes corresponding to the search performed (e.g., all notes in the particular notebook that is highlighted in the left window. The right window shows a single note selected from the middle window.

The behavior I'm describing occurs in the middle window, and only in that window. Each note shown in that window includes three elements: a small picture of the note, then below that the title of the note, then below that the date of the note. The notes are ordered based on whatever is checked from a pull down list on the top of the window, but as far as I can tell they always include the picture, the name and the date.

My problem is with the date in the middle window. For some notes, this date is correct (e.g., "August 2, 2010.") For other notes, however, this date reads "Today," even though both the original and the last updated fields in the note itself show an earlier date. Moreover, as I mentioned in my original post, a note I created today shows the date as "August 6, 2010," which is correct, but other notes created on earlier days show "today," which is incorrect for those notes, though it would be a correct description of the note created today.

Share this post


Link to post

Thank you for the detailed report. Cannot reproduce this issue - but will keep testing this scenario

Share this post


Link to post

For what it's worth, after I closed Evernote completely and reopened, a couple of the notes that had previously indicated "today" showed up with their correct dates, but a couple of others still say "today." And, oddly enough, a note that previously showed the date Aug. 6, 2010 changed to "today." Both are correct, of course, but it seems somewhat strange.

And, five minutes later, when I checked Evernote again, everything is now displaying correctly. The notes that previously said "today" all now have the correct date. I don't believe I did anything at all, other than minimizing Evernote and then pulling it up again.

There's definitely something flaky in the code that displays the "today" label in the middle window. If this recurs, I'll let you know.

Share this post


Link to post

I believe I've figured this out. If a note is displayed in the search window (the middle window), and if it has a date of "today" or "yesterday," and if the client is left on overnight, the "today" and "yesterday" labels remain unchanged, even though the date has changed. In that condition, any notes that are added show the correct numeric date instead of "today." The date labels update to the correct labels when the client is closed and reopened. Sync'ing doesn't have any effect, nor does merely minimizing the program (I suspect my earlier post was wrong on this point).

This was quite irritating for a while, since I added a bunch of notes over a week long period without closing Evernote, so the date labels were almost all wrong in that middle window. Now that I know what's going on, I'll just close the program from time to time.

Share this post


Link to post
jqp said:

This was quite irritating for a while, since I added a bunch of notes over a week long period without closing Evernote, so the date labels were almost all wrong in that middle window. Now that I know what's going on, I'll just close the program from time to time.

Yes, that does sound irritating.

I wonder if the Evernote staff can duplicate the problem.

Do they recommend shutting down the program to update the dates?

Share this post


Link to post

Thank you for more information. Will try the scenario again.

Share this post


Link to post

I'm having a similar problem with the Win7 and Andriod versions.

For at least one note (created over a year ago) EN shows a creation date of today in Win7. The same note shows a creation date of Dec 31 1969 on my Android phone.

Naturally dating is very important for record keeping, hopefully there is a good explanation.

Share this post


Link to post

More info on my date problem:

When I do a search by "created date" the problem note does not show up as newly created even though it displays in the list as created on the current date and time. In fact If I search for notes created before I started using EN this note shows up along with one other note. This seems consistent with the Android software that shows both as Dec 31 1969.

I've also noticed that in other places in the Win7 GUI it lists "created date" as "none".

The problem notes have an "updated date" of July (3 and 4) 2009 and seem to be screen caps with a WinMo phone so maybe there was a glitch in the WinMo software at that time which caused the date field to get set incorrectly. Since it seems like an isolated incident I'm just going to try to manually fix the date on these two notes.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...