Jump to content
Alberto7

Evernote for 10.11.6

Recommended Posts

Hi guys:) 
Where can I download Evernote for OS X EL CAPITAN 10.11.6? I find only for 10.12

Thank you!

Share this post


Link to post

Thank you. I have downloaded beta version in the link, and then update it! It works on! ;)

Share this post


Link to post

Obviously Evernote is welcome to determine what level of OS they will support their product on, but there are some of us who need to keep it working on existing technology that cannot upgrade beyond a certain OS (such as this iMac Early 2008 that is at the maximum El Capitan, 10.11.6). I think when people are asking for the best version that will run on whatever system they are stuck with, it would be beneficial all if you would simply provide the download links with the note, "Hey, these aren't supported going forward, but they did work at the time. Use at your own risk." For example, I'm using 7.2.1 right now. Is that the last and best-performing version that will work with El Capitan? That is information that I think would be good to provide, with little or no downside to Evernote. No?

Share this post


Link to post

@k9gardner - I'm not a MacOS user,  so can't comment on the 'best' version to try,  but if 7.2.1 is working for you and someone higher up this thread was suggesting 6.13.3,  it looks like you are ahead of the curve anyway. 

Evernote have already stated they're not supporting older MacOS builds before 10.12,  so I don't think they're in a position to say 'this works for such and such version" because that statement in itself lays them open to complaints of "I'm having issues with your suggested version,  how do I fix them" and puts them straight back into supporting older OS's. 

Older Evernote versions are still available - from the release thread in the Forums if you can find the right one,  and from library sites like https://filehippo.com/mac/download_evernote_for_mac/

If anyone else here is still using El Capitan you might get some better suggestions,  but if it works - I'd suggest you don't upgrade from whatever you've got,  unless there are major issues.

 

Share this post


Link to post

I appreciate your reply! And I thought of what you said here just after I posted my comment. That being said, I did find elsewhere in the Forums a link to 7.2.3 which that user (I believe an employee) said worked with El Cap. I downloaded it, and I concur: 7.2.3 has been working for me (for a day anyway!) with no problems on this installation of El Capitan. Still, while I understand what you're saying about there being ways to find it, and the possible "liability" perhaps that might be implied, I can tell you that other software vendors, like Intuit, make available earlier versions of QuickBooks that were at the time compatible with specific operating system versions, and they pretty much are able to leave it at that. It could be a message like, "This software worked with that OS in 2014, and you're welcome to download it and use it, at your own risk. No support is or will be available." That's not a literal quote from anybody's website, but a way to handle it. Anyway I'm not gonna beat a dead horse. 7.2.3 works with El Capitan, I now have it and can confirm that it works, and it is downloadable from various sources. My work here is done. :) 

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...