Jump to content
marikomidori

Search not working

Recommended Posts

EN 7.2 (Premium account)

Mac OS 10.13.5 

Searching for a term (whether in 'all notes' or 'my notes') returns no or few results, even when I know the term is in several notes. As far as I can tell, searching by tag works fine. 

Help please! This renders Evernote almost completely useless to me as I upgraded to Premium precisely so as to be able to rely on full-text search and minimise burden of tagging all my notes.  

Share this post


Link to post

Hi.  Your search options as a Premium user shouldn;t be much different from any other account level,  except that the content of your PDF and other files will be OCR'd automatically.  You should be able to contact Support directly on https://help.evernote.com/hc/requests/new, (or https://twitter.com/evernotehelps if that link won't work for you.) 

If you'd like some suggestions from the Forums - can you give us an example of the terms you're searching for?

Share this post


Link to post
On 6/25/2018 at 5:28 AM, marikomidori said:

Searching for a term (whether in 'all notes' or 'my notes') returns no or few results, even when I know the term is in several notes. As far as I can tell, searching by tag works fine. 

To rebuild the search index

Option Key Help > Troubleshooting > Recreate

ADF893D4-65EA-46B7-A7A2-19844AF32C95.png.b81cc4542bc1582a202c2bc5b07e9446.png

 

Share this post


Link to post

Problem and Work Around: Searching for a specific term in Notes,  Using Mac High Sierra, Evernote Version 7.1.1 (456642 App Store) Editor: 45.1.5170 (bfe1ee3)

Evernote instructions indicate that when searching for a term, enclosing the text within quotes will return only those notes that have that term.

I followed that rule, but Evernote returned all notes that had any of the words within the term. This behavior replicated on all searches for terms that I tried.

Through a lot of trial and error, I discovered the issue.

I was looking for the term last day .  In the search of All Notes, I typed "last day".  However, only  last day" showed up in the search box.  The first quote was not there. And, the search returned all notes with either the word last or day.  See Attached.

However, if I entered  last day"  and then edited the search by adding the leading ", the search term then appeared as "last day" and only 6 of my notes were found, all of which contained only the term I was looking for.

I found that when entering the leading ", it disappeared from the search very quickly.  But if I entered the leading quote AND IMMEDIATELY the first letter of the search term, the quote stayed in place. I don't know what the glitch is, but now I know a work around that works for me.

Screen Shot 2018-06-29 at 7.23.41 AM.png

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...