Jump to content
laird

Disable hover links

Recommended Posts

Hi,

The hoverlink shown in my attachment started around the time of the web beta and while I like a lot of the web beta changes, this one drives me nuts because it obscures information and does not seem to be configurable.

I would love to find a way to disable this feature or possibly a pointer to a tampermonkey script to deal with it.  

 

Thanks,

 

Alan

Screen Shot 2018-05-23 at 9.31.36 AM.png

Share this post


Link to post

@laird I don't think there's another way to nicely access the edit/remove controls for links (although the link button at the top is... okay I guess), but here's a Tampermonkey script to hide them:

// ==UserScript==
// @name         Evernote Link Hover Controls Disabler
// @namespace    https://www.evernote.com/
// @version      0.1
// @description  Disable hover-over link controls
// @author       rezecib
// @match        http*://www.evernote.com/*
// @grant        GM_addStyle
// ==/UserScript==

(function() {
    'use strict';

    GM_addStyle(`
        #gwt-debug-FloatingLinkBar-root {
            visibility: hidden !important;
        }
    `);
})();

 

  • Like 2

Share this post


Link to post

This worked great until moving to the new format. 

I've been inspecting the source for about 30 minutes and it's way beyond me.

Any suggestions on what I would need to change to support the new format?

 

Thanks!

Alan

Share this post


Link to post

@laird This is the best I could come up with:

// ==UserScript==
// @name         Evernote Link Hover Controls Disabler
// @namespace    https://stage.evernote.com/
// @version      0.1
// @description  Disable hover-over link controls
// @author       rezecib
// @match        http*://stage.evernote.com/*
// @grant        GM_addStyle
// ==/UserScript==

(function() {
    'use strict';

    GM_addStyle(`
        #qa-NOTE_LINK_HOVER_DIV{
            visibility: hidden !important;
            height: 0px;
            width: 0px;
            padding: 0px;
        }
    `);
})();

The problem is that the hover uses a higher-level div style (#qa-ACTIONS_MODAL) for the box. If I set that one to be hidden, you'll impact other dropdown menus that also use that style. For example, the tags pop-up menu when you click on a tag at the bottom of the note window. You can test this out by swapping "#qa-NOTE_LINK_HOVER_DIV" with "#qa-ACTIONS_MODAL". 

CSS does not have a way to select the parent such that I could only apply the style to #qa-ACTIONS_MODAL divs that contain #qa-NOTE_LINK_HOVER_DIV.

I also tried some jQuery, but I couldn't get it to work. I think this has to do with the fact that the code doesn't exist until the point at which you hover.

Maybe you can play with it more and get it to work?

  • Like 1

Share this post


Link to post

Hi Scott, 

Thanks!  That's a lot cleaner than the hover links. 

It's interesting to hear how the hover has moved  to a different part of the CSS. 

I'd love to have this be an adjustable part of the UI but this userscript takes care of me nicely.

Thanks!

 

Alan

Share this post


Link to post

Looks like the UI has changed again and this Tampermonkey script no longer works.  I disabled my user scripts to make sure nothing else was causing an issue and I'm using the new web interface.  It feels a little like a transitional interface.  In chrome, links to other docs and sites are green links and there are no hoverlinks until you click in the doc and then they pop up and block the text view.

Switching back to the classic editor (which seems to be what was called the new editor the last two years) and the userscript works again and fonts are rendered more seamlessly.  

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...