Jump to content
iHanna

Search and replace replaces wrong

Recommended Posts

I have used "search and replace" many times for searching html and replacing some of the texts and tags etc. But now anything I copy into the search bar is replaced with coded signs for " and > and other signs. What happened? Can I change a setting to get it back?

 

For example I want to search for this in my text note: <script async src="//embedr.flickr.com/assets/client-code.js" charset="utf-8"></script>

But when I paste it in the search field it says: &lt;script async src=&quot;//embedr.flickr.com/assets/client-code.js&quot; charset=&quot;utf-8&quot;&gt;&lt;/script&gt;

so of course the search does not work! :-/ 

 

UPDATE: PC/Windows user. Used to work on the same platform, but since last update this happened.

 

Share this post


Link to post

Helps to mention which Evernote client you are using: Windows, Mac, Android, iOS, web. Version number helps, too...

  • Thanks 1

Share this post


Link to post
1 hour ago, iHanna said:

<script async src="//embedr.flickr.com/assets/client-code.js" charset="utf-8"></script>

I pasted the above into EN 6.11 GA and this is what I get.  It looks like it is working for me.  How are you generating the search text?  What does the search explanation look like?

ScreenClip.png.4aa701c2bd4725083c844bf9b6e23686.png

Share this post


Link to post

Yeah, search works, just not "search and replace" called on with CTRL + H. Did you try that too? I copied the search text from what I had pasted in the Evernote note, also formated to simplified format - or or what do you mean?

Share this post


Link to post

In the latest 6.11.2 release, I paste the string into the Ctrl+H's "Find text in note" field, and it looks fine, but pasting it into the "Replace with" field, it expands out to the " &lt;script async src=&quot;//embedr.flickr.com/assets/client-code.js&quot; charset=&quot;utf-8&quot;&gt;&lt;/script&gt;" line noise string.

  • Thanks 1

Share this post


Link to post
2 hours ago, iHanna said:

Yeah, search works, just not "search and replace" called on with CTRL + H. Did you try that too? I copied the search text from what I had pasted in the Evernote note, also formated to simplified format - or or what do you mean?

My bad, I did not try it in search and replace.  I get the same results as you, in both the find and the replace fields of Ctrl+H.  As it is or after removing any formatting.

  • Thanks 1

Share this post


Link to post

Yeah, thanks guys. Though this makes the function totally worthless, since that's not what I want to search for to replace. I hope it is fixed. Any chance the developers sees this? 

Share this post


Link to post
2 minutes ago, iHanna said:

Any chance the developers sees this? 

A better chance if you contact Evernote Support
All Accounts       Twitter @evernotehelps     
Paid Accounts    Contact Evernote Support 

  • Thanks 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...