Jump to content
cetanorak

Recent Change To Web App: Breaks Formatting of Pasted Code Snippets

Recommended Posts

I have been using Evernote to document some software development courses and for some time have been able to copy Javascript code directly from Visual Studio Code into the Evernote web application (not the Mac OS X client app). 

For months I would copy and paste code snippets directly from Visual Studio IDE into an Evernote note, and the result would look exactly like this:

1.thumb.png.9a2db84e1bd5550093c5ce1e1b1a3720.png

 

At some point in the past couple of weeks, something changed on the Evernote Web App.  Now all of my notes containing copy and pasted sections of code suddenly look like this:

2.thumb.png.46f11af49087855f6594e6a35e088078.png

 

AND I can no longer copy and paste directly from Visual Studio Code, as it results in this:

3.thumb.png.60c129d7ca7ff321d365ba1799b08ff5.png

 

Did some update to the Web Application break this?

Share this post


Link to post

Yes same problem here on chrome and windows application. I was searching to resolve this problem i thought it might be on my end and this is the only post that came out. I think its some kind of bug that appeared on recent update that also removed code block option from web client but i might be wrong, maybe they removed that neat feature.

Share this post


Link to post

FYI, to all of you software developers struggling with managing code snippets in Evernote, I just download an application called Quiver (Mac OS X), imported all of my Evernote Notebooks/Notes and have it saving everything to iCloud/DropBox. Copy/Paste right from an IDE works perfectly, preserves indentation and syntax highlighting.  Also, there is a feature where a note can be converted to a Code Cell, which looks and acts like a code editor.   Thus far, this application seems like the perfect solution for managing code snippets.

If you've been struggling with Code Snippets in Evernote, check out Quiver.

Share this post


Link to post

Just found out it works in firefox, it looks like latest chrome update broke it

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...