Jump to content
chronistin

Bug: Cursor position is ignored

Recommended Posts

I just noticed this which is seriously annoying:

Wenn working on a note,  writing or pasting appends to the end of the note, instead of where the cursor was placed. 

In detail:
I open a note, place the cursor where I want to add something, and start writing / pasting whatever I want to add. Note jumps, and new Content is placed at the end of the note. 

Please repair this.

 

 

 

  • Thanks 1

Share this post


Link to post

Which Evernote version are you using? The most recent release or the beta?

Share this post


Link to post

Most recent public release.

It has happened in prior releases, but only when sync starts or when the title auto-updates. Now it also happens without these reasons.

Share this post


Link to post

I've noticed this new "feature" also.  I ALT+Tab a lot to cut paste information.  When I do the cursor drops to the end of the document.  It's infuriating.

Share this post


Link to post

Just tested with 6.11 and if I am positioned in a note in EN,  then Alt+Tab to another window, copy something and Alt+Tab back to EN, the cursor is where I left it and the paste goes there.  FWIW. 

  • Like 1

Share this post


Link to post

I can confirm that pastes go where I put them in 6.11 GA

Share this post


Link to post

This has happened to me as well, quite frequently.  But, happens when I place the cursor, and then start to type.  Click in the window, go to type, cursor disappears, and the 'window/note' gets unselected.  Initially, seems that when I had on auto-formatting options, then it happened frequently. 

Started on the last couple of releases, only public- no betas. 

Does not happen in the web browser version, only on the desktop version. 

When I reboot my system, seems to resolve.  But if the system at all goes into sleep mode, then wakes up, then I get the behavior happening more frequently. 


 

Share this post


Link to post

Hmmn.  I did notice in 6.11 that when creating a new note there was some 'thinking time' (for Evernote) before that note was ready to take input - I assume it was creating the new note in my database.  Just tried again in the new beta 6.12 and there seems less time before the note is ready - but it is still necessary to check to see a blinking cursor before you start typing...

Share this post


Link to post

okay, some feedback, hopefully the developers willlook at this information:

For review – (Win 10 on two different computers)

Problem:

After choosing a note, then selecting a position for the blinking cursor, the cursor will disappear and the note seems disselected when starting to type. when I subsequently select the note again and place the cursor, I can type normally.

Noted patterns:
- if my computer is shut down, then I don't seem to have a problem. However, if my computer enters a sleep mode, I have more problems after it wakes up.

Workarounds:

- I have now found that opening the task manager, there are multiple subprocesses that are present. After ending each of these tasks, the problems seem to resolve. there usually about five of them, labeled Evernote sub processes.

I hope someone can use this information!




Share this post


Link to post

Ok, update: I've noticed-

if I have a fresh restart, EN works like normal. However, if it enter's sleep, then I will have the problem regularly. If I go into the Task Manager and end the processes, sometimes this will stop it from happening.

Hope this helps!

update #2: 
If the window get's deselected and I ALT+TAB to a different window/program, I can cycle back to EN, and it will let me interact normally (or I can immediately ALT+SHIFT+TAB back as well)

Share this post


Link to post

Update #3: 

I've noted that when starting or working with a note, I'm able to alter the title without problems, but soon as I shift to the body (by tabbing or by clicking somwhere with a mouse, the blinking cursor is placed), as soon as I enter anything with the keyboard, the window or note is deselected. 

 

Share this post


Link to post
10 hours ago, Inqzitr said:

Update #3: 

I've noted that when starting or working with a note, I'm able to alter the title without problems, but soon as I shift to the body (by tabbing or by clicking somwhere with a mouse, the blinking cursor is placed), as soon as I enter anything with the keyboard, the window or note is deselected. 

 

I am having same problems.  Super frustrating.  This is in addition to the fact that when I click the global key for bringing a new evernote note, it remains in background.  Perhaps these two issues are unrelated.  But the double whammy has managed to kill my productivity boosts from EN.  Seriously, any help?

Share this post


Link to post

Same here. I've also noticed this very annoying behavior: I select some text to copy it, as soon as I hit the Ctrl key, before I can hit the "C" to do the copy, it unselects it! This last release has some very annoying problems I sure hope they fix soon. 

  • Thanks 1

Share this post


Link to post

I'm having the same issue.  Super annoying!

I click into a note to add or edit it.  Then I have to wait a few seconds and then click again or else the cursor will jump to the bottom or disappear completely.

Please fix.  It kills my productivity when taking notes and jumping between applications for copy/paste.

Share this post


Link to post
22 hours ago, Tony Ace said:

I'm having the same issue.  Super annoying!

I click into a note to add or edit it.  Then I have to wait a few seconds and then click again or else the cursor will jump to the bottom or disappear completely.

Please fix.  It kills my productivity when taking notes and jumping between applications for copy/paste.

This describes my issue very well.  I am a big fan of Evernote, but this issue is really getting a little long in the tooth for me.

  • Thanks 1

Share this post


Link to post

It sounds incredible that this cursing - pardon - cursor issue, reported during month in several threads by dozens of users, remains unsolved,  despite of several  updates distributed since (current: 6.11.2.7027).

I've really been appreciating Evernote for years, but now slolwy begin to doubt of the long-term reliability of this product and thus seriously begin to think of alternatives. 

Share this post


Link to post

Ok, something else noted... hopefully this will help the Devs solve this problem.

If the cursor position is de-selected, if I hit TAB 2x, the cursor comes back into position. 

[EDIT]

I was incorrect;  it does NOT return to the original cursor position, but simply goes to the beginning of the note, and then I can edit normally. 


Thanks!

Share this post


Link to post

I have exactly the same problem - I have to click repeatedly within a note before I start to edit it otherwise it jumps around in the note randomly and doesn't respond to the text I type.  

This also happens when trying to copy and paste sections of text, where it simply isn't recognised, and even a right click "copy" despite seeming to acknowledge the command, doesn't work.  

This is such an inconvenience that if it doesn't get fixed I will have to reconsider my subscription and whether there are alternatives to Evernote.  

Share this post


Link to post

I'm afraid you'll be disappointed in your search for alternatives.

Which makes it all the more urgent for the developers to fix this annoying bug.

 

Share this post


Link to post

Hi all - this may be some good news - after I downloaded 6.14.1.7551 (307551) yesterday, the problem has disappeared !

(at least I haven't been able to reproduce it)

Share this post


Link to post

That's great!  I'll have to download it. 

A couple other observations... hopefully this will help the Devs solve this problem if this patch hadn't...

  • If the cursor position is de-selected, if I hit TAB 2x, the cursor comes back into position, but only at the top of the note. 
  • if I have adobe acrobat open, even in the background, it seems to happen more frequently. 

 

Thanks!

Share this post


Link to post

after I downloaded 6.14.1.7551 (307551) yesterday

Hm, when I do "check for updates", it says I have the latest (6.13.14.7474 (307474) Public (CE Build ce-48.0.5483)). 

How do I get that 7551 you found?

Thanks,

Lee

Share this post


Link to post
36 minutes ago, LeeBreisacher said:

How do I get that 7551 you found?

This is a beta version. To get betas: Tools / Options / General / "Enable beta features and updates".

Use with caution; beta versions are not always stable. The usual precautions apply. The forum section that usually contains a topic for each release (general and beta) is here: https://discussion.evernote.com/forum/225-evernote-for-windows/.

  • Thanks 1

Share this post


Link to post

EDITED: partly solved after updating to 6.13 (cursor sometimes dissapears after couple of seconds of writing, but most of times it's working now)

WINDOWS 10

I think it's connected problem to the mentioned above.

After switching widnows with ALT + TAB when I place cursor on screen and start writing. It dissapears and I need to place cursor with mouse again. Every time. 

Frustrating!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...