Jump to content
Brian Goldin

Help - Search not working with upgrade

Recommended Posts

I've recently upgraded to Version 6.13 (455674 App Store) running on MacOS. Search used to work beautifully but now when I search for something nothing is returned. Here are a few screenshots to illustrate what's happening.

1) First a view of some of my notes:
download?id=YkDFWq1xpFOLvWmEppeUvozRrYsW 

2) Searching for a term that is in one of the titles does not return any results. Using "Leadership"
download?id=PnmxBSe4sg5Xerld86L8bhplfAnX

3) searching for a word "Fema" that is used in the body of the first note also doesn't work

image.thumb.png.c355552e2532ef25a8ea753f6816f9b3.png

At this point, without search, i'm finding that evernote is nearly useless

 

 

 

 

 

image.png

image.png

image.png

image.png

  • Like 1

Share this post


Link to post
On 2017-11-08 at 3:39 AM, Brian Goldin said:

I've recently upgraded to Version 6.13 (455674 App Store) running on MacOS. Search used to work beautifully but now when I search for something nothing is returned.

 

  • Like 2
  • Thanks 2

Share this post


Link to post

Had the same problem. In my eyes, this is a pretty major bug - while I could not search it turned Evernote from an incredibly useful tool I use everyday to being near useless.

Managed to get this back working as well, but instructions above were not clear and took me a while to get working again. Basically needed to type 'Troubleshooting' in the help search box to find it, as was not there by default. Really, there should be a simple click-option to recreate the search indexing around the search box and asking the user if they want to do this immediately after searching, as I can't imagine someone who has used evernote for a long time not wanting to be able to search all their notes.

 

Share this post


Link to post

I'm assuming that there was a problem with my upgrade that caused the index to be useless / corrupt. Once rebuilding the index everything has been working without issue :D

Share this post


Link to post

rebuild the search index Hold down the option key, click Help then Troubleshooting > Recreate Full Text Search Index

worked for me too. Thanks!!

Share this post


Link to post

I've got the same problem since 2 updates. I'm on mac, french user. 

DO SOMETHING IN YOUR NEXT UPDATE PLZ !!! 

Share this post


Link to post
On 11/13/2017 at 1:51 AM, scottan said:

Had the same problem. In my eyes, this is a pretty major bug - while I could not search it turned Evernote from an incredibly useful tool I use everyday to being near useless.

Managed to get this back working as well, but instructions above were not clear and took me a while to get working again. Basically needed to type 'Troubleshooting' in the help search box to find it, as was not there by default. Really, there should be a simple click-option to recreate the search indexing around the search box and asking the user if they want to do this immediately after searching, as I can't imagine someone who has used evernote for a long time not wanting to be able to search all their notes.

 

I agree. This happened to me the first time on upgrade to 6.13.3 (455969 Direct) for Mac today. Which means, I think, it's been happening over a month and Evernote hasn't fixed it. It's good to have the rebuild index option, but who would have thought to use that apart from the forums?

Share this post


Link to post

I appreciate the suggestion to rebuild the search index. I see that in several threads regarding the search function. However, just so the Evernote team knows, that doesn't work for everyone. I've rebuilt the search index several times and my Evernote still returns zero results on most searches. And I've read that I'm not the only one. Search works like a charm on my iPad, but not on my iMac or MacBook Pro .

Share this post


Link to post
13 minutes ago, Kirkus said:

I appreciate the suggestion to rebuild the search index. I see that in several threads regarding the search function. However, just so the Evernote team knows, that doesn't work for everyone. I've rebuilt the search index several times and my Evernote still returns zero results on most searches. And I've read that I'm not the only one. Search works like a charm on my iPad, but not on my iMac or MacBook Pro .

A next troubleshooting step is to resync your database.

          Hold the **Shift** and **Option** keys on your keyboard and click the sync wheel 

Share this post


Link to post

After taking an update, I'm having the same issue. Thanks for bringing this up, Brian.  And- wow, I'm pretty shocked to find out just how much I rely on search.

Share this post


Link to post
On 1/1/2018 at 9:40 AM, DTLow said:

A next troubleshooting step is to resync your database.

          Hold the **Shift** and **Option** keys on your keyboard and click the sync wheel 

Thanks for the suggestion, DTLow. But that made no difference. I also recreated the full text search index again. The search still doesn't work for me. And I see more and more users reporting the problem.

It's now become a deal-breaker. I haven't seen much response from the Evernote team, which is discouraging. I simply don't have time to keep troubleshooting a problem that, imo, should be addressed in a better way than what I'm seeing. It's too bad too. I used to depend on Evernote pretty much daily. But I'm off to search for a replacement.

Thanks to everyone for their suggestions.

Share this post


Link to post

I have this problem as well.

I think I am rebuilding my search index as I type this, however after giving me the warning that it may affect performance / take time...there seems to be no feedback that it is working (re-indexing) or notification that it's done...so I'm puzzled.  Used to be a mac cardinal rule to get some kind of feedback on operations like this. Something spinning, a progress bar, what have you...

Share this post


Link to post
On 1/11/2018 at 7:42 AM, kdforEvernote said:

I have this problem as well.

I think I am rebuilding my search index as I type this, however after giving me the warning that it may affect performance / take time...there seems to be no feedback that it is working (re-indexing) or notification that it's done...so I'm puzzled.  Used to be a mac cardinal rule to get some kind of feedback on operations like this. Something spinning, a progress bar, what have you...

I have the same problem. How do I know that I've recreated the index?

Share this post


Link to post

I just noticed the same issue on my Mac now. I started the rebuilding, but there is no sign of Evernote actually doing anything...NOT GOOD!

Share this post


Link to post
On 2018-01-10 at 8:42 PM, kdforEvernote said:

there seems to be no feedback that it is working (re-indexing) or notification that it's done...so I'm puzzled.

 

7 minutes ago, Atze552 said:

I just noticed the same issue on my Mac now. I started the rebuilding, but there is no sign of Evernote actually doing anything...NOT GOOD!

You can monitor your Activity Log5a5b8b3f663e6_ScreenShot2018-01-14at08_53_50.png.b932b28874e3b201168f4c4b60e138f2.png

Share this post


Link to post
2 minutes ago, DTLow said:

You can monitor your Activity Log

Thanks for the tip - not really transparent though what it does and how long it is going to take. I just noticed notes missing from the Mac as well, that still show up on iOs. Maybe I should try the complete rebuild of the database?

 

Share this post


Link to post
1 minute ago, Atze552 said:

Maybe I should try the complete rebuild of the database?

That would be my recommendation

You can start a full sync by:   Hold the Shift and Option keys on your keyboard and click the sync wheel

Share this post


Link to post

Hmmm, rebuild runs for about 40 seconds, then there is nothing happening anymore in the activities list. How long should a rebuild take? Expected longer than that. And the search still does not work as expected. I tried altering a note (e.g. removing keywords) and after that the notes show up in search results. 

Share this post


Link to post
5 minutes ago, Atze552 said:

Hmmm, rebuild runs for about 40 seconds, then there is nothing happening anymore in the activities list. How long should a rebuild take? Expected longer than that.

My full sync takes about an hour (10,000 notes)5a5b909a25889_ScreenShot2018-01-14at09_16_49.png.60799cd67db367c10bce632ccd20a630.png

Ths activity log shows the sync activity

Share this post


Link to post

DT Low, nice workaround to look at activity monitor.

My comment is more to the evernote team. Mac programming "toolbox" used to spec that when stuff like this is going on the program provide the user with some sort of feedback (thus the spinning wheels, progress bars etc.) it's just good / courteous programming.

Also: be careful not to conflate re-building the index with full sync. Two different things.

It does SEEM as though the last release/update somehow did a number on many of our indices.

Share this post


Link to post

same issue, I submitted a support ticket...has anyone gotten a response from support or anyone at evernote?

Share this post


Link to post

Same thing here, MacOS High Sierra with latest updates, Evernote 6.13.1, does not find certain notes even with the search terms being in the description of the note, not even the note body content, let alone full-text content in attached files. Evernote on iOS still seems to work properly - but I would assume that the search index (or at least the process of indexing itself) for handheld devices is done centrally in a cloud.

This is a pretty serious issue, as it makes Evernote basically a "copy to dev 0" storage... I found this out purely by coincidence, as a search on my iPad delivered results, whereas an identical search on my Macbook Pro came up empty.

Started the index rebuild, but I find it difficult to assess from the event log wether or not the rebuild process has finished. The log is almost incomprehensible, (or should entires like 2018/01/17 23:29:30:025 I|*   83XX0 -[ENUXPuppetmaster evaluateRules] | >UXPuppetmaster< Object: <ENUXPuppetmaster: 0x6040XXXX900> Evaluated script version: mac.169 should make any sense to me?) making me wish for something like the Windows Event log. Will monitor this thread for a couple of days before I submit a ticket. I would guess or hope the Evernote Dev Team is aware of the problem and working on a solution...

Even more important would be a future mechanism to prevent this or address this by making users aware, e.g. by actively communicating a search index problem on a device; otherwise, if a search comes up empty, one might just think that one forgot to save it in Evernote. At least, up to this point, I would not have thought of checking on other devices if I get results if the first one delivered null...

Let's face it: Search is THE USP of Evernote Premium if you consider the sheer volume of data you could theoretically store each month (and I am utilizing maybe 1% of my monthly upload volume), without a working search index, it is basically a data graveyard. If I wanted unreliable search results, I´d just use my company's MS Outlook and save everything as a mail...

Share this post


Link to post

Same for me, Evernote without a working function is useless........ 

Same as other, when i re-index i don't see any progress-bar and i don't understand anything in the log activity monitoring.. 

And sincerely i don't have the feeling it works properly since i've done the re-indexation, it's a little bit better, but not like before, some of my notes doesn't appear in the list, it finds some things i don't care about.

I have to search my notes on my smartphone to be sure to find it. EVERNOTE MUST CORRECT THAT QUICKLY !!!

Share this post


Link to post

Having the same problem. Search (on OSX Desktop App) is completely useless. Will only search the current notebook, no matter what I do will not find notes containing keywords in other notebooks. 

Please fix this. It's working in the online client so I don't see why this cant be fixed, especially when a google search returns so many users of Evernote having the same problem. 

  • Like 1

Share this post


Link to post

Same issue. I don't even know how to create a support ticket for Evernote to even look into it. Chat is disabled during work hours, I am not upgrading to call them. Help!

Share this post


Link to post

I am having the same issue! I am trying to re-index but can't tell if it is working. Has anyone found a solution yet?

Share this post


Link to post

I just encountered the same issue earlier today. I really like Evernote and I use it on a daily basis but I couldn't believe what a mess this was. Without this forum, I would have had no idea how to solve it. The most important thing in Evernote is the search bar. How could it not have been seen as a priority to protect this in the upgrade process (or automatically reindex the search as part of the upgrade process).....

Don't know what to say really. Even worse that this still hasn't been addressed so many months after the first issues. Also, there was nothing to indicate whether the re-indexing was still running, if it finished successfully, failed.... UX at its worst.

Share this post


Link to post

I'm glad I'm not the only one.   Same issues:

1.  returning "0 results"

2.  full indexing doesn't do do anything.  no activity at all

3.  Activity log is just a jumble of code

4.  Has taken me 30 minutes of attempted problem solving to even get to this forum

For a non-programmer, this is unacceptable.

If I can't find a solution in the next week, I'm going to just use dropbox or google docs.  Someone please help!

Share this post


Link to post

The Lack of any official response is quite annoying after such a long time users posting the issues still exist...

 

I am not sure if everything is supposed to be working right now or not. Leads to me questioning if the search actually is trustworthy and accordingly the whole tool...? Really sad to see that after more than a decade of using Evernote. 

Share this post


Link to post

Stunning that this issue has not been addressed. 

A couple of observations.

  • I have noted that the latest Evernote installed on Windows 7 and 10 behave differently with saved searches. 
  • The web version and app on iOS work fine with the same saved searches
  • I fortunately had an install file for an older version (6.5.4.4720) which I have installed and the saved searches work well. Not sure what version introduced the bug, but I would rather be running a version that is over two years old that works than a new version that does not!

I am disappointed that Evernote tech support does not seem to be reading the posts on this forum or at least acknowledging that they are and let us know they are working on a solution!

Share this post


Link to post

Just upgraded from an old 6.x to 7.1.1 and search is not returning all the results. For example, searching for the word "the" returns only 99 results. This problem has just gutted half of the functionality of Evernote.

How can this be?

 

Share this post


Link to post
4 minutes ago, ybakos said:

This problem has just gutted half of the functionality of Evernote.

Agreed. Hopefully it will be resolved soon despite being an issue for the past six months – far too long for such a significant bug to remain unresolved.

Share this post


Link to post

 


1. Open Evernote on your Mac
2. Hold down the Option key on your keyboard and select Help from your Mac's menu bar
3. Select Troubleshooting > Recreate Full Text Search Index

 

  • Like 1

Share this post


Link to post
1 hour ago, AllenMCC said:

1. Open Evernote on your Mac
2. Hold down the Option key on your keyboard and select Help from your Mac's menu bar
3. Select Troubleshooting > Recreate Full Text Search Index

 

This does not solve the problem. It is a known bug which support is working on and a fix will be incorporated into the next version..... we hope.

Share this post


Link to post

Hit the same problem after upgraded to version 7.2.  The tips on "Troubleshoot" / "Rebuild Index" saved my day.  Can't believe this bug still exists.

Share this post


Link to post

Using Evernote 7.2 on Mac OS 10.13.5.  Search does not work properly after upgrade.  I followed other users' advice to recreate my index but I cannot access the command.  When I search in Help for troubleshoot, there are no returns.

  • Like 1

Share this post


Link to post

I'm having the same problem!

I have tried both solutions listed here (rebuilding the index and option+shift+sync circle click).  The lack of feedback on these is also frustrating.  In any case, as users above, notes with the word I'm searching for *in the title* don't appear when I search.  This is extremely frustrating.  Have paid for evernote for several years, but will discontinue/migrate to another system if this isn't fixed as it makes Evernote nearly worthless.

Using 10.13.5, Evernote 7.2
 

Share this post


Link to post

@ericnoah  On Mac, press the "option/alt" key and at the same time click on the Help menu.  You can then find the "Troubleshooting..." item under the menu.

Share this post


Link to post

Thanks Patrick for your reply.  I did press the option key and click on the Help menu, but for some reason the bottom half of the menu did not appear.  I just tried again and it worked,.  We'll see if recreating the index solves the problem.  

Share this post


Link to post
On 6/8/2018 at 3:31 AM, Mark Miller said:

@ybakos @JimCom The Mac team is aware of this issue and we will investigate it in the very near future.

Any chance on receiving a response from Evernote which is a bit less vague?

I - and I assume many others - heavily rely on Evernote for a proper workflow. Looking into this issue has so far taken up the first 30 min of my day with it still not being resolved. 

Tried the option / troubleshoot suggested and hope this will fix it.  

Share this post


Link to post

Funny thing--I restarted my Macbook without reindexing and now Evernote search appears to be working perfectly.

Share this post


Link to post

I had this exact same issue on Mac OS 10.13.6 on Evernote 7.2.2. 

The steps above did not resolve my issue.  The "Troubleshooter -> Recreate Full Text Search Index" just hung there and it wasn't doing anything according to the "Activity Log..."

This is what I had to do to resolve it.

  1. Uninstall Evernote by dragging the app into "Trash"
  2. Empty your "Trash" bin
  3. Now, in your Finder, and do a search on "evernote"
  4. The "com.evernote.Evernote" should appear in your search results
  5. With your cursor over that folder, do a two finger click and select "Get Info"
  6. Double-click on the folder icon under "Preview"  (if a new Finder window doesn't open up, you may need to go to your existing Finder window, highlight another folder other than "com.evernote.Evernote", and then go back to the Get Info window and double-click in the preview folder)
  7. A new Finder window should open up.  It should have "com.evernote.Evernote" highlighted, and its parent folder "CoreData" highlighted.  Scroll to the left to get to the "Container" folder
  8. Within the "Container" folder, you'll find two folders that start with "com.evernote".  Delete both of these folders (and all their subfolders).  (DO NOT delete the "Container" folder)
  9. Empty your "Trash" bin
  10. Restart your machine.  This should completely remove all of your previous data associated with Evernote.
  11. Once your Mac is restarted, open your AppStore and reinstall Evernote
  12. Login with your Evernote account.

At this point, your fresh install of Evernote should sync and reindex all your notes.  This worked for me.  Hope this works for all of you.

Please note, this is what worked for me.  You're doing this at your own risk.

 

 

Share this post


Link to post

I am having the same problem with search in V7.6. The comprehensive search feature is THE reason I use Evernote. This needs fixed!

 

  • Thanks 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...