• 0
Chantal Leonard

Evernote for Windows 6.8 Beta 4 Released

Idea

Hi folks - 

We're excited to announce Windows 6.8 Beta 4. You can install it here or by checking for updates. Fixes in this beta include:

  • A fix for an issue where recording audio was not saved when switching notes
  • A fix for an issue preventing clipping of a screenshot unless a notebook is selected in the left panel 
  • A fix for an intermittent issue when drag and drop of an image into a note resizes the image to take up the entire width and height of the note space. 
  • A fix for an issue with Find and Replace bar can be duplicated in the note 
  • A fix for an issue where the app crashes when a user navigates to the upgrade screen 
  • A fix for an issue where editing encrypted text and then navigating back and forth between notes quickly loses those edits.
  • A fix for an issue where local links no longer work 
  • A fix for an issue where encrypting text using Ctrl+Shift+x no longer works 
  • A fix for an issue where file attachments in a table go in a wrong cell
  • A fix for an intermittent issue where the Windows app crashes immediately after opening note

We also made a small tweak to the sidebar background color, to something that's a bit more neutral to better complement some of the other colors we use in our color palette.  Let us know what you think and if you have any questions on the changes.

Thanks,

Chantal and the rest of the Windows team.

---------------------------------------

Release Notes for Windows version 6.8

Note: Version 6.8 is supported in OS versions Windows 7 and up.

Improved

We've made a number of changes to how a note is displayed. Some of the key changes include:

  • Better Print results for notes including highlighting, italics and underline and the ability to print to PDF
  • If you have a touch monitor, you can now pan notes with the swipe of a finger
  • More quickly start a bulleted list using a hyphen. In addition to using the still supported '*'+space shortcut, you can now also use '-'+space shortcut

Fixed

This release has many bug fixes. Some notable fixes include

  • A fix where words selected in a note using touch caused the application to crash
  • A fix where users were unable to record audio
  • A fix where attachments dropped in notes received a temporary filename
  • A fix where replace in note (Ctrl+H) wasn't replacing text
  • A fix where a debug port was inadvertently left active
  • Like 1

Share this post


Link to post

56 replies to this idea

Recommended Posts

  • 2
11 hours ago, keisoko said:

It seems that I am unable to use the numbered list format inside the code block to represent line numbers in Beta 4. Even switching between notes, as I was able to do in Beta 3, does not work anymore. If I apply numbered list to the pasted source code first, I then cannot use code block format.

The intended behavior of code block is to only allow formatted text and rich links. In previous versions of the app you may have been able to place other items into code block, but that was not the intended behavior.

Going forward these items will not be able to be placed into code block:

  1. Lists
  2. Todos / checkboxes
  3. Horizontal rules
  4. Tables
  5. Attachments
  6. Images
  7. Encryption blocks
  8. Additional code blocks within a code block
  • Like 2

Share this post


Link to post
  • 0

It seems that I am unable to use the numbered list format inside the code block to represent line numbers in Beta 4. Even switching between notes, as I was able to do in Beta 3, does not work anymore. If I apply numbered list to the pasted source code first, I then cannot use code block format.

Share this post


Link to post
  • 0

Hi
Just updated to the latest beta (6.8.4.6134 (306134) Prerelease (CE Build ce-1.30.2933)).
When trying to drag files from Outlook (attachment in an email) into an Evernote note, I get the "forbidden" cursor.
If I drop the file in the note-list, a new note is created with the attachment inside.
Dragging from my desktop or file browser (I use Directory Opus), everything works OK and the file is attached to the note.
 

Share this post


Link to post
  • 0

Looks like the problems of dragging attachments into notes from Outlook still remain in this new beta release, hopefully to be fixed soon! I'm staying at 6.7.5.

Share this post


Link to post
  • 0

I am consistently getting crashes when searching for a note then opening it.

  1. Go to the Notebooks icon so all notes are visible.
  2. Type in 3 tags and two key words
  3. 3 notes are found. OPen the one I want.
  4. Header is fine, but body is blank. The body is there in body window of LIst View, but empty when I open the note in its own window.
  5. Close the window. (as if to try again)
  6. Evernote vanishes.

There is nothing in the CRASHES folder, but the app log has this kind of thing in it. You can see where it crashed and started over on a new launch.

Quote

10:38:28 [INFO   ] [16216] [17412] Service search [tag:excel tag:powerquery tag:powerpivot r] found 2 notes in 0.221732 sec
10:38:28 [INFO   ] [16216] [17412] Service search [tag:excel tag:powerquery tag:powerpivot re] found 2 notes in 0.355729 sec
10:38:28 [INFO   ] [16216] [17412] Service search [tag:excel tag:powerquery tag:powerpivot refre] found 0 notes in 0.100771 sec
10:38:28 [INFO   ] [16216] [17412] Service search [tag:excel tag:powerquery tag:powerpivot refres] found 0 notes in 0.070532 sec
10:38:29 [INFO   ] [16216] [17412] Service search [tag:excel tag:powerquery tag:powerpivot refresh] found 3 notes in 0.114137 sec
10:38:29 [INFO   ] [16216] [17412] Service search [tag:excel tag:powerquery tag:powerpivot refresh] found 3 notes in 0.126278 sec
10:38:29 [INFO   ] [16216] [17412] Service search [tag:excel tag:powerquery tag:powerpivot refresh d] found 2 notes in 0.174044 sec
10:38:29 [INFO   ] [16216] [17412] Service search [tag:excel tag:powerquery tag:powerpivot refresh dat] found 0 notes in 0.114684 sec
10:38:29 [INFO   ] [16216] [17412] Service search [tag:excel tag:powerquery tag:powerpivot refresh date] found 2 notes in 0.088945 sec
10:38:32 [INFO   ] [1060] [6440] Starting EvernoteSubprocess.exe
10:38:32 [INFO   ] [1060] [6440]  * Command-line params: --type=renderer --no-sandbox --disable-databases --primordial-pipe-token=F21E9682571F46FA5BCFDB3C82A7EA12 --lang=en-US --lang=en-US --log-file="C:\Users\XXXXXXXX\Evernote\Logs\cef.log" --log-severity=disable --product-version="Evernote Windows/306134 (en-US, DDL); Windows/10.0.0 (Win64);" --enable-pinch --device-scale-factor=2 --num-raster-threads=2 --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,3553;0,11,3553;0,12,3553;0,13,3553;0,14,3553;0,15,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,3553;1,11,3553;1,12,3553;1,13,3553;1,14,3553;1,15,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,3553;2,11,3553;2,12,3553;2,13,3553;2,14,3553;2,15,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,3553;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,3553;3,13,3553;3,14,3553;3,15,3553;4,0,3553;4,1,3553;4,2,3553;4,3,3553;4,4,3553;4,5,3553;4,6,3553;4,7,3553;4,8,3553;4,9,3553;4,10,3553;4,11,3553;4,12,3553;4,13,3553;4,14,3553;4,15,3553 --service-request-channel-token=F21E9682571F46FA5BCFDB3C82A7EA12 --renderer-client-id=11 --mojo-platform-channel-handle=4756 /prefetch:1

[8120] Log opened on 2017/11/08 10:38:57 (UTC-8:00), logging level: [INFO   ]

10:38:57 [INFO   ] [8120] [14936] Command line: "C:\Program Files (x86)\Evernote\Evernote\Evernote.exe" 
10:38:57 [INFO   ] [8120] [14936] Evernote for Windows 6.8.4.6134 (306134) Prerelease

...

I can go directly to the notebook it is in, search there with no tags, and open the note fine.

Even after opening the note this way, then going back and repeating steps above, it locks up, but in step 4 it shows the body. When I close it, Evernote freezes with "not responding" and never comes back. Oh, wait. It just crashed and vanished on its own. Didn't have to kill it.

I am attaching the enex for the note too in case you think that has something to do with it.

BTW, I use this note all of the time, and generally search the same way. Worked fine before this beta.

 

Evernote.enex

Edited by EdH
Added the relevant note.

Share this post


Link to post
  • 0

The underline for search terms is broken. (same note as above) - the search term was:

refresh date

this is what the UI shows

 

2017-11-08_11-40-15.png

Share this post


Link to post
  • 0
54 minutes ago, EdH said:

Go to the Notebooks icon so all notes are visible.

  1. Type in 3 tags and two key words

    I am consistently getting crashes when searching for a note then opening it.

  2. 3 notes are found. OPen the one I want.
  3. Header is fine, but body is blank. The body is there in body window of LIst View, but empty when I open the note in its own window.
  4. Close the window. (as if to try again)
  5. Evernote vanishes.

There is nothing in the CRASHES folder, but the app log has this kind of thing in it. You can see where it crashed and started over on a new launch.

I can go directly to the notebook it is in, search there with no tags, and open the note fine.

Even after opening the note this way, then going back and repeating steps above, it locks up, but in step 4 it shows the body. When I close it, Evernote freezes with "not responding" and never comes back. Oh, wait. It just crashed and vanished on its own. Didn't have to kill it.

 Thanks for the report. I'm trying to reproduce on my end with the .enex, but can't. What's your note list set to? Snippet, Top List, Side List, etc. Does the crash continue after selecting File > Exit  and reopening the app? 

Share this post


Link to post
  • 0
4 minutes ago, Austin G said:

 Thanks for the report. I'm trying to reproduce on my end with the .enex, but can't. What's your note list set to? Snippet, Top List, Side List, etc. Does the crash continue after selecting File > Exit  and reopening the app? 

Left Panel, Note List, and Note Panel are checked in view, so upper right is note list, and lower right is the note body.

There is no "File Exit" - either the app crashes on its own, or hangs indefinitely until I kill it via Task Manager. It never recovers in that session.

ANd the note is in a notebook that is in a stack. Finding the note in the notebook doesn't crash. Seems to only crash when I am in the "Notebook" icon showing all 22,000+ notes.

EDIT: Also crashes when in the stack and not the notebook.

If I search for:

tag:excel refresh date

it doesn't crash. It is like it requires all 3 tags to be used.

Share this post


Link to post
  • 0

Thank You for fixing the pdf extra space but is it just me or does other feels that the pdf viewer is like smaller than the size of an a4 paper

Share this post


Link to post
  • 0

Any reason why you changed the color of the left panel in the dark theme? I definitely prefered the dark navy blue to the new bland greyish color..

Share this post


Link to post
  • 0
19 minutes ago, gustavgi said:

Any reason why you changed the color of the left panel in the dark theme? I definitely prefered the dark navy blue to the new bland greyish color..

Sort of a head scratchier and begs the question, with everything else going on why a "subtle" change to the UI?  Weird.

Share this post


Link to post
  • 0
10 hours ago, fchandler said:

Looks like the problems of dragging attachments into notes from Outlook still remain in this new beta release, hopefully to be fixed soon! I'm staying at 6.7.5.

Thanks for mentioning - something we're prioritizing for our next Beta. 

Share this post


Link to post
  • 0
3 hours ago, gustavgi said:

Any reason why you changed the color of the left panel in the dark theme? I definitely prefered the dark navy blue to the new bland greyish color..

Good callout - I've added to the the list of the changes in the post description. We're doing this to align our color usage across platforms. Expect to see this change make its way across desktop platforms. In terms of how it was selected, we were looking for a color that would complement the other colors we use, including our green. Expect to start seeing more use of that accent color in parts of our UI as we continue doing improvements. A good example of this is the new column/row button in the editor. 

 

 

  • Like 1

Share this post


Link to post
  • 0

Same bug as before in the saved searches:

 

In the German version the search operator "any" is changed to "Alle" (all of).

 

The same search works in the web client, not in the windows client. Already subject of a separat topic resp. referred to in the topic Beta 3.

Share this post


Link to post
  • 0
8 hours ago, Chantal Leonard said:

Good callout - I've added to the the list of the changes in the post description. We're doing this to align our color usage across platforms. Expect to see this change make its way across desktop platforms. In terms of how it was selected, we were looking for a color that would complement the other colors we use, including our green. Expect to start seeing more use of that accent color in parts of our UI as we continue doing improvements. A good example of this is the new column/row button in the editor. 

 

 

Would it be possible to have additional color options for the the left panel color rather than just the current light and dark theme? 

Share this post


Link to post
  • 0
9 hours ago, Chantal Leonard said:

Good callout - I've added to the the list of the changes in the post description. We're doing this to align our color usage across platforms. Expect to see this change make its way across desktop platforms. In terms of how it was selected, we were looking for a color that would complement the other colors we use, including our green. Expect to start seeing more use of that accent color in parts of our UI as we continue doing improvements. A good example of this is the new column/row button in the editor. 

 

 

I personally think you should mainly focus on what background color works with white text, and not what complements Evernote-green. A more greyish background color makes the white text less visible. Since there is no scaling option in Evernote, every change for the worse affects work on HDPI monitors. I also think that the previous dark navy color complemented Evernote-green well, as well as the blue-green-grey UI elements of drop down menus and tags etc.

Share this post


Link to post
  • 0
20 hours ago, EdH said:

Left Panel, Note List, and Note Panel are checked in view, so upper right is note list, and lower right is the note body.

There is no "File Exit" - either the app crashes on its own, or hangs indefinitely until I kill it via Task Manager. It never recovers in that session.

ANd the note is in a notebook that is in a stack. Finding the note in the notebook doesn't crash. Seems to only crash when I am in the "Notebook" icon showing all 22,000+ notes.

EDIT: Also crashes when in the stack and not the notebook.

If I search for:

tag:excel refresh date

it doesn't crash. It is like it requires all 3 tags to be used.

thanks for the update and additional info. We're looking into it! 

  • Like 1

Share this post


Link to post
  • 0
13 hours ago, Chantal Leonard said:

Good callout - I've added to the the list of the changes in the post description. We're doing this to align our color usage across platforms. Expect to see this change make its way across desktop platforms. In terms of how it was selected, we were looking for a color that would complement the other colors we use, including our green. Expect to start seeing more use of that accent color in parts of our UI as we continue doing improvements. A good example of this is the new column/row button in the editor. 

 

 

FYI, the light color is different when the left panel is closed or opened, white vs light gray.  I typically have the left panel closed so I really didn't notice until now.  I'd opt for the white if I had a vote.  ;)

ScreenClip.png.9b3bbf0d12a0ccfeb2ef798951564824.png         ScreenClip.png.0f59b9242b14b016f6d07b8a07821115.png

Share this post


Link to post
  • 0
On 11/8/2017 at 1:08 PM, EdH said:

Left Panel, Note List, and Note Panel are checked in view, so upper right is note list, and lower right is the note body.

There is no "File Exit" - either the app crashes on its own, or hangs indefinitely until I kill it via Task Manager. It never recovers in that session.

ANd the note is in a notebook that is in a stack. Finding the note in the notebook doesn't crash. Seems to only crash when I am in the "Notebook" icon showing all 22,000+ notes.

EDIT: Also crashes when in the stack and not the notebook.

If I search for:

tag:excel refresh date

it doesn't crash. It is like it requires all 3 tags to be used.

I had the crashing problem in EN Windows in beta 2 and 3.  In my case, selecting the note, selecting it as 1st or last in a shift-select, having it appear as the 1st item in a search, etc. all crashed instantly.  Basically, with the note panel open, if the note was active there it crashed.  It was a handful of feeds that crashed every time, for every emailed note from that feed.

To help support, they asked me to export some said notes in enex format, and send to them.  I did so, and they could repro the problem, and it is fixed (for me) in beta 4.  If you can do the same hopefully they can repro the problem.

Share this post


Link to post
  • 0
47 minutes ago, eafpres said:

I had the crashing problem in EN Windows in beta 2 and 3.  In my case, selecting the note, selecting it as 1st or last in a shift-select, having it appear as the 1st item in a search, etc. all crashed instantly.  Basically, with the note panel open, if the note was active there it crashed.  It was a handful of feeds that crashed every time, for every emailed note from that feed.

To help support, they asked me to export some said notes in enex format, and send to them.  I did so, and they could repro the problem, and it is fixed (for me) in beta 4.  If you can do the same hopefully they can repro the problem.

I included the enex in this thread, so they have it for the beta cycle.

Share this post


Link to post
  • 0

Import a page (simplified article) from a site that has bulleted or numbered lists. Some of the lists have no space between the last item and the next heading/text, which I don't like. Press enter after the last list item (bulleted or numbered), and press the formatting bar item for removing the bullet/number. The block of numbered/bulleted text is highlighted, and in some cases the entire note. I don't see anything in the activity log to indicate what the problem might be. Not something I have seen before. Happens with a couple of different sites that I use.

Share this post


Link to post
  • 0
3 hours ago, FactMan said:

Import a page (simplified article) from a site that has bulleted or numbered lists.

Is this a problem with the web clipper or the Windows client? It'd probably be helpful to post a sample site, if that's feasible...

Share this post


Link to post
  • 0
51 minutes ago, jefito said:

Is this a problem with the web clipper or the Windows client? It'd probably be helpful to post a sample site, if that's feasible...

I don't know the answer to your question. However, here is an example page: https://articles.mercola.com/sites/articles/archive/2017/11/10/how-to-grow-radishes.aspx. There are a couple of sections where the problem occurs.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now