• 2
Chantal Leonard

Evernote for Windows 6.8 Beta 1 Released

Idea

Today we're releasing version 6.8 Beta 1 - you cadownload it here. This release includes a number of fixes to the note experience.  

Please try these out for yourselves and let us know what you think. 

Thanks,

Chantal and the rest of the Windows and the Editor teams! 

--------------------

Full release notes for version 6.8: 

Evernote for Windows 6.8 Release Notes

Improved

More quickly start a bulleted list using a hyphen. In addition to using the still supported '*'+space shortcut, you can now also use '-'+space shortcut

Fixed

This release has many bug fixes. Some notable fixes include

  • A fix where tables clipped from Microsoft Word or Outlook did not appear correctly in Evernote
  • A fix where additional lines are pasted when pasting a line of text from Evernote to other applications
  • A fix for no longer dropping the check box and end line on copy/paste of a to-do item
  • A fix where some reminders are not synced after clicking the sync button
  • A fix to ensure the app if downloaded from the Windows Store respects the Options>Start on Windows Logon option
  • A fix so that selecting the 'New Note' button when in the Business tab with no notebook selected, no longer creates a note in Personal

 

Share this post


Link to post

89 replies to this idea

Recommended Posts

  • 2

Sorry to be harsh but Evernote Jesus Christ can you please fix copy-paste once and for all?  It's incredibly buggy and inconsistent.  Simple: Paste (control-V) should paste the formatted content of the clipboard, including font type, size, color, attributes (underline/bold/italics) and links;  Paste-text-only (control-shift-V) should paste text only and adopt the "local" formatting at the point of paste (including font type, size, color etc.).  Really, not complicated.  It's ridiculous that you can't get that right.  Every single user of Evernote I speak with agrees.  It it weren't so frustrating it'd be funny.  Version 6.7 actually made it WORSE.  Can this be finally fixed in 6.8?  PLEASE?  Can't be that hard.  Really.  

  • Like 2
  • Thanks 4

Share this post


Link to post
  • 2

For EN Win v6.8, we will be reverting Ctrl-Shift-V (Paste & Match Style) to the way it was in prior to the EN Win v6.6 release. I.e., only the text will be pasted in - links, images, attachments, etc., will be stripped out.


That is the behavior that users have come to expect, based on their experience with Evernote over the years, as well as with many other apps and web browsers.
Based on user feedback, we will consider other improvements to paste in future releases.

  • Like 3

Share this post


Link to post
  • 1
4 hours ago, Karczag said:

Sorry to be harsh but Evernote Jesus Christ can you please fix copy-paste once and for all?  It's incredibly buggy and inconsistent.  Simple: Paste (control-V) should paste the formatted content of the clipboard, including font type, size, color, attributes (underline/bold/italics) and links;  Paste-text-only (control-shift-V) should paste text only and adopt the "local" formatting at the point of paste (including font type, size, color etc.).  Really, not complicated.  It's ridiculous that you can't get that right.  Every single user of Evernote I speak with agrees.  It it weren't so frustrating it'd be funny.  Version 6.7 actually made it WORSE.  Can this be finally fixed in 6.8?  PLEASE?  Can't be that hard.  Really.  

The problem is "Paste as Text" isn't on the menu. It is "Paste and Match Style" and that can mean whatever you want it to mean.

Share this post


Link to post
  • 1

Code blocks are disappearing in this release.  I create a new note and add a code block and everything looks OK.  Open another note and when I come back to the original the code block is gone.  Seems to only change/break notes that I open.  Reverted back to 6.7 and the issue is not present.  Untouched/viewed notes seem to be fine.

Before.png

After.png

Share this post


Link to post
  • 1
13 minutes ago, EvernoteAlex said:

For EN Win v6.8, we will be reverting Ctrl-Shift-V (Paste & Match Style) to the way it was in prior to the EN Win v6.6 release. I.e., only the text will be pasted in - links, images, attachments, etc., will be stripped out.

cheering_minions.gif.c82d31f92de002f434e593342fd5b4d5.gif

  • Like 1
  • Haha 1

Share this post


Link to post
  • 0

Sorry, I cannot find the 6.7.5 public release discussion.  I installed it today, Paste and Match Style is still broken, copying and pasting from various web sites inconsistently pastes either plain text, or full graphics and formatting, I cannot determine a pattern of when it works and when it doesn't.  

Back to 6.5, where it works as it should.

Share this post


Link to post
  • 0

Not sure when this started,  might have been with this release;  but I was just trying to get a 'classic note link' to refer back to Evernote from my ToDo app,  and I can't now seem to do it.

Ctrl + Copy Internal Link or Share > Ctrl + Copy Shareable Link give the same result as clicking those options without pressing Ctrl.

Copy Internal Link gets me a link showing the note title which will not work in Firefox or my ToDo app.  If I copy the location I see "evernote:///view/120.... etc" but that won't work at all.

Copy Shareable Link takes me to the Web version of my note only - not terrible,  but not what I want.

Did I miss something obvious???

Share this post


Link to post
  • 0
4 hours ago, gazumped said:

Not sure when this started,  might have been with this release;  but I was just trying to get a 'classic note link' to refer back to Evernote from my ToDo app,  and I can't now seem to do it.

Ctrl + Copy Internal Link or Share > Ctrl + Copy Shareable Link give the same result as clicking those options without pressing Ctrl.

Copy Internal Link gets me a link showing the note title which will not work in Firefox or my ToDo app.  If I copy the location I see "evernote:///view/120.... etc" but that won't work at all.

Copy Shareable Link takes me to the Web version of my note only - not terrible,  but not what I want.

Did I miss something obvious???

I just did a test with an email and a todo in Wunderlist.  In both cases I used Copy internal link/paste and in both cases focus was transferred to the note in EN.  Still opens a tab in Chrome first, but end up in EN.  So I think it is working for me, eM Client and Wunderlist anyway.. 

Link is of the form https://www.evernote.com/shard/s1/nl/.....

  • Like 1

Share this post


Link to post
  • 0
11 hours ago, Karczag said:

Sorry to be harsh but Evernote Jesus Christ can you please fix copy-paste once and for all?

Buddha says "Meditate first, then post." Really.

11 hours ago, Karczag said:

 Simple: Paste (control-V) should paste the formatted content of the clipboard, including font type, size, color, attributes (underline/bold/italics) and links

I'm seeing this working, in simple cases at least. There may be edge cases where it fails. That's where we can help them pin things down, by specifying scenarios where it fails. I'm testing in the 6.8.1 beta, btw.

11 hours ago, Karczag said:

Paste-text-only (control-shift-V) should paste text only and adopt the "local" formatting at the point of paste (including font type, size, color etc.).

Ditto for this, except that links are maintained. Remember, they don't call it Paste-text-only; they call it "Paste and Match Style". Both have their uses, in my world, and having ways to do both would be nice. I think there's also a use case for Paste-in-Default-Format. I'd use it, anyways.

This is probably related to the Clear Formatting operation (which maintains links currently), and Remove Formatting (which seems to not be working at all, so maybe a regression there; I'll need to pull this out and report it separately), but should probably remove links as well. I would use both of these operations.

11 hours ago, Karczag said:

Really, not complicated.   It's ridiculous that you can't get that right.  Every single user of Evernote I speak with agrees.

Except that HTML formatting is complicated. I'm guessing that that's one of the major difficulties.. I'm also wondering about the keep/remove link  issue.  Also I'd say that there might be some disagreement as to what the fundamental operations should do. Anyways, to summarize the set of operations that I'd like to see:

Possible paste operations:

  • Simple: paste and retain any current formatting of the pasted text. Keep links as links.
  • Paste-and-Match-Style: pasted text takes on the formatting that's active at the point of insertion. Keep links as links.
  • Paste-and-Match-Style-No-Links (I'd guess that this is equivalent to what people call Paste-Text-Only): pasted text takes on the formatting that's active at the point of insertion. Remove links.
  • Paste-In-Default-Style: pasted text takes on the current default style as  defined in Tools / Options / Note / Note font and size. Keep links.

Possible formatting operations:

These operate on selected text in a note, or the whole note if there's no selection:

  • Clear-formatting : convert formatting to default style, but maintain links as links
  • Remove-Formatting : clear formatting to default style, but remove links
  • Remove-Links : maintain current formatting, but remove links

I haven't gotten into the shortcut key issue (without using Alt-, and think that they avoid that, you'd need more than Ctrl+V and Ctrl+Shift+V), but all of these options ought to be at least available on the right-click context menu.

  • Like 4

Share this post


Link to post
  • 0
4 hours ago, csihilling said:

So I think it is working for me, eM Client and Wunderlist anyway.. 

Now I know how all those folks feel where I've said "It's working on my system" when it's NOT working for them.  ;)

Duly motivated,  I went on to experiment further (as they say).  It seems to be down to how the software you're pasting into deals with links.  Turns out Workflowy (that I was using there) receives the note title in a straight paste,  but doesn't accept a usable link.  If I paste the URL from the same link,  Workflowy can't process it - though it works quite happily with standard links. 

TickTick,  which is my normal To Do app,  accepts the link URL,  but does not display the note title.  That URL works fine to bounce me through to the web version of the note,  but won't go to the Evernote Desktop version - though Evernote 'jumps' as though goosed when the web page pops up.

Some days I hate my life...  :(

EDIT: - OK it can get worse.  Just cleared the decks to actually get some work done,  and the notes that I "couldn't get to" via the links are all stacked up behind the Evernote main window.  So Copy Internal Link does work for some software,  just not for others.  I'll winge at Workflowy later...  ^_^

Share this post


Link to post
  • 0
1 hour ago, gazumped said:

That URL works fine to bounce me through to the web version of the note,  but won't go to the Evernote Desktop version

There is a process to set standard behavior, Google below, don't know if there is an equivalent for FF.

Relative to the stack of open windows, try unchecking Open note links from other... in Options - Navigation.

 

  • Like 1

Share this post


Link to post
  • 0
On 9/26/2017 at 5:49 AM, fchandler said:

Still an issue....

This is scheduled to be fixed in the 6.8 GA. 

 

Share this post


Link to post
  • 0
3 hours ago, Sam Jensen said:

Code blocks are disappearing in this release.  I create a new note and add a code block and everything looks OK.  Open another note and when I come back to the original the code block is gone.  Seems to only change/break notes that I open.  Reverted back to 6.7 and the issue is not present.  Untouched/viewed notes seem to be fine.

Before.png

After.png

Thanks for mentioning that, I see exactly what you're showing. I've reported this unexpected behavior to the development team.

Share this post


Link to post
  • 0
1 hour ago, csihilling said:

Relative to the stack of open windows, try unchecking Open note links from other... in Options - Navigation.

Thanks.  That works.  I forgot about that one... :)

  • Like 1

Share this post


Link to post
  • 0

WIN + SHIFT + F doesn't take me to the search bar.

  • If I'm already viewing All Notes, then it takes me directly to the search field. If I'm having another search open, I have to do the command twice, as the first time, it only takes me to All Notes without the cursor being in the search bar. 
  • I believe that this feature has been available before as it's just now that I'm getting the frustration.. 
  • Running 6.8.1 on Windows. 

Share this post


Link to post
  • 0
1 hour ago, TYVM_23 said:

WIN + SHIFT + F doesn't take me to the search bar.

  • If I'm already viewing All Notes, then it takes me directly to the search field. If I'm having another search open, I have to do the command twice, as the first time, it only takes me to All Notes without the cursor being in the search bar. 
  • I believe that this feature has been available before as it's just now that I'm getting the frustration.. 
  • Running 6.8.1 on Windows. 

Strange, this seems to work for me on 6.8.1. on Win 10.

I was going to suggest that you check that this shortcut key is enabled by checking Tools / Options / Shortcut Keys, but your scenario seems to suggest that this is working only in certain situations. I can't seem to make it fail whether I have a current search or not.

Weird.

Share this post


Link to post
  • 0
20 hours ago, Sam Jensen said:

Code blocks are disappearing in this release.  I create a new note and add a code block and everything looks OK.  Open another note and when I come back to the original the code block is gone.  Seems to only change/break notes that I open.  Reverted back to 6.7 and the issue is not present.  Untouched/viewed notes seem to be fine.

Before.png

After.png

This issue has been fixed and will be in the next beta 

Share this post


Link to post
  • 0

Found a somewhat annoying issue with note search (Ctrl+F); not sure that it's been reported:

So you hit Ctrl+F, and type some text, and find a string in your note.  "Great, here I am! Now to get busy." So, OK, hit Escape, and prepare to read or edit or whatever in that location. But Escape sends you back to the top of your note (not even where you were when you initiated Find), and you lose your place. My expectation is that you'd just stay where Find brought you. You need to reach for the mouse and click in the document to stop Find and continue editing.

I'd cite as precedents Visual Studio and Notepad++. Curiously MS Word's Find will put you back where you started Find if you hit Escape, but not at the top of the document.

Bonus points if the text highlighting were discarded in favor of an actual selection, so that Escape would let you start typing immediately and replace what you found, or make a selection, or paste, etc. That seems like pretty common behavior as well. 

In any case, kudos for making Find be incremental, something I miss greatly when it's not available....

  • Like 1

Share this post


Link to post
  • 0

Why is there suddenly an extra .25" of whitespace between the note editor window and the note list window, to the right of the dividing line? This wasn't there in 6.5.4.4720 (304720), which I still have installed on another computer. Seems unnecessary.

  • Like 1

Share this post


Link to post
  • 0
On 9/27/2017 at 9:25 AM, Karczag said:

Sorry to be harsh but Evernote Jesus Christ can you please fix copy-paste once and for all?  It's incredibly buggy and inconsistent.  Simple: Paste (control-V) should paste the formatted content of the clipboard, including font type, size, color, attributes (underline/bold/italics) and links;  Paste-text-only (control-shift-V) should paste text only and adopt the "local" formatting at the point of paste (including font type, size, color etc.).  Really, not complicated.  It's ridiculous that you can't get that right.  Every single user of Evernote I speak with agrees.  It it weren't so frustrating it'd be funny.  Version 6.7 actually made it WORSE.  Can this be finally fixed in 6.8?  PLEASE?  Can't be that hard.  Really.  

If I use ctrl+shif+v to past text with a hyperlink, the pasted text should not include the hyperlink. Please fix. 

Share this post


Link to post
  • 0
3 hours ago, bioadam said:

If I use ctrl+shif+v to past text with a hyperlink, the pasted text should not include the hyperlink.

Why? “the pasted text should not include the hyperlink”

edited: withdrawn - I was experiencing a Paste and Match Style flashback

Share this post


Link to post
  • 0
30 minutes ago, DTLow said:

Why? “the pasted text should not include the hyperlink”

Folks seem to want

  1. Paste
  2. Paste and Match Style (keep hyperlinks)
  3. Paste plain text

'Twould seem many think Paste and Match Style should be plain text.  As it once was, I think?  I'm all for adding Ctrl-Shift-Alt-V or whatever to get plain text.

  • Like 2

Share this post


Link to post
  • 0

OK, just wanted to link to someone else's issue that's a problem in 6.8 Beta 1: plain text on the clipboard (from say, some source code, and delimited, in my case, with CR/LF pairs) loses any blank lines when pasted into an Evernote note. This occurs also if you paste into a code block. The original topic is here: 

 

 

  • Thanks 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now