Jump to content
Evernote for Windows Update Required Read more... ×
Ever Better: Refreshing the Evernote Brand Read more... ×
  • 4
Chantal Leonard

Evernote for Windows 6.7 Beta 1 Released

Idea

Hi folks - 

Hot on the heels of our 6.6 GA, here's our first Beta of version 6.7. You can download it here. This first Beta includes a number of fixes and improvements. Please take it out for a spin and let us know what you think. 

Thanks,

Chantal and the rest of the Windows & Note Editor teams. 

----------------

Release Notes for Windows version 6.7

Fixes and Improvements

Fixed paste + match style behavior where not all content was being pasted as expected

Fixed an issue where local unsynced content disappears when the source notebook is no longer available

Options dialog updates to use standard Windows control for tree navigation

Focus is not set to title or content based on user preference regardless of how new notes Open (previously only supported when a note is opened in a new window)

Added information on the note editor version in the 'About' dialog to improve root causing of issues

Fixed issue where wrong note is sometimes shown when launching presentation mode

Fixed issue where nothing happens when users clicks Edit >> Delete option in Single Note View

  • Like 2

Share this post


Link to post

Recommended Posts

  • 0
7 minutes ago, lisec said:

I still haven't enabled any of these functions because I have not quite figured out how to keep a backup of my "full" enex file . Are you guys just trusting that all will be good with your data? (I don't mean to bring this up in this thread - is there a discussion of backup vs "on demand" and now "purge" somewhere?)

The same issue. It will be fine if Evernote add ability to backup all cloud data without full content in the local database.

Right now I have two separate installation of Evernote: one with 'sync on demand' to keep the database small and Evernote fast;  and second installation with full local database to create backups.

  • Like 2

Share this post


Link to post
  • 0
16 hours ago, csihilling said:

Bug report.

I just added a business card.  When typing into the notes field the cursor continually bounces back to the beginning of the field.  Every 5 to 10 characters, or maybe just when I pause typing.

Thanks, I see exactly what you mention and have reported this to the development team.

  • Like 1

Share this post


Link to post
  • 0
9 minutes ago, lisec said:

I still haven't enabled any of these functions because I have not quite figured out how to keep a backup of my "full" enex file . Are you guys just trusting that all will be good with your data? (I don't mean to bring this up in this thread - is there a discussion of backup vs "on demand" and now "purge" somewhere?)

Not yet - maybe Justin could split this thread of these recent posts?  I ventured to the 'on demand' arena because I have two laptops - the beefy working one,  and the backup that goes travelling when I need it.  I kept a full database on the main 'beefy' one,  and tried ODS on the backup.  I don't want to lose my full copy database either!  ;)

  • Like 1

Share this post


Link to post
  • 0
4 minutes ago, gazumped said:

Not yet - maybe Justin could split this thread of these recent posts?  I ventured to the 'on demand' arena because I have two laptops - the beefy working one,  and the backup that goes travelling when I need it.  I kept a full database on the main 'beefy' one,  and tried ODS on the backup.  I don't want to lose my full copy database either!  ;)

See, that's interesting because I was just about to go grab my mini win10 laptop and do that, i.e. try the on-demand business, but stopped at the last minute. That is the laptop I use in line at TIFF or on holidays or wherever I might not have internet access!  I suppose I could always copy the notes I think I will need to a "local" database when I know I'm heading somewhere. I already do that with my phone (I have a "OnDevice" folder for that), but I'm always afraid of having missed some crucial notes.  Hmmm.  

Share this post


Link to post
  • 0
12 minutes ago, andrey.demidov said:

The same issue. It will be fine if Evernote add ability to backup all cloud data without full content in the local database.

Right now I have two separate installation of Evernote: one with 'sync on demand' to keep the database small and Evernote fast;  and second installation with full local database to create backups.

I would have almost no issue trying it out if there were a "export all notes as individual notes using the title of the note as the title of the html file" backup option. Then at least I would still have all my information and easy access to it as well.

Share this post


Link to post
  • 0
4 minutes ago, lisec said:

See, that's interesting because I was just about to go grab my mini win10 laptop and do that, i.e. try the on-demand business, but stopped at the last minute. That is the laptop I use in line at TIFF or on holidays or wherever I might not have internet access!  I suppose I could always copy the notes I think I will need to a "local" database when I know I'm heading somewhere. I already do that with my phone (I have a "OnDevice" folder for that), but I'm always afraid of having missed some crucial notes.  Hmmm.  

AFAIK the ODS is an all or nothing thing - unless sorry you meant a local (offline) notebook...  where again I use something similar on my phone.  It's a good notion (though me being totally paranoid about data would have a local notebook title in bright red and at the top of the list so I don't forget to copy the contents back to synced safety when I get back...)  :)

Share this post


Link to post
  • 0
4 minutes ago, lisec said:

I would have almost no issue trying it out if there were a "export all notes as individual notes using the title of the note as the title of the html file" backup option. Then at least I would still have all my information and easy access to it as well.

My daily backup is an html export to a cloud drive.

Each note is an html file named with the note title.  There is an additional folder for attachments

  • Like 1

Share this post


Link to post
  • 0

@Jason Miller

How about indented code block?

if you are not at the start of the line with no indentation at all, it is impossible to add a code block.

This used to be possible, but now it is impossible.

And as you may know, in many situations, specially with clips from the web or heavy editing, Evernote makes it impossible to be able to insert a line that is at 0 position, effectively impossible to add a code block.

 

 

Share this post


Link to post
  • 0
4 minutes ago, Hrant said:

@Jason Miller

How about indented code block?

if you are not at the start of the line with no indentation at all, it is impossible to add a code block.

This used to be possible, but now it is impossible.

And as you may know, in many situations, specially with clips from the web or heavy editing, Evernote makes it impossible to be able to insert a line that is at 0 position, effectively impossible to add a code block.

 

 

At this point indenting a code block would be a feature request, since it was originally suppose to take up the width of the note 

I will ping Dev

Share this post


Link to post
  • 0
2 hours ago, Jason Miller said:

Not being worked on at the moment, also a bit harder to reproduce (so far) internally) - QA will "play" with it a bit more to get clear steps for Dev to look at

Maybe this will help with reproducing the issue:

 
To summarize, there are (at least) 3 issues:
  1. Font size settings (here, 10pt) are not correctly carried into notes (9pt is what EN reverts to despite settings)
  2. actual font size is neither 9pt or 10pt; let's call it 9.8pt
  3. when copying/pasting this 9.8pt font, it then becomes 9pt

 

  • Like 1

Share this post


Link to post
  • 0

Thanks Jason.

This used to be possible, which changed at some point not too recently, either by design or due to a regression.

 

Share this post


Link to post
  • 0
8 minutes ago, Hrant said:

Thanks Jason.

This used to be possible, which changed at some point not too recently, either by design or due to a regression.

 

It was due to design, we are getting unpredictable behavior so, we restricted it more (even remove Code Block from tables) 

Share this post


Link to post
  • 0
21 minutes ago, Jason Miller said:

It was due to design, we are getting unpredictable behavior so, we restricted it more (even remove Code Block from tables) 

Thanks again.

Hopefully once the root issue of unpredictable behavior is uncovered / resolved (if it is still being seeked), the removed functionalities would be put back.

I'm saying it because I know how product teams tend to forget / de-prioritize it if there is no customer demand / push back.

 

Share this post


Link to post
  • 0
2 hours ago, lisec said:

I still haven't enabled any of these functions because I have not quite figured out how to keep a backup of my "full" enex file . Are you guys just trusting that all will be good with your data? (I don't mean to bring this up in this thread - is there a discussion of backup vs "on demand" and now "purge" somewhere?)

If you enable this, you won't be able to export everything to an ENX file. At best you'd get headers for the body-less notes.

There is actually a bug with this whole thing too in that if you merge notes and some are "purged" where they have no body, only the subject line gets merged, the body gets tossed in the trash. So you don't lose it, but you do if you don't realize what happened.

And then there is the search issue mentioned above.

So, half baked solution right now, but for me worth it because with 20,000+ notes and 9GB or so of data, EN was constantly freezing on me making it hard to use. The MySQL database being used on Windows just sucks. The Mac version has no such issues. My Mac has the whole shebang downloaded.

Share this post


Link to post
  • 0
14 hours ago, gustavgi said:

I don't know if this bug has been mentioned before but I have several clipped notes where words are merged/space has been removed, in 6.7. The notes looks fine on my phone, but as soon as they are edited on 6.7, the notes are permanently corrupted.

@Jason Miller As I consider this one to be serious, I just wanted to make sure this is on your radar as it messes up my notes.

Share this post


Link to post
  • 0
2 minutes ago, gustavgi said:

@Jason Miller As I consider this one to be serious, I just wanted to make sure this is on your radar as it messes up my notes.

So does the clipped note appear in Windows this way (is it ok anywhere else)?  Which clipping method are you using and from what website - I can ping the Clipper folks and the Editor folks to hopefully track down the problem 

Share this post


Link to post
  • 0
8 minutes ago, Jason Miller said:

Which clipping method are you using and from what website

Clipping? What's that? Webclipper hasn't worked at all for such a long time that I completely forgot it even existed. Is that ability coming back?

Share this post


Link to post
  • 0
1 minute ago, OrbWeaver said:

Clipping? What's that? Webclipper hasn't worked at all for such a long time that I completely forgot it even existed. Is that ability coming back?

Clipper does work in Chrome, the old clearly client does not. 

So are you coping an an entire page, or section of a page and pasting into Windows and then things go wrong?  (spaces get eaten and such) 

Share this post


Link to post
  • 0
3 minutes ago, Jason Miller said:

Clipper does work in Chrome

... but not in Firefox. I'm wondering if that is because Evernote = Google, Firefox = Mozilla, Google and Mozilla = war. :)

It's a pain to have to jump back and forth but I do it frequently. Sometimes it is easier to do the "cut and paste and sorta match style" and clean things up later.

Share this post


Link to post
  • 0
50 minutes ago, EdH said:

So, half baked solution right now, but for me worth it because with 20,000+ notes and 9GB or so of data, EN was constantly freezing on me making it hard to use.

Are you using SSD ?

Share this post


Link to post
  • 0
1 minute ago, OrbWeaver said:

... but not in Firefox. I'm wondering if that is because Evernote = Google, Firefox = Mozilla, Google and Mozilla = war. :)

It's a pain to have to jump back and forth but I do it frequently. Sometimes it is easier to do the "cut and paste and sorta match style" and clean things up later.

More like Firefox was breaking stuff

Share this post


Link to post
  • 0
3 minutes ago, OrbWeaver said:

... but not in Firefox

By the way, I am using Firefox including latest Nightly Builds and Evernote extension works for me.

  • Like 2

Share this post


Link to post
  • 0

I've seen a few notes where people are commenting that actual font size doesn't seem to match the indicated size. I too noticed that some time ago and while my explanation to myself may be totally wrong, it made sense to me at the time.

I tell EN my default font should be 12pt. EN sees that I have set Windows to show everything at 125% so assumes that substituting 11.5pt will actually render as about 12 on my particular screen. A true 12pt would look larger due to the 125%. It certainly looks like 12pt but if I cut something and paste into Word, presto, there's 11.5 point. Perhaps EN pays attention to Windows personalized settings while Word goes by the book. As I said, that was how I figured it was working but that explanation is probably wrong.

Share this post


Link to post
  • 0
8 minutes ago, Jason Miller said:

More like Firefox was breaking stuff

Gee, ya think so??? :):)

 

Share this post


Link to post
  • 0
16 minutes ago, andrey.demidov said:

Are you using SSD ?

Yup. But I first had this problem years ago on an HDD, for 2-3 years on an SDD, then for 3 years on a hybrid drive, and now for 18 months on a Surface Pro 4 512GB SDD. So it isn't the hardware.

Share this post


Link to post
  • 0
15 minutes ago, OrbWeaver said:

I've seen a few notes where people are commenting that actual font size doesn't seem to match the indicated size. I too noticed that some time ago and while my explanation to myself may be totally wrong, it made sense to me at the time.

I tell EN my default font should be 12pt. EN sees that I have set Windows to show everything at 125% so assumes that substituting 11.5pt will actually render as about 12 on my particular screen. A true 12pt would look larger due to the 125%. It certainly looks like 12pt but if I cut something and paste into Word, presto, there's 11.5 point. Perhaps EN pays attention to Windows personalized settings while Word goes by the book. As I said, that was how I figured it was working but that explanation is probably wrong.

I didn't experience this font size issue until v6.6.

My earlier post has a screencast that demostrates the issue.

 

Share this post


Link to post
  • 0
32 minutes ago, Jason Miller said:

So does the clipped note appear in Windows this way (is it ok anywhere else)?  Which clipping method are you using and from what website - I can ping the Clipper folks and the Editor folks to hopefully track down the problem 

Yes the previously clipped notes and new clipped notes are only displayed wrong in v6.7 on Windows (might have been in 6.6 as well, but I skipped that version), so nothing wrong with the clipper. It's very random as well. Some clipped notes from a certain site are affected, but others from the same site are not. And it's just some words, but all throughout the notes.

Since it's swedish, I marked with a red marker where there should be a space. The same note has spaces where it should in the older Windows versions and on my Android phone.

Skärmbild (459).png

Share this post


Link to post
  • 0
1 minute ago, gustavgi said:

Yes the previously clipped notes and new clipped notes are only displayed wrong in v6.7 on Windows (might have been in 6.6 as well, but I skipped that version), so nothing wrong with the clipper. It's very random as well. Some clipped notes from a certain site are affected, but others from the same site are not. And it's just some words, but all throughout the notes.

Since it's swedish, I marked with a red marker where there should be a space. The same note has spaces where it should in the older Windows versions and on my Android phone.

Skärmbild (459).png

:-(

Do you happen to have a website and the ENEX file (that can be shared) that I can throw at Dev?

Share this post


Link to post
  • 0
26 minutes ago, Jason Miller said:

:-(

Do you happen to have a website and the ENEX file (that can be shared) that I can throw at Dev?

The website is behind a paywall, but I'm attaching the ENEX. I imported it on my other Windows PC that still runs 6.5.4 and it looks fine there. I checked the latest iOS version on my iPad, and the note looks fine there as well. This is an isolated Windows bug introduced in the latest version. My guess is it has something to do with the other problems regarding fonts.

Missing spaces in text.enex

Share this post


Link to post
  • 0
4 hours ago, EdH said:

That makes devs slow and lazy. Make 'em work for it! :D

Cheaper to have techs do it. Costs a lot of money keeping the devs busy making bugs code... 

Share this post


Link to post
  • 0

Count your lucky stars, you're rare exception.

It hasn't work for so long, I have to constantly switch to Chrome if I want to capture anything.

And based on the reviews of the plugin, along with the comments in here, I'm assuming that I'm not alone on this boat.

 

 

Share this post


Link to post
  • 0
1 hour ago, Jason Miller said:

So does the clipped note appear in Windows this way (is it ok anywhere else)?  Which clipping method are you using and from what website - I can ping the Clipper folks and the Editor folks to hopefully track down the problem 

I have an example, if it helps, although I haven't upgraded to 6.6 yet so... whenever I open any of the film pages at tiff.net (http://www.tiff.net/tiff/films.html) and copy paste (using paste or Shift Ctrl V) the line with basic info about the film gets all of its spaces removed. It goes from the image I've provided to "Italy, France, USA, Germany120 minutes2017STCColourItalianNorth American Premiere" (notice that some spaces are respected - not sure why.) I'm not sure if this is a good example, though, because the tiff site is one of the worst sites ever. You should try opening one of those films and saving with Clipper (Chrome or Firefox). Prepare to laugh out loud.

 

2017-08-16-1732-24.jpg

Share this post


Link to post
  • 0
9 hours ago, lisec said:

I have an example, if it helps, although I haven't upgraded to 6.6 yet so... whenever I open any of the film pages at tiff.net (http://www.tiff.net/tiff/films.html) and copy paste (using paste or Shift Ctrl V) the line with basic info about the film gets all of its spaces removed. It goes from the image I've provided to "Italy, France, USA, Germany120 minutes2017STCColourItalianNorth American Premiere" (notice that some spaces are respected - not sure why.) I'm not sure if this is a good example, though, because the tiff site is one of the worst sites ever. You should try opening one of those films and saving with Clipper (Chrome or Firefox). Prepare to laugh out loud.

 

2017-08-16-1732-24.jpg

That looks like a web table, which will not be preserved with copy+paste. So there are no spaces. it just looks that way because the text is centered in each cell. So I don't think that's an Evernote issue.

Share this post


Link to post
  • 0
6 hours ago, gustavgi said:

That looks like a web table, which will not be preserved with copy+paste. So there are no spaces. it just looks that way because the text is centered in each cell. So I don't think that's an Evernote issue.

Right. That explains it.

Share this post


Link to post
  • 0
8 hours ago, EvernoteAlex said:

Regarding paste & match style: in the next beta, the header style from source will no longer be retained

Excellent. Thanks.

Share this post


Link to post
  • 0
20 hours ago, gazumped said:

AFAIK the ODS is an all or nothing thing - unless sorry you meant a local (offline) notebook...  where again I use something similar on my phone.  It's a good notion (though me being totally paranoid about data would have a local notebook title in bright red and at the top of the list so I don't forget to copy the contents back to synced safety when I get back...)  :)

I think we have a similar setup. I made my "OnDevice" folder available off line on my phone so that even without the net I can still access whatever is in there.

Maybe that should always be an option now for all OS's (not just Android). I just turned on Sync on Demand on my mini laptop and already I want a notebook that has some files that should be there permanently. 

Share this post


Link to post
  • 0
16 hours ago, lisec said:

I have an example, if it helps, although I haven't upgraded to 6.6 yet so... whenever I open any of the film pages at tiff.net (http://www.tiff.net/tiff/films.html) and copy paste (using paste or Shift Ctrl V) the line with basic info about the film gets all of its spaces removed. It goes from the image I've provided to "Italy, France, USA, Germany120 minutes2017STCColourItalianNorth American Premiere" (notice that some spaces are respected - not sure why.) I'm not sure if this is a good example, though, because the tiff site is one of the worst sites ever. You should try opening one of those films and saving with Clipper (Chrome or Firefox). Prepare to laugh out loud.

 

2017-08-16-1732-24.jpg

Thanks for sharing the URL, I another hiccup with pasting part of the text from the website (fortunately nothing you ran into) so very useful (text is pushing into the margin (sometimes)

Share this post


Link to post
  • 0

I have noticed in the latest Beta that double clicking on an encrypted text icon no longer prompts for the password to decrypt. Using the right-mouse button (Show encrypted text) still works however.

Share this post


Link to post
  • 0
14 minutes ago, JeffreyC said:

Screen shot courtesy of Skitch - Long Live Skitch

Does it not in the form of screen capture?  ;)

Share this post


Link to post
  • 0
3 minutes ago, Wilkster said:

I have noticed in the latest Beta that double clicking on an encrypted text icon no longer prompts for the password to decrypt. Using the right-mouse button (Show encrypted text) still works however.

Interesting, double clicking is prompting me for the password, however I am running what will be Beta 2 - so maybe something broke and then got fixed

Share this post


Link to post
  • 0
2 hours ago, Jason Miller said:

Interesting, double clicking is prompting me for the password, however I am running what will be Beta 2 - so maybe something broke and then got fixed

No, that isn't it. Something else is going on with @Wilkster's note. I have beta 1 and double-clicking on encrypted text brings up the password dialog box here.

Share this post


Link to post
  • 0
15 minutes ago, EdH said:

No, that isn't it. Something else is going on with @Wilkster's note. I have beta 1 and double-clicking on encrypted text brings up the password dialog box here.

Ok, @Wilkster you open a support ticket and share your ENEX (depending on content) - does this happen with any other notes?

Share this post


Link to post
  • 0
3 hours ago, Jason Miller said:

Interesting, double clicking is prompting me for the password, however I am running what will be Beta 2 - so maybe something broke and then got fixed

I saw this behavior before V6.6.  I could double click the first time I used the note, but after that a right click was required to enter the password.  Works fine in this beta for me.

Share this post


Link to post
  • 0
On 8/16/2017 at 8:17 AM, csihilling said:

Bug Report.

To change the Synchronize automatically setting I had to first uncheck the option, OK out of options, then back into Options, check the  Synchronize automatically option and then change the time.  Used to be able to do this just by selecting a new time.

Repro'd. Bug created.

  • Like 1

Share this post


Link to post
  • 0
5 hours ago, Jason Miller said:

Ok, @Wilkster you open a support ticket and share your ENEX (depending on content) - does this happen with any other notes?

I made a copy of the note, added a few blank lines after the encrypted icon, and it then responded on double-click with the prompt. Then did the same with the original note and it works correctly. Chalk it up to some unique note issues.

Share this post


Link to post
  • 0
20 minutes ago, Wilkster said:

Notun bir kopyasını çıkardım, şifrelenmiş simgeden sonra birkaç boş satır ekledim ve daha sonra istemiyle çift tıklatarak yanıt verdim. Daha sonra orijinal nota aynısını yaptı ve düzgün çalışıyor. Bazı benzersiz notlarla ilgili sorunları tebeşirle.

Buttons disappear when file path is long.

  • Like 1

Share this post


Link to post
  • 0
20 hours ago, Ziya O. said:

Hi,

Bir sorun var. Aşağıdaki resimleri gözden geçirin.

1.png

2.png

Hi

It looks like the forum dropped the image you posted - can you repost so I can share with the Dev folks who are looking at this issue? 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×