Jump to content
  • 5
bountonw

code block should not autoformat

Idea

The purpose of a code block is to render unformatted text in a monospaced font. When writing code, two dashes should be represented as two dashes and not an em-dash or en-dash. A quote, double quote or tick should remain as typed and not do some "smart" behavior. A lowercase initial word is meant to stay lowercase. Please turn off auto-formatting for code blocks

This is not a feature request. This is a bug report. :) 

  • Like 2

Share this post


Link to post

5 replies to this idea

Recommended Posts

  • 0

Helps to specify the platform that you're referring to. The em-dash thingy doesn't appear to occur on the Windows client. Otherwise, I agree that this sort of behavior should be off in a code block. Upvoted.

Share this post


Link to post
  • 0

I also have this issue on OSX running the latest versions of everything. Single quoted strings turning to weird quotes, so code is wrong when pasting it into REPLs. Is this whole ‘unformatted monospace text’ thing really that hard? If Evernote devs dogfood, I’m sure they are aware of the issue.

Share this post


Link to post
  • 0
On 2017-07-09 at 10:17 PM, bountonw said:

When writing code, two dashes should be represented as two dashes and not an em-dash or en-dash. A quote, double quote or tick should remain as typed and not do some "smart" behavior. A lowercase initial word is meant to stay lowercase. Please turn off auto-formatting for code blocks

 

14 minutes ago, Sethicus said:

I also have this issue on OSX running the latest versions of everything. Single quoted strings turning to weird quotes, so code is wrong when pasting it into REPLs. Is this whole ‘unformatted monospace text’ thing really that hard? If Evernote devs dogfood, I’m sure they are aware of the issue.

What are your Mac preference settings for auto-formatting5a09219276b18_ScreenShot2017-11-12at20_30_50.png.80f72f80d8b53f3d6035632944cc12d5.png

 
  •  

Share this post


Link to post
  • 1

I have "Use smart quotes and dashes" feature enabled in Keyboard settings. Regardless of that, in code block this system setting should be overridden like in all code editors and developer-focuses note taking apps.

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...