Jump to content
Sign in to follow this  
stickman

android (Archived) camera capture error

Recommended Posts

It looks like there is a problem with the camera snapshot feature. It looks like it takes a snapshot but it comes back with this error:

No snapshot found to upload.

Is this an acknowledged bug or something new? Any known way to solve it?

Share this post


Link to post

What device model and manufacturer are you using?

This doesn't happen on my Motorola Droid Milestone, but we're investigating a few other similar reports.

Thanks

Share this post


Link to post

HTC G1, Cyanogenmod 5.0.7DS (Android 2.1).

If you need any help to debug the issue, I'm here to help.

Share this post


Link to post

It would be very helpful if you could use the "SendLog" application to send us more details from your device after a failure:

viewtopic.php?f=51&t=12927&p=54054#p54054

We've heard from one other user with this problem, who said it went away after two(!) reboots. This may be caused by a low-memory or low-space error on your device, so you could check whether your storage is almost full on the phone (for example).

Thanks!

Share this post


Link to post

Dave,

I was the other user that had this happen. I have had it happen one other time (after the last time), but then I did it again and it worked fine the next try. It seems to be an intermittent issue.

Share this post


Link to post

I'd be very curious about the memory and storage available on your device when this happens.

Under Android Settings, you can see storage via "SD card & phone storage"

and you can see memory availability under: Settings > Applications > Running services

I'd be curious if this is happening when you happen to have virtually no memory and/or flash storage available.

Share this post


Link to post

I am another (third?) user who ran into this problem just this morning, when Evernote stubbornly refused to upload a snapshot. I would take a snapshot with the camera, and after a few seconds the [Cancel] [Retake] [OK] buttons came up. I chose [OK] but never got a prompt for name, tags, etc. Instead it returned to the Evernote screen with the error message noted by the other user.

I came here to report the problem this afternoon, and ran into this thread. Learning that it was an intermittent problem, I tried it again, and now it works. I'll try to catch it in the act if it happens again.

=GPN

Share this post


Link to post

Hello

Since 2 days ago I have the same problem. I´m using HTC Magic 32b wih android 2.1.

I´ve tried to reinstall apk on the phone but still getting same problem.

"No snapshot found to upload" :shock: :shock:

Is quite frustrating, as this is a feature that I use a lot.

Share this post


Link to post

I have the same problem... I un-installed Evernote, deleted the folder on the memory card, re-installed Evernote and I still have the same problem...

Phone: Motorola Droid

OS Version: 2.2

Share this post


Link to post

I recently installed Evernote, and have never been able to upload a picture due to this issue. I recently reformatted my SD card too, so it's nearly empty.

I'm using an HTC Magic with Android 1.6.

Available storage is 7,15GB (out of 7,40GB) in the SD card, 77,25MB free internal storage (out of 296MB).

Available memory is 19MB out of 96MB.

If you need more info, let me know. Thanks!

Share this post


Link to post

I'm having a similar issue also. What I've noticied is I have 5 notes pending too upload including 3 from last night and 2 from this morning. All but the last 1 are camera/image notes. The last is just a dummy text note I tried creating to see if that would upload. Since last night, I been off and on wifi and the phones been restarted with no sucess.

Running stock 2.1 on Motorola Droid

Share this post


Link to post

Unfortunately, I can't reproduce the problem. Can I have a volunteer to post the error log? Or email me the log file.

"from Dave: It would be very helpful if you could use the "SendLog" application to send us more details from your device after a failure: viewtopic.php?f=51&t=12927&p=54054#p54054"

Share this post


Link to post

Thank carlessr for sending us the log.

08-14 00:53:00.055 I/ActivityManager( 71): Low Memory: No more background processes.

08-14 00:53:00.055 I/WindowManager( 71): WIN DEATH: Window{43531310 com.evernote/com.evernote.ui.MainActivity paused=false}

08-14 00:53:00.475 D/CameraService( 51): CameraService::connect E (pid 4624, client 0x1c8f0)

It seems that it is related to the phone camera's memory usage. Evernote application gets kill when making the photo; therefore, evernote doesn't know there is a snapshot when it becomes active again.

I logged a defect and put a high priorty in it.

Share this post


Link to post

Good this bug has been recorded. I get the same thing on my HTC Magic 32B. Occasionally the snapshot will work, but mostly I get the "snapshot not found" error. Sounds like the phone camera's memory usage issue you mention Ah_Fan.

Share this post


Link to post
Thank carlessr for sending us the log.

08-14 00:53:00.055 I/ActivityManager( 71): Low Memory: No more background processes.

08-14 00:53:00.055 I/WindowManager( 71): WIN DEATH: Window{43531310 com.evernote/com.evernote.ui.MainActivity paused=false}

08-14 00:53:00.475 D/CameraService( 51): CameraService::connect E (pid 4624, client 0x1c8f0)

It seems that it is related to the phone camera's memory usage. Evernote application gets kill when making the photo; therefore, evernote doesn't know there is a snapshot when it becomes active again.

I logged a defect and put a high priorty in it.

I too have been having this problem. (Stock VZW Droid1 FRG01B)

Based on the reasoning, above, for the issue I was able to find a work-around (although quite tedious). Before attempting to take a snapshot note I would switch over to system_preferences/manage_applications and click on the running tab. (FroYo seems to no longer allow applications (including TaskKillers) to successfully force close other apps...) I would then kill all the processes that I wasn't currently using (i.e. basically everything except the camera, preferences, evernote, and anything that would crash the phone or immediately spawn half a dozen processes (took some trial and error there)). Then I would quickly get my photo for the snapshot note. I would have to do this every time I took a photo note (17 times over the afternoon as I documented an assembly procedure) as during the time between notes applications would get re-spawned.

I'm _really_ looking forward to a bug fix here to remove the pain from taking a snapshot note.

BTW: Before doing this yesterday I attempted to install the latest beta for Evernote that I could find, and about gives the following version: 1.5.1 (98310)

Share this post


Link to post

Another workarounds:

1. make the photo with the phone's native camera, go to the photo gallery and use "share as" to Evernote

2. email the photo to your Evernote account

3. use Evernote upload note to upload the photo from your camera's directory into your Evernote account.

One more thing which I am not sure: when you see that "No snapshot found to upload" happens, your photo "maybe" still saved in the phone's gallery. If so, you can locate that photo and do any of the workarounds from above.

We will sure fix this problem as soon as we can.

Share this post


Link to post

I reinstalled evernote, and am getting the same errors. It makes Evernote on Android pretty useless. And the "work arounds" don't work for me. After reinstall, evernote is not listed to share photos (work around 1). *updated* after a reboot, this seems to work again. And uploading a file is enormously difficult since you have to wander around file system and find a photo whose name you don't really know. Same issue for emails.

Share this post


Link to post

Same problem here. Motorola Droid, Android 2.2, Evernote 1.5.1. I have never been able to get a photo to upload using the Evernote app. Basically makes Evernote useless.

I really wish you would fix this. Let me know if I can help you by sending data from my phone.

Share this post


Link to post

+1

Actually +2 as it happens on both Moto Droids I own, one stock one running CM6.

I have at least 40mb of ram available, plenty of space on SD card.

The image IS being created (can see it on evernote folder) but the app just can't seem to associate the newly created image with an upload.

Can send logs if needed.

Share this post


Link to post

I'm having the same error. I can't take a photo and upload it or sync it to the cloud.

I'm running the latest and greatest beta and I'm on the Original Droid with Froyo (2.2)

I wasn't able to do it with the market version of the app either.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...