Jump to content
Andrew R

Safari Mac Safari Webclipper - nothing happens

Recommended Posts

I thought the previous version of clipper was fun enough (constantly being asked to sign in, suggestions to "why not clip this PDF" on every single PDF opened) but it's now not working at all.

When I click the evernote button a new tabs opens and ends up at URL www.evernote.com/ClipperSuccess.action?canClose=true&login=true    This quickly closes leaving me back on the page I wanted to clip but nothing else happens.

I've already tried reinstalling the extension (now on 6.11), restarting browser, clearing all evernote cookies/local storage.

 

Screen_Shot_2017-03-08_at_12_06_49.jpg

 

Update: This was resolved as follows: 

  • Uninstall the Evernote Web Clipper in Safari by navigating to Safari > Preferences > Extensions > Evernote Web Clipper and choose Uninstall
  • From the menubar, choose Safari > Clear History and choose All History > **Clear History
  • On your keyboard, press ⌘ command + ⌥ option + esc simultaneously, then select Safari and choose Force Quit
  • Restart your Mac
  • Open Safari and install the Evernote Web Clipper from www.evernote.com/webclipper
  • If prompted to choose between installing the extension from the Safari Extensions Gallery or directly from the developer choose Install from Developer.
  • Navigate to Safari > Preferences > Extensions > Updates to ensure you have the latest version of the extension installed
Edited by Andrew R
Updated with resolution
  • Like 1

Share this post


Link to post

Followed solution steps as described above. Clicking on the web clipper still does nothing. Not sure what happened within the past few weeks but it used to work flawlessly. Now, nothing!

Share this post


Link to post

Manually cleaning EN local cache files stored in ~/Library/Safari/LocalStorage/ did the trick for me, check this post with entire workaround:

 

  • Like 1

Share this post


Link to post

Ah I'd tried that beforehand and it hadn't helped so perhaps in some cases it's a combination of both the above AND clearing LocalStorage that's needed to get things working again.

Share this post


Link to post

Yup, it looks like we're back to the same catastrophe. Why the folks at Evernote can't fix this is beyond me.

Share this post


Link to post

Folks have done a lot of good work to come up with ways to fix this. The problem is, and Evernote is not acknowledging it, these solutions require USERS to uninstall potentially many things, clear out low-level (relatively speaking) files, then execute various restarts and reinstalls until finally - hopefully - the Evernote Web Clipper works. (And those results seem a little mixed as to success.) Casual users who just expect products to work likely will not do this, or worse, end up breaking something they can't fix. While I am a fairly experienced user, this is too much of a pain when I can just use the One Note clipper to do the same thing for the relatively few items (in the big scheme of things) that I actually clip. Sure, it means I have to use a separate app to view them. But that is less intrusive (for me) than trying to fix something that is not designed well. A better approach, if Evernote would think of users first, would be to provide an update that replaces the (obviously) defective version of the Web Clipper and as part of the installation process clears out the files no longer needed by the extension. There is just something wrong with a solution that requires me to uninstall extensions from companies A-E in order to reinstall a malfunctioning version of an extension from company F.

  • Like 1

Share this post


Link to post

Does not work for me. Tried the first method. Clean the LocalStorage too. What a shame ! The only solution now for me is to open the website on my iPhone and use the iOS Evernote extension... 

Share this post


Link to post

You have to set Safari's privacy preferences to allow cookies from websites I visit, otherwise clipper won't work.

  • Like 1
  • Thanks 1

Share this post


Link to post

I already have Safari's preferences set that way, so that's not the issue. As I said earlier, the web clipper was working fine for months then just stopped. I can't wait on Evernote so I've been using the OneNote web clipper instead. It actually works.

Share this post


Link to post

I am having issues with this as well. I have tried everything suggested above but alas it doesn't work. I sign it. It flashes "success" and then nothing. So darn frustrated.

Share this post


Link to post

Seems like Evernote doesn't give a hood. Shameful that they are not replying after many months of complaints. I had one out of 4 working Macs left. I had to do a clean install and after that web clipper is a bit like Donald Trump. It finds itself a big succes and says even so overtime when clicking the icon. Nothing happens of course. 

I am getting fed up. Need to see if an alternative service is working.

Share this post


Link to post
6 hours ago, The Barbarian said:

Shameful that they are not replying after many months of complaints

In the nearly 10 years of this forum,  Evernote have never replied to complaints or requests except very very occasionally if they needed more information from the poster. 

The way to get a direct response is to contact Support directly if you're a paying customer on https://help.evernote.com/hc/requests/new or tweet them if not via https://twitter.com/evernotehelps

  • Like 1

Share this post


Link to post
On 8/9/2017 at 11:41 AM, adcbc said:

You have to set Safari's privacy preferences to allow cookies from websites I visit, otherwise clipper won't work.

*** This worked for me! Thank you so much! ***

This is the solution folks. Just wanted everyone to know. :)

Share this post


Link to post
On 02/09/2017 at 5:02 PM, pbubblegum said:

Has a true fix ever been developed? I've tried everything here but nothing works.

There seems to be a fix which works for lots of users - see above.  If all else fails,  contact Support.  You can contact them directly if you're a paying customer on https://help.evernote.com/hc/requests/new or tweet them if not via https://twitter.com/evernotehelps

Share this post


Link to post

adcdc solution noted above worked!  

On 8/8/2017 at 8:41 PM, adcbc said:

You have to set Safari's privacy preferences to allow cookies from websites I visit, otherwise clipper won't work.

 

Share this post


Link to post

Just stumbled upon this same symptom in September 28, 2017 after installing WebClipper for the first time. Lost a browser session full of open tabs while trying to resolve it. Simply by restarting my browser, for some reason Safari did not restore the opened tabs. Nothing that can not be googled again but a pain in the 455.

I'd recommend to not use WebClipper and just try plain copy and paste.

Share this post


Link to post

The webclipper is the only reason to stay with evernote, but this has happened to me before and it's happening again now. None of the above solutions work for me, and I've had enough now—I can't be bothered to waste more time on this shoddy product. I'm a premium customer, but I won't be renewing. It's DEVONthink all the way from now on.

Share this post


Link to post

I have now read through several threads on this topic.

I am having the same issue on Safari Version 11.0 (12604.1.38.1.7), and Webclipper 6.12.4

I have tried all the proposed solutions:

- Enabling all cookies (really?  this is a thing? in 2017?)

- Uninstalling, Clearing history, forcing quit, rebooting, re-installing

- Uninstalling, clearing Safari history, forcing quite, going into Library/Safari/Localfiles and clearing it all out, re-installing

- Logging into Evernote web version

- Shouting very loudly at the screen

Nothing has fixed the unable to log in to Evernote on Safari problem (the "dot" is still on the extension icon, and I get the open tab, login, logout cycle when I try to use it)

The only solution appears to be either (a) Use a different product, (b) Use Chrome

I am an Evernote premium customer - have been for 4+ years - but am now seriously reconsidering.  This is ridiculous.

Share this post


Link to post

Just started happening to me too. Have tried the above fixes with no success. It works using Firefox, but this is NOT my preferred workaround!

Share this post


Link to post

Yes, I am having the same problem as well. When I click on the clipper button it only reloads the website again. Have tried the whole reboot, clear cache, reinstall clipper. nothin works.

Share this post


Link to post

Is there any alternative to Evernote? I'm tired of paying for this garbage that keeps on regressing with each passing year.

Share this post


Link to post
6 hours ago, hatamoto1961 said:

The webclipper is the only reason to stay with evernote, but this has happened to me before and it's happening again now. None of the above solutions work for me, and I've had enough now—I can't be bothered to waste more time on this shoddy product. I'm a premium customer, but I won't be renewing. It's DEVONthink all the way from now on.

 

5 hours ago, bluedaze said:

I have now read through several threads on this topic.

I am having the same issue on Safari Version 11.0 (12604.1.38.1.7), and Webclipper 6.12.4

I have tried all the proposed solutions:

- Enabling all cookies (really?  this is a thing? in 2017?)

- Uninstalling, Clearing history, forcing quit, rebooting, re-installing

- Uninstalling, clearing Safari history, forcing quite, going into Library/Safari/Localfiles and clearing it all out, re-installing

- Logging into Evernote web version

- Shouting very loudly at the screen

Nothing has fixed the unable to log in to Evernote on Safari problem (the "dot" is still on the extension icon, and I get the open tab, login, logout cycle when I try to use it)

The only solution appears to be either (a) Use a different product, (b) Use Chrome

I am an Evernote premium customer - have been for 4+ years - but am now seriously reconsidering.  This is ridiculous.

 

3 hours ago, laike9m said:

Having the same problem:huh:

 

3 hours ago, fvandersluijs said:

Me too! Since today :wacko:

 

2 hours ago, laferrereta said:

Just started happening to me too. Have tried the above fixes with no success. It works using Firefox, but this is NOT my preferred workaround!

 

1 hour ago, danAr said:

Yes, I am having the same problem as well. When I click on the clipper button it only reloads the website again. Have tried the whole reboot, clear cache, reinstall clipper. nothin works.

 

18 minutes ago, Abd said:

Is there any alternative to Evernote? I'm tired of paying for this garbage that keeps on regressing with each passing year.

Hey all, it sounds like you've encountered a new issue we've identified. There's more information here:

 

Share this post


Link to post

Got this problem today. Nearly got mad about this. I tried everything mentioned above. I visited the evernote.com website and logged in. After I closed the site and and reopened it, I had to login again. 

I now discovered, that suddenly a "remember me for 30 days" option was available on the login page. I clicked this and now the web clipper works again. 

I'm absolutely sure, that this option was not visible to me the whole day. Strange behavior.

Share this post


Link to post

Try this:

For Safari: Log in to the Web Clipper by signing into Evernote Web at https://www.evernote.com/Login.action and check ‘Remember me for 30 days’ when logging on.

For all other browsers: Log in to the Clipper normally, but select the ‘Remember me for 30 days’ option when signing in.

Share this post


Link to post
On 8/21/2017 at 7:37 AM, Suzie Q. said:

*** This worked for me! Thank you so much! ***

This is the solution folks. Just wanted everyone to know. :)

Worked for me too. Changed setting from "current website" to sites I visit. Thought that was how I had it set already, but I was mistaken. Thanks!

Share this post


Link to post

I really liked Bluedaze's post.  I just read these posts to hear other people complain about this, because it somehow makes me feel less angry when I see that there are many of us fighting with this system.  Thanks for that post, Bluedaze.  

Share this post


Link to post
8 minutes ago, zebu fleckvieh said:

Here's a quote I found that really describes my feelings:  "I felt like I was struggling with something that was supposed to solve my problem." 

from this lovely little article:  'Evernote is About to be Crushed'

http://techrail.in/evernote-is-about-to-be-crushed-by-competition

Seems like that link is to a post that's at least 3 years old.  at 220M users Evernote still seems to be struggling along...

  • Like 1

Share this post


Link to post

I was having the same problem as everybody here for over a year, i thought I had tried everything. Reading this thread, though,  I thought that MAYBE THE CULPRIT WAS THE NEW EXTENSION ITSELF (it updates in the background, leaving us unaware of the change: thus the  « it broke suddenly »).

So I connected an old MacBook that had an identical system, but had never been updated to the new Web Clipper extension, and lo and behold, after installing the old extension (6.9.0-b.25 (5134137/1.1.0.926). IT WORKS!

This was driving me crazy and I feel so much better now. Thank you all for putting me on the right track, finally.

—mh


MacBook Pro running TIGER: running High Sierra on the same machine, with the new clipper, never caused a problem.

 

Capture d’écran 2017-11-28 à 18.27.33.jpg

Share this post


Link to post

Oh and after installing the old extension, I DISABLED AUTOMATIC UPDATES in the Safari extensions preferences, otherwise I will be stuck with the same problem at the first update. That's fine with me, as long as I have the clipper back.

Share this post


Link to post

I had the same issue: I installed the Evernote web clipper extension, but nothing would happen when I would click on the icon. It turns out the version I was using did not support the Evernote web clipper. I upgraded my Mac to High Sierra and the web clipper works just fine now.

Share this post


Link to post

I'm in the same boat. Clipper just stopped working one day and no matter what I do it just doesnt seem to want to come back. I don't have the time to be constantly troubleshooting this. I just need a fix or I'm out. Has anyone found any other solutions which might solve it for me? I'm on Safari 11.0.3 and Evernote 6.13.1 and clipper 6.13.2.

 

Share this post


Link to post

I'm getting tired of having to fuss with the web clipper, trying x or y, and it working sometimes and not other times. I run the latest versions of Mac software and updates. If Evernote does not make this bulletproof, the entire platform is USELESS in my view. I'm a premium user but will become a non user shortly. Frankly, I think Evernote should consider this fix perhaps one of their highest priorities to get done right, and should consider their inability as a threat to their existence. I am not recommending the application to my friends and co-workers due to this problem alone. It's a major hassle!

Share this post


Link to post

Evernote Clipper has the disadvantage that every browser is being updated frequently - with Firefox and Chrome I believe it's daily - following a road map of its own.  Firefox (they say) just went to a whole new architecture.  Evernote have to try to stay on top of any changes that might affect Clipper - and some times it takes a while to catch up.  So far (touch wood) my Firefox clipper is still working,  even with the new version.  There have been a couple of threads about this so it sounds like Safari might have changed - again - to cause a new problem.

To make sure that they're aware of any issues as quickly as possible I'd recommend everyone reports them to Support - they are available on https://www.evernote.com/SupportLogin.action if you're a subscriber,  Twitter - https://twitter.com/evernotehelps if not.

Share this post


Link to post
在 2017/11/29 在 AM8點40分, mhrob說:

I was having the same problem as everybody here for over a year, i thought I had tried everything. Reading this thread, though,  I thought that MAYBE THE CULPRIT WAS THE NEW EXTENSION ITSELF (it updates in the background, leaving us unaware of the change: thus the  « it broke suddenly »).

So I connected an old MacBook that had an identical system, but had never been updated to the new Web Clipper extension, and lo and behold, after installing the old extension (6.9.0-b.25 (5134137/1.1.0.926). IT WORKS!

This was driving me crazy and I feel so much better now. Thank you all for putting me on the right track, finally.

—mh


MacBook Pro running TIGER: running High Sierra on the same machine, with the new clipper, never caused a problem.

 

Capture d’écran 2017-11-28 à 18.27.33.jpg

Hello, mhrob, Do you have the history clipper version of safari ? Could you please give me one ? I am tried to find old clipper extension 

Share this post


Link to post

My problem is that the clipper outlines the article to be clipped but does not offer a dialogue box to allow it to be saved.  I followed the instructions above.  It turns out that Apple no longer allows the Evernote developer file to be used, giving only the Safari Extensions version and saying it no longer supports the developer's version. Using the Safari Extensions version leads to the same problem I was having before.

Can anyone help?  Many thanks.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...