Jump to content
Toph

Version 6.9.2 on macOS 10.12 - typing "a" works as "Paste to Evernote"

Recommended Posts

Just like it says in the title, when I remove a shortcut from "Paste to Evernote", the A key is somehow the fallback shortcut for this. Lower case, with no modifiers.

Actually, this is happening for all shortcuts that have a default set.

I'm running the latest release on macOS Sierra, and have wiped and reinstalled Evernote twice now.

Share this post


Link to post
On 9/21/2016 at 8:50 AM, Toph said:

Just like it says in the title, when I remove a shortcut from "Paste to Evernote", the A key is somehow the fallback shortcut for this. Lower case, with no modifiers.

Actually, this is happening for all shortcuts that have a default set.

I'm running the latest release on macOS Sierra, and have wiped and reinstalled Evernote twice now.

Hi @Toph, thanks for reporting this. Our developers are aware of this issue and are working on a fix. I do not have an ETA for when this will be released.

In the meantime, a workaround is selecting Evernote > Preferences > Keyboard Shortcuts from the menu bar and using modifier keys such as CTRL, OPT, or CMD + Letter to restore a shortcut.

Please let me know how this works out for you or if you have any questions!

Share this post


Link to post

I got the same problem. Clean install of the app. It blocks the letter "a" in any way. Even change to another shortcut doesn't help.

Any beta with a fix available? I am in a busy production now and need Evernote on my desktop!

Share this post


Link to post

If you search & close the "Evernote Helper" app in the Activity Monitor then all is fine.

But you have to do it after every restart.

Share this post


Link to post

Another way to "fix" it is to paste the following lines into a Terminal window... 

defaults write com.evernote.evernote "ShortcutRecorder fullscreenshot" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder newnote" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder newnotewindow" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder pasteboard" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder screenshot" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder search" -dict keyCode -1 modifierFlags 0 modifiers 0

EN please fix this annoying bug asap.

 

Share this post


Link to post

I removed the keybo-rd shortcuts from Preferences > Keybo-rd shortcuts, -nd now Evernote h-s decided to t-ke complete control over my A key, using it to create new notes with the letter a.

I tried entering new keyboard shortcuts and I'm still having problems with the a key – now I have to paste a while listening to a ridiculous beep sound whenever I forget. I have also disabled the clipper in Chrome, but this seems to be global, and I cant find a way to disable the OS X Evernote Clipper – which is stupid because I NEVER use it.

Evernote. Fix this IMMEDIATELY. I can't tell you how disgruntled I have become with your company since you decided to increase your prices – you are literally hours away from going into my trash can forever.

 

Share this post


Link to post
On 5. Oktober 2016 at 1:55 PM, luckman212 said:

Another way to "fix" it is to paste the following lines into a Terminal window... 


defaults write com.evernote.evernote "ShortcutRecorder fullscreenshot" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder newnote" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder newnotewindow" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder pasteboard" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder screenshot" -dict keyCode -1 modifierFlags 0 modifiers 0
defaults write com.evernote.evernote "ShortcutRecorder search" -dict keyCode -1 modifierFlags 0 modifiers 0

EN please fix this annoying bug asap.

 

If I use your fix, and Evernote we'll release a bug release, I guess I need to re-set your fix, right? How'd this will look like?

Share this post


Link to post

+1. This bug is horribly Annoying. 

Not sure why this fix is taking so long since the issue is pretty obvious. The app is binding unassigned shortcuts to Keycode 0 which equals A.

@luckamy23's solution works by re-assigning them to -1 which is undefined. Just update the 0 to -1 in the App itself.

 

For reference, here's a list of the reserved keycodes on OSX.

http://macbiblioblog.blogspot.com/2014/12/key-codes-for-function-and-special-keys.html

 

Share this post


Link to post

HI,

I wonder if it's my local issue only. After upgrading to Sierra and Evernote 6.9.2 I noticed typing "a" anywhere (in Evernote or any other app) when Evernote is running behaves as "Paste to Evernote": new "Untitled" note is created with the current clipboard content. Obviously, I have no such shortcut and tried remapping a relevant shortcut in settings to anything or deleting it - nothing helps. Re-installed Evernote 6.9.2 from scratch, rebooted the Mac (it's mac Book Air, if it helps) - the problem still persists. I have disabled Evernote Helper as I never used it before.

Basically, I'm now unable to use Evernote client on Mac as any type I type "a" - well, I have a new Untitled note so I have to keep it closed and use Web version instead.

Upgrading to beta of v10 isn't an option either as it screws up my numbered list notes (it squashes all empty list items and trims the list which in my case ruins the numbering)

Is anybody else also having this problem? 

Share this post


Link to post
4 minutes ago, evgenyg said:

I wonder if it's my local issue only. After upgrading to Sierra and Evernote 6.9.2 I noticed typing "a" anywhere (in Evernote or any other app) when Evernote is running behaves as "Paste to Evernote": new "Untitled" note is created with the current clipboard content. Obviously, I have no such shortcut and tried remapping a relevant shortcut in settings to anything or deleting it - nothing helps. Re-installed Evernote 6.9.2 from scratch, rebooted the Mac (it's mac Book Air, if it helps) - the problem still persists. I have disabled Evernote Helper as I never used it before.

Basically, I'm now unable to use Evernote client on Mac as any type I type "a" - well, I have a new Untitled note so I have to keep it closed and use Web version instead.

Upgrading to beta of v10 isn't an option either as it screws up my numbered list notes (it squashes all empty list items and trims the list which in my case ruins the numbering)

Is anybody else also having this problem? 

I think it's a known error

See

 

Share this post


Link to post

[If this forum if for new ideas, is there one for bug reports? Thx]

,.. to open a new note. In fact, even if I set the shortcut keys to something sane, it still captures the A key. How can I fix?

 

EEC756D9-56A2-42B3-A579-394329230AB5.png

Share this post


Link to post

Hi,

I'm having a problem that whenever Evernote is installed on my Mac whenever I press the 'a' key (lowercase 'a' specifically), it clips whatever I'm looking at to a new note. It's not a keyboard issue- the same issue occurs when I use an external keyboard or the onscreen keyboard. It's not a general OS issue- the problem goes away when I uninstall Evernote (and reappears when I reinstall it). Removing the built-in shortcuts didn't do anything either. 

Couldn't find anything else about it on the internet, so thought I'd report a technical bug where support said to submit a ticket and maybe I'm being dense but there was no form to submit a ticket? So I came here haha.

As okay as the web version is, I'd really love to have my notes back so please please help!

 

Thanks

Share this post


Link to post

They fixed this in 6.10 but now the Clipper shows up with the text "Press (null)(null) anytime to show this window".  

JJeSIrP.png

Didn't anyone look at this before pushing this release? Please fix.

 

Share this post


Link to post
On 9/23/2016 at 1:19 PM, BSR said:

Our developers are aware of this issue and are working on a fix. I do not have an ETA for when this will be released.

It has now been over 4 months since this bug was reported.  Has this terrible bug been fixed yet?
If so, which version and release date?

Share this post


Link to post
17 hours ago, JMichaelTX said:

It has now been over 4 months since this bug was reported.  Has this terrible bug been fixed yet?
If so, which version and release date?

@JMichaelTX Our reports show the fix was this was included in the current GA release, version 6.10. 

Share this post


Link to post
46 minutes ago, BSR said:

@JMichaelTX Our reports show the fix was this was included in the current GA release, version 6.10. 

No it was only partially fixed.  Now, when removing the hotkeys, the Evernote Helper menu shows "Press (null)(null) anytime..." as I reported above on October 29, 2016.

Evernote_Helper.png

Share this post


Link to post
16 minutes ago, luckman212 said:

No it was only partially fixed.  Now, when removing the hotkeys, the Evernote Helper menu shows "Press (null)(null) anytime..." as I reported above on October 29, 2016.

Evernote_Helper.png

@luckman212: This is not related to OP's issue. I'll DM you.

Share this post


Link to post

Thanks for the DM but obviously you are not fully understanding the issue. The problem is that when all hotkeys are removed (see screenshot below) then instead of removing the "Press <whatever-hotkey> anytime..." text in the popup, it displays "Press (null)(null)... " which although purely cosmetic, is odd and potentially confusing.  I tried quitting everything and deleting the "~/Library/Group Containers/Q79WDW8YH9.com.evernote.Evernote/Evernote/quick-note" folder as you suggested but that made no difference.

screen.png

Share this post


Link to post
33 minutes ago, luckman212 said:

Thanks for the DM but obviously you are not fully understanding the issue. The problem is that when all hotkeys are removed (see screenshot below) then instead of removing the "Press <whatever-hotkey> anytime..." text in the popup, it displays "Press (null)(null)... " which although purely cosmetic, is odd and potentially confusing.  I tried quitting everything and deleting the "~/Library/Group Containers/Q79WDW8YH9.com.evernote.Evernote/Evernote/quick-note" folder as you suggested but that made no difference.

screen.png

Thanks for your response.

Our developers have two reports filed regarding shortcuts in Evernote Mac:

  • The issue in this thread that OP and others were experiencing is when a Keyboard Shortcut field uses letter "A" if empty. This was fixed in the 6.10 update.
  • The other issue, which is the one you are experiencing and is being tracked separately from the issue above, is removing the Quick Note shortcut shows (null)(null) in EN Helper. I don't currently have an ETA on when this will be fixed.

If you are able to, please submit a support ticket so we can get your activity logs and have our Technical Support team look further into this. Thanks.

Share this post


Link to post

You want me to submit another ticket? What happened to my very detailed ticket #1886092 from 10/30/2016?

  • Like 1

Share this post


Link to post
1 hour ago, luckman212 said:

You want me to submit another ticket? What happened to my very detailed ticket #1886092 from 10/30/2016?

It looks like ticket you submitted is closed and I'm unable to reopen it. If you don't mind, please submit another ticket using the link in my signature and include an activity log from Evernote so we can reopen the case with our development team. Thanks!

How to send an Evernote activity log

Share this post


Link to post
5 hours ago, BSR said:

It looks like ticket you submitted is closed and I'm unable to reopen it.

@BSR

Before Evernote closes a ticket that is a bug report, shouldn't you confirm with the user who submitted the ticket that the bug has been fixed?

It also seems like a decent bug tracking system will allow a "manager override" to reopen a ticket, or at least create a new ticket from the closed one.

cc: @EvernoteAlex

Share this post


Link to post
7 hours ago, BSR said:

It looks like ticket you submitted is closed and I'm unable to reopen it. If you don't mind, please submit another ticket

Ok, I submitted a new ticket - #2015216

Share this post


Link to post
On 2/12/2017 at 7:16 PM, JMichaelTX said:

@BSR

Before Evernote closes a ticket that is a bug report, shouldn't you confirm with the user who submitted the ticket that the bug has been fixed?

It also seems like a decent bug tracking system will allow a "manager override" to reopen a ticket, or at least create a new ticket from the closed one.

cc: @EvernoteAlex

The support ticket was closed after a member of our escalations team filed the report with our developers based on the information in @luckman212's ticket. The actual bug report that was filed is still open. I can't speak to what goes into the prioritization of fixes by our devs, but the issue is still being worked on. 

Share this post


Link to post
6 minutes ago, BSR said:

[...] I can't speak to what goes into the prioritization of fixes by our devs 

No need to speak. Actions speak louder than words.

Share this post


Link to post
10 minutes ago, luckman212 said:

No need to speak. Actions speak louder than words.

I completely understand the frustration. As I said, the issue is still being worked on. I'll post any updates here as I receive them.

18 minutes ago, BSR said:

I can't speak to what goes into the prioritization of fixes by our devs, but the issue is still being worked on.

 

Share this post


Link to post
34 minutes ago, BSR said:

The support ticket was closed after a member of our escalations team filed the report with our developers based on the information in @luckman212's ticket. The actual bug report that was filed is still open

@BSR, thanks for the clarification.  It would be very helpful if Evernote would advise the user who submitted the ticket that a bug report had been filed.

Share this post


Link to post
12 minutes ago, JMichaelTX said:

@BSR, thanks for the clarification.  It would be very helpful if Evernote would advise the user who submitted the ticket that a bug report had been filed.

You're welcome @JMichaelTX

This actually is part of the reporting process. The Mac specialist on the Technical Support team who received the escalation did notify @luckman212 that the report had been filed.

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...