Jump to content

Search the Community

Showing results for tags 'permission denied'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Calendars

There are no results to display.

There are no results to display.

Forums

  • General Discussion
    • Community Announcements
    • Evernote General Discussions
    • Evernote Integrations
    • Evernote Betas
    • Evernote API Discussion
  • FAQ's: Best Answers
    • FAQ's: Best Answers
  • Possible Bugs/Technical Issues
    • General Technical Issues
    • Evernote Business
    • Evernote for Android
    • Evernote for iOS
    • Evernote for Mac
    • Evernote for Windows
    • Web Client
    • Evernote Product Suite
  • Product Feedback/Feature Requests
    • General Feature Requests
    • Evernote Business
    • Evernote for Android
    • Evernote for iOS
    • Evernote for Mac
    • Evernote for Windows
    • Evernote Web Client
    • Evernote Product Suite
  • Evernote Forum Archives
    • Using Evernote
    • General Discussion Archive
    • Product Archives
  • Web Clipper***
  • International Forums
    • Japanese Discussions
    • Brazilian Portuguese Discussions
    • Discussions in Spanish
    • Korean Discussions
    • Traditional Chinese Discussions

Blogs

There are no results to display.

There are no results to display.

Categories

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Subscription

Found 1 result

  1. We are seeing "Permission denied" errors in IE when we have the Evernote Add-on installed and we open new windows, tabs and fancybox popups to every site/page we've tried. The problem appears to be in the Evernote Add-On itself. This simple page will demonstrate the problem: <html><body><a href="http://www.apple.com" target="_blank">click here</a></body></html>You will need to load the above page from a webserver as the problem does not appear to happen from html pages when they are opened directly with file URLs. I also think that you will need an IP or domain other then http://localhost/, as I was not able to reproduce it until I used http://127.0.0.1/. I have tried multiple URLs in the <a> tag, as well as the page itself. The contents or destination does not appear to have any affect on the problem. Once you click on the button, IE complains with a "Permission denied" error. And if you have debugging enabled and choose to debug the script, it loads the following page and targets the first code line as generating the error: /** * Represents page context (have permissions to access and modify DOM objects) */ PageContext = { url: (location && location.href) ? location.href : document.location.href, title: document.title, META: "evernote-webclipper-extension", getFavIconUrl : function() { var links = document.getElementsByTagName("link"); var i; for (i = 0; i < links.length; i++) { if (links[i].rel) { var rels = links[i].rel.toLowerCase().split(/\s+/); if (Evernote.ArrayExtension.indexOf(rels, "icon") !== -1) { // Found it! return links[i].href; } } } //Try to get it from google web site var re = new RegExp( "^[^:]+:\/+([^\/" + ":" + "]+).*$" ); var domain = PageContext.url.replace( re, "$1" ); return "http://www.google.com/s2/favicons?domain=" + domain.toLowerCase(); }, injectAdditionalTags : function() { var url = document.location.href; if ( url.match( /^https?:\/\/[a-z0-9-+\.]*(evernote|yinxiang)\.com\//i ) ) { try { var metas = document.getElementsByTagName( "meta" ); for ( var i = 0; i < metas.length; ++i ) { if ( metas[i].name == PageContext.META ) { return; } } var meta = document.createElement( "meta" ); meta.name = PageContext.META; meta.content = "installed"; var head = document.head; if ( head ) { head.appendChild( meta ); } if ( document.body ) { document.body.className += ((document.body.className) ? " " : "") + PageContext.META; } } catch ( e ) { alert( "PageContext.injectAdditionalTags() failed: " + e ); throw e; } } } };if((document.readyState == "complete" || document.readyState == "interactive") && !window.PageContext) { PageContext.injectAdditionalTags();} If you disable the Evernote Extension, this problem does not occur. Given that I can't reproduce the problem without using an IP or domain in the URL, I would guess that it is a security setting/feature. I use the default security settings, straight out of the box. I have only enabled display of all JavaScript errors and enabled script debugging - both which are off by default. I have version 4.6.2.7927 of the Evernote Extension installed. Our team has noticed this with several versions of IE including IE8, IE9 and IE10. We have also observed this problem on 32-bit and 64-bit versions of IE. All OS versions were Windows 7 with a mix of 32-bit and 64-bit editions. Is this a known issue? Is there an estimated date when a fix will be released?
×
×
  • Create New...