Jump to content

luckman212

Level 5
  • Content Count

    641
  • Joined

  • Last visited

  • Days Won

    1

Posts posted by luckman212


  1. I don't think you can read about it anywhere (yet) - this is something I was told privately in a support ticket. Not sure when it's coming either... could be the next beta or not for a few more months.


  2. This beta is getting better! Best release in a while.

    I know a new editor is coming... so I'm ignoring all of the code block bugs I reported which are still present.

    Still can't search EN note contents w/ Spotlight though, depsite nuking and rebuilding indexes again after installing 7.10b2

     

    • Like 1

  3. There's a bug related to https://discussion.evernote.com/topic/117007-mac-76-beta-1/?do=findComment&comment=521750 -

    This is about how highlighted words are shown when scrolling within a note. The original bug was fixed (scrolling vertically, the hghlights stay in the right place). BUT there's a 2nd part of the bug: when highlight results are found in Table cells, they don't move left/right as the table is scrolled & the contents are wider than the window.

    Here's a screenshot:

    EN-highlight-scroll-bug.png.cd55dd372cf6455554d0c058d14648ee.png

    and here's a little animated one showing the scrolling left/right while the highlights remain stationary:

    table-highlight-bug.thumb.gif.3b48f0ffd66e55bd7568af8a686b830e.gif

    bugreport filed: #2822781


  4. Code block editing is getting better in 7.10, but still has annoying bugs.

    1. Positioning the cursor at the origin of a codeblock and hitting the DEL key (forward delete) causes the entire first line to "jump" or pop out of the codeblock. The annoying workaround is to remember to position the cursor at the 2nd character and then use BACKSPACE instead. This bug has been there for at least a few years. Not sure if it's been reported but since someone finally seems to be doing work on codeblock I figure now's as good a time as any to try to bring this to light.

    2. Extra linefeeds are added to blocks of text containing blank lines when they are converted to codeblocks.

    Here's an animated demo of both bugs:

    codeblock_fun2.gif.5dbecd8c2562bb27edd23be5df6a2ce5.gif

    (edit: filed bugreport #2815737)

    • Like 1

  5. On 4/6/2019 at 10:27 AM, DTLow said:

    I post bug reports here in these release feedback discussions.
    For non-beta versions, I also submit a bug report to Support.

    Just in case, I opened an official bugreport (#2815722) related to these issues.

    • Like 1

  6. 4 Spotlight bugs:

    1. Spotlight only finds results when the EN app is RUNNING. E.g. if I search for "spotlighttest" while EN is not running, I see this:

    image.png.06da6a2dfefe4df4485ba8a4f53fae11.png

    Then, launch EN and repeat, and now it shows up:

    image.thumb.png.5aa8b42078d8fc8915406c2319ab024a.png

    2. Note title metadata in Spotlight is not updating- (see above screenshot)- original title (which had a space in it) is still shown in the Spotlight preview, but the note has long since been updated...days ago.

    3. EvernoteQuickLook keeps prompting for access to Keychain, despite me authenticating and clicking "Always Allow". This happens EVERY time EN is quit, re-launched and a Spotlight search is run. I've even tried clicking the "Allow all applications to access this item" but EN doesn't like that either and seems to just delete the token and create a new one, setting it back to its original value of "Confirm before allowing access".

    image.png.f7ccdec2de0802b42671a24401ad5069.png

    image.png.43d97fa4a48f0cdf535d35388fff5491.png

    4. Just to keep everything in one place, the bug I mentioned earlier: only TITLES seem to be indexed by the EN Spotlight Importer. Note contents are just indexed as "plaintext" files and show up as content.enml, content-pre-sync.enml, and snippet.txt which are unusable (can't be opened, and don't reveal to which note they relate):

    image.png.8cf9c50008299a260fc93527e0a6a229.png

    • Like 1

  7. What's the best way to report bugs in this version? Post here or submit bugreports via the feedback form? I want to make sure I'm not farting into the wind and I'm finding lots of little bugs already (par for the course)

    • Like 1

  8. 19 minutes ago, DTLow said:

    This is the database organization used on the Mac platform.

    Well, this is new I think- I don't remember seeing results like that in Spotlight w/ 7.9

    The bug is annoying because it does find things, but then you can't open them or see which note they are attached to. As I said before, I assume and hope that this is just a bug.

    • Like 1

  9. 20 hours ago, macfixer said:

    I can't, either. It seems the metadata now has a .enspot extension — I wonder if Alfred can't "see" these files yet?

    Actually I don't think 7.10 uses "enspot" files anymore. On the 2 systems I've installed 7.10 beta on, I deleted them completely and rebuilt both the Full Text and Spotlight metadata indexes, and spotlight search is PARTIALLY working with no trace of any .enspot files on my disk anywhere. When I say PARTIALLY working, I mean, that note content is not searchable via Spotlight, but TITLES are. I assume this is a bug?

    I agree, it would be nice if Alfred could see these - not sure how to make that happen either. Alfred problem? Seems like this article references a ~/Library/CoreData/com.evernote.Evernote folder, which no longer exists...

    Update: Ok it seems like what used to be the "CoreData" folder is now called CoreNote and lives at ~/Library/Group Containers/Q79WDW8YH9.com.evernote.Evernote/CoreNote/

    Below that, in /accounts/www.evernote.com/<account-id>/content, you will find a folder with a {guid} for each note in your database. Opening those up, there are "content.enml" "quickLook.png" and "snippet.txt" as well as other file attachments etc. The problem is, when I search in Spotlight, what shows up is the "content.enml" file with the preview showing RAW ENML instead of the snippet that it used to show. See below:

    spotlight.thumb.png.def0d9cc49e227e8b830b8628ae8c194.png

    • Like 1
    • Thanks 1

  10. Not that this is a solution but, if you install 7.9 beta 2 it PARTIALLY fixes this bug, but you still get the extra RETURN/newline added to everything copied from EN.  To work around that portion, I created an Alfred workflow that I bind to "CMD+SHIFT+C" which automatically trims off the extra linefeed. Major kludge but until they can fix the editor component it's better than accidentally pasting  rm -rf /  into a Terminal....


  11. 22 minutes ago, Jay-Bob said:

    The developers are on it, but it hasn't been fixed yet. It will be mentioned in the release notes when fixed.

    Ok, but- why release it then? It's almost like you want us to be disappointed.

    • Like 2

  12. 1 hour ago, Nick L. said:

    Fixes and Improvement: 

    • Small improvements to the client.

    Known issues:

    • Empty lines are eliminated when copying and pasting.
    • Spotlight search in macOS Mojave doesn't work.
    • Text appears fuzzy on non retina displays.

    Please continue sending us your feedback. Enjoy!

    Can I ask quite simply- why were the copy/paste bugs not fixed before releasing again? I don't understand how you can say "please continue sending us your feedback" when it is patently ignored??

    what exactly are the "small improvements" anyway? anything actually user-facing?

    This is disappointing after the CEO's post last month, I thought we were going to start seeing positive changes. 

    • Like 1

  13. 2 minutes ago, Sayre Ambrosio said:

    Yes, it's been good so far. Now with that said, I'm right in the middle of updating to the latest Mojave developer beta so we'll see if that breaks anything.

    Wow what is your secret sauce to make Spotlight work in Mojave? I have done everything .... completely delete Evernote, reinstall the entire OS, delete database and re-download everything, blow away Spotlight indexes, even bought a whole new computer ... it just doesn't work.... 

×
×
  • Create New...