Jump to content

flying_kiwi

Level 1
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About flying_kiwi

  1. I had a similar problem, with Evernote homepage redirecting me to the Japanese international site. I'm on Chrome, browsing from Australia in English. Went to Settings > Languages > manage languages... and found that Japanese was above English(Australia) in the list there. See attached pics. Moving Japanese to the bottom has fixed the issue.
×
×
  • Create New...