Jump to content
We apologize for the inconvenience, but chat support is currently unavailable. Please feel free to submit an email ticket or reach out at discussion.evernote.com. Thank you for understanding. ×

fcarballo

Level 1
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About fcarballo

  1. I install the 6.10 beta 3 and when I try to open it this is what I get.... Version too old: Your local Evernote data is being managed by a newer version of Evernote. Please use the latest version
×
×
  • Create New...