Jump to content

Michael VM

Level 1
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Michael VM

  1. Agree with the frustrations. It is unfathomable that no system requirements are posted. Just trying to start using with my Note 4 and and imac. Running OSX10.6.8, and can't find a version that will work with that OS. Of course after downloading it and installing it once already only to be told AFTERWARDS, that it is incompatible with anything less then 10.7.5. Bad why to start, and it wouldn't take much to provide a user with that information before downloading. The fact that these thread has been here for years and nothing has ever been done to correct it does tell you something.
×
×
  • Create New...