Jump to content

Bart van As

Level 1
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

5 Neutral

About Bart van As

  1. For those with problems on high dpi displays such as Surface Pro 3 or Yoga 2 Pro, you can easily resolve this until Evernote fixes this in 2 simple steps. What you need to do: 1) Tell Windows that it needs to ignore any setting that any application itself tells Windows (which is clearly wrong, since the UI is unusable) whenever a "manifest" file is available. Open registry editor and create the following DWORD registry key: Enable Windows to prioritise external manifests by creating and setting this registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide\PreferExternalManifest (DWORD) to 1 2) create a "manifest" file that tells Windows that Evernote is not using high dpi UI: create the file Evernote.exe.manifest with the following contents and place it next to Evernote.exe in C:\Program Files (x86)\Evernote\Evernote: (use Notepad or something similar - I had to save it in another location first and then copy because of file rights) <?xml version="1.0" encoding="UTF-8" standalone="yes"?> <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3"> <assemblyIdentity type="win32" processorArchitecture="*" version="11.0.0.0" name="Evernote.exe"> </assemblyIdentity> <description>Evernote</description> <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2"> <security> <requestedPrivileges> <requestedExecutionLevel xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3" level="asInvoker" ms_asmv3:uiAccess="false"> </requestedExecutionLevel> </requestedPrivileges> </security> </trustInfo> <asmv3:application> <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings"> <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware> </asmv3:windowsSettings> </asmv3:application> </assembly> note: forum makes an automatic link where it shouldn't so just copy from here: http://pastebin.com/XXqafS0P Now start Evernote again (no reboot required) and your UI is a bit fuzzy (due to scaling) but works perfectly fine! Problem solved! Thanks a lot to Luis and Surface Pro Artist Blog who first proved this workaround for Adobe Photoshop and Illustrator.
  2. For those with problems on high dpi displays such as Surface Pro 3 or Yoga 2 Pro, you can easily resolve this until Evernote fixes this in 2 simple steps. What you need to do: 1) Tell Windows that it needs to ignore any setting that any application itself tells Windows (which is clearly wrong, since the UI is unusable) whenever a "manifest" file is available. Open registry editor and create the following DWORD registry key: Enable Windows to prioritise external manifests by creating and setting this registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide\PreferExternalManifest (DWORD) to 1 2) create a "manifest" file that tells Windows that Evernote is not using high dpi UI: create the file Evernote.exe.manifest with the following contents and place it next to Evernote.exe in C:\Program Files (x86)\Evernote\Evernote: (use Notepad or something similar - I had to save it in another location first and then copy because of file rights) <?xml version="1.0" encoding="UTF-8" standalone="yes"?> <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0" xmlns:asmv3="urn:schemas-microsoft-com:asm.v3"> <assemblyIdentity type="win32" processorArchitecture="*" version="11.0.0.0" name="Evernote.exe"> </assemblyIdentity> <description>Evernote</description> <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2"> <security> <requestedPrivileges> <requestedExecutionLevel xmlns:ms_asmv3="urn:schemas-microsoft-com:asm.v3" level="asInvoker" ms_asmv3:uiAccess="false"> </requestedExecutionLevel> </requestedPrivileges> </security> </trustInfo> <asmv3:application> <asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings"> <ms_windowsSettings:dpiAware xmlns:ms_windowsSettings="http://schemas.microsoft.com/SMI/2005/WindowsSettings">false</ms_windowsSettings:dpiAware> </asmv3:windowsSettings> </asmv3:application> </assembly> note: forum makes an automatic link where it shouldn't so just copy from here: http://pastebin.com/XXqafS0P Now start Evernote again (no reboot required) and your UI is a bit fuzzy (due to scaling) but works perfectly fine! Problem solved! Thanks a lot to Luis and Surface Pro Artist Blog who first proved this workaround for Adobe Photoshop and Illustrator.
×
×
  • Create New...