Jump to content

Mahm00d

Level 1
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Mahm00d

  1. I maybe a little late, but for anyone who may come acros this thread: I had the same problem on my Win7 PC and what make it work for me was this: Internet Options > Advanced and tick the Use SSL 2.0.
×
×
  • Create New...