Jump to content

Web clipper not working on specific website?

Recommended Posts


I have been using Web Clipper for ages and never had any problems. Yesterday I tried to clip http://www.artgallery.sa.gov.au/agsa/home/About/

but it just will not work. I thought it was the extension but I have uninstalled it and reinstalled it, restarting the imac each time and it still did not work. I thought I would test a website that I have clipped from before and it worked fine. But will still not work with the Art Gallery of SA site. Any suggestions?

Thank You,


Link to post

I'm having trouble today, as well, and the Web Clipper is not working with anything that I try to clip/bookmark into Evernote.  If I "share" a link (the top right corner of the Safari Browser) to Evernote, that seems to be OK.  However, sharing a link isn't what I really want to do.  That just demonstrates to me that Evernote works, but Web Clipper does not.

I installed updates last night on my Mac, and now the Web Clipper does not work at all in Safari.  I've tried the usual - restarting (again), re-installing Web Clipper, etc.  I think it has to do with Safari itself and the updates.  I'll try Firefox.  Please let me know if you find a solution.

UPDATE:  My computer showed that I still had a Safari security update (which I thought downloaded overnight, but apparently it did not).  Once that went through, and my computer restarted again, the Web Clipper worked.

Edited by NYTeacher
  • Like 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...