Jump to content

iTunes Unable to download or Update App

Recommended Posts

I'm a premium user. I can't update my Evernote App on the iPhone 5S. I tried to update the app straight on my PC and got an error. So I tried to update the app straight from the Iphone 5S and got the same error. I've tried several times. I've updated other apps (just now) with no problems and no network connection issues.

Attached is the snapshot of the error message. 

I also have a iPod (older ios 6.1) that has the Evernote App but I don't update that APP as Apple hasn't updated that ios for years.

Any suggestions on how to update the Evernote App?



2016 ENOTE ISSUE 083016.JPG

Link to comment
  • Level 5*

I've done the IOS update many times without issue.
Hard to debug these "unknown errors"  :(

Possible solutions
- reboot your iphone and try again
- delete the app and do a clean install

Link to comment

I've been having this issue since this morning as well on iphone 6 running 9.3.4. Have tried multiple reboots and deleted the app. Just fails when trying to install, the download never starts. Also tried on wifi vs LTE.

Link to comment

Ok thanks all.

I will try a modem reboot and move to a new install for the iphone.

We are having another storm and potentially that is causing a slow intermittent issues with internet connection. Just so odd - as I've successfully downloaded other things. I have to wait to reboot the modem as family are watching a show and want me to wait. :huh:

I did try updating directly from the i phone instead of the computer (my normal practice) but the app just stayed on "waiting" status and has become non-functional. I just got a message back from Apple stating the same things DTLow & Willem stated above but others are also reporting the same type of connection problems.

Thanks again -hopefully it will be operational in a few hours



Link to comment

I have the same issue. My network connection is not slow (more than 100 Mbit/s). I noticed this issue when I wanted to update Evernote on my iOS devices. Other apps were updated without problems, but not Evernote. Then I deleted the app, just to download as a fresh install, but it simply does not want to download from the App Store. I have even tried to download from iTunes via my MacBook. But it did not work neither.

This is really a bizarre problem. I have never had such issue with any app before. Now I cannot use Evernote on my iPad. :(



Link to comment

Hi Aleksandar -  My problem was fixed with a complete reboot of the cable company's 3 boxes (routers and such).  Like you I had internet connection and other APPS updated but I couldn't get the Evernote one to respond. Also, all the internet speed tests I ran looked decent.

BUT Apple tech said something that made me go ahead and wait to reboot all the cable company boxes.  "though you have internet connection you may not have the correct and current server location through your provider. You must do a full reboot of your cable provider boxes to update links so the server is obtaining a correct address. and especially if you are working on WI-FI in your home"

Seemed strange, but I went ahead and waited for everyone to be off TV and rebooted everything. I now have the reinstalled the APP to my iphone  By the way, I also tried updating directly from my phone too but it didn't work. That could be because I use WI-FI and not cellular data.

Strange but it worked for me. Good Luck

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...