Jump to content
Due to limited holiday staffing, chat will be unavailable from Thursday, July 2 at 5:30 PM (CDT) to Monday, July 13 at 8 AM (CDT). This will allow us to reply to your email requests as quickly as possible. Thank you for understanding. ×

Archived

This topic is now archived and is closed to further replies.

maxxyme

Link doesn't open in latest Evernote version

Recommended Posts

Hi,

I just update Evernote this morning to new 6.2.4.3244 (303244) Public version.

And I'm having trouble opening an external link I have copy-pasted in a note:

http://www.celio.com/CELIO_ALL/03-05-BERMUDA/DENIM-BERMUDA/short-denim-bermuda/Short-regular-délavé-100%-coton/p/1030874

Other similar link does not have the problem:

http://www.celio.com/CELIO_ALL/03-05-BERMUDA/DENIM-BERMUDA/short-denim-bermuda/Bermuda-regular-effet-usé-coton/p/1030878

Note: I do not remember having the problem before updating.
I suspect this is related to some UTF8 encoding for the French accentuated character "é" but as you can see the 2nd link has 1 too and it opens fine.

Share this post


Link to post
1 hour ago, maxxyme said:

Hi,

I just update Evernote this morning to new 6.2.4.3244 (303244) Public version.

And I'm having trouble opening an external link I have copy-pasted in a note:

http://www.celio.com/CELIO_ALL/03-05-BERMUDA/DENIM-BERMUDA/short-denim-bermuda/Short-regular-délavé-100%-coton/p/1030874

Other similar link does not have the problem:

http://www.celio.com/CELIO_ALL/03-05-BERMUDA/DENIM-BERMUDA/short-denim-bermuda/Bermuda-regular-effet-usé-coton/p/1030878

Note: I do not remember having the problem before updating.
I suspect this is related to some UTF8 encoding for the French accentuated character "é" but as you can see the 2nd link has 1 too and it opens fine.

Thanks for letting us know about this. It's actually the % symbol in the first link that's leading us astray. We'll work on addressing that for our next release.

Share this post


Link to post
23 hours ago, emerick said:

Thanks for letting us know about this. It's actually the % symbol in the first link that's leading us astray. We'll work on addressing that for our next release.

Thanks Emerick for answering so quickly.

Share this post


Link to post

This issue appears when the link contains a French accentuated character (é, etc)

 

Share this post


Link to post
2 minutes ago, flaneige said:

This issue appears when the link contains a French accentuated character (é, etc)

Well, according to emerick, it's rather the % character that messes with the Unicode-encoding of the special (French) characters... (like here on this forum, % being converted to the unexpected sequence %25 ?!)

Share this post


Link to post
On 22/08/2016 at 2:43 PM, emerick said:

Thanks for letting us know about this. It's actually the % symbol in the first link that's leading us astray. We'll work on addressing that for our next release.

Problem still there with 6.3.3

Share this post


Link to post

The following link works :  file:///C:\Test\fichier test.txt

This one doesn't work :  file:///C:\Test\fichier testé.txt

Share this post


Link to post

The problem still exists in the most current release, but the original report is somewhat flawed.

This link exists in an Outlook email: http://bw.healthcarerealty.com/Projects/Operations/BrightWork Pages/Work - Due Soon.aspx 

But after pressing the "Save to Evernote" button the link becomes: http://bw.healthcarerealty.com/Projects/Operations/BrightWork%20Pages/Work%20-%20Due%20Soon.aspx 

If you look at the uninterpreted link you would see that the original has '%20' inserted for each blank while the Evernote link changes this to '%2520'. Clicking on the Evernote link results in a rather nasty server error - something about the syntax not being correct.

So this is what needs to be corrected.

Share this post


Link to post

×
×
  • Create New...