Jump to content
We apologize for the inconvenience, but chat support is currently unavailable. Please feel free to submit an email ticket or reach out at discussion.evernote.com. Thank you for understanding. ×
  • 3
Ashlea

Request for undo option back in tool bar

Idea

Hi,

The undo button in the tool bar with the B and i etc was really convenient. Could we at least have the option to have it there/choose what's in the toolbar?

Now once you select it it floats and then disappears and you have to reopen options tab.. after being so conveniently placed...

  • Like 2

Share this post


Link to post

13 replies to this idea

Recommended Posts

  • 0

Hi, ashlea, and welcome to the forums! Yeah, I don't mind having it in the menu, but it was handier on the toolbar. Maybe they moved it off to make room when they added superscript, subscript, and strikethrough. But since I already have to scroll to see some options on the toolbar anyway, it wouldn't be any worse to have Undo back there.

Share this post


Link to post
  • 0

I don't remember the Undo/Redo functions ever being in what I call the 'formatting ribbon' (bold, italic, underline, etc) - which is what the OP seems to be referring to, although perhaps 'formatting ribbon' isn't the official term for it.

But I do remember them being on the Toolbar, right next to the green tick that you tap to save your note. There were two rounded semi-circular grey ticks, one for Undo and one for Redo - right where they were perfectly easy to reach - without having to open up a menu each and every time you wanted to undo something; and without taking up any space (the latest version of the app simply has blank white space where the two buttons were previously so conveniently located).

But hey, I found a neat way around this issue! Firstly, I always keep backups of APKs in case new app versions create technical issues, or, as in this case, developers decide to make silly changes that reduce the ergonomics of the app. So, on my main Android device, the one I use for making most of my notes, I simply refuse to update Evernote until they put the buttons right back there where they belong :-)

Yep, that device is still running Evernote v7.5 which I believe was the last version before this awkward change was made. Keeping the old APK as a backup means that if ever I need to restore the device, or if I wish to install Evernote on a new device, I can continue to use v7.5, which, for this reason alone, I believe was the best version of Evernote for Android yet.

 

Share this post


Link to post
  • 0

Ralph77, the version I have at the moment, v 7.9.9 has it back where you say they were. ?

  • Like 1

Share this post


Link to post
  • 0

Hi Ashlea,

Thanks - the latest version I'd got up to on my secondary device (which I don't take many notes on, but I generally update Evernote on it, just to see if the buttons have been reinstated) was v7.9.8.2, which still didn't have the buttons where they belong.

So... I just updated it now to the latest 7.9.9... but sadly the buttons are still not there for me - did you have to change some setting to get them back up there?

Cheers, Ralph

Share this post


Link to post
  • 0

Hi, sorry about that. It was just there when I updated. This is on my mobile device, maybe it's different on a tablet, if that's what your secondary device is.

Share this post


Link to post
  • 0

Hmm, intriguing, both of mine are LG mobile devices, though different models. What I'll do is uninstall/reinstall on both of them, then I'll report back with results :-)

Share this post


Link to post
  • 0

OK, I've not done a complete uninstall/reinstall, but did it the quick way (Clear Data via the apps list).

I'm starting to wonder if maybe it could be related to the version of Android being used? The device that I installed v7.9.9 on, and yet is still not showing the Undo/Redo buttons, is running Lollipop (Android 5).

I've attached a couple of screenshots just so the devs know I'm not mad :-p

I can confirm that Evernote v7.5 does show the Undo/Redo buttons on both versions 5 & 6 of Android, because I previously had them visible on Lollipop, and they're still visible on Marshmallow.

As you can see from the screenshot, v7.9.9 isn't displaying the buttons for me on Lollipop.

Ashlea, can you confirm which Android your device is running?

v7.9.9 without Undo or Redo.png

v7.5 with Undo & Redo.png

Share this post


Link to post
  • 0

Hi Ashlea,

I finally found my v7.5 backup so I was confident to upgrade to v7.9.9 on my Android 6 phone. Unfortunately I was not able to confirm your findings. Please see the attached screenshots:
One shot confirms that there are still no Undo/Redo buttons on the toolbar.
Another shot shows where the Undo/Redo options are at the bottom of the breakout menu.
Another shot confirms I'm using v7.9.9.
And finally a confirmation that I'm running Android 6.0.1.

I'm interested to know if, as well as having the Undo & Redo buttons on the toolbar, do you also get the Undo/Redo options at the bottom of the menu?

Screenshot_2017-04-30-10-23-41.png

Screenshot_2017-04-30-10-23-27.png

Screenshot_2017-04-30-10-25-55.png

Screenshot_2017-04-30-10-26-30.png

Share this post


Link to post
  • 0

Hi Ralph,
The Undo/Redo options are in fact also at the bottom of the menu which I had not noticed.

 

  • Like 2

Share this post


Link to post
  • 0

Thanks for your help with this Ashlea, I guess I need to report this as a bug then, rather than as a feature request.
Cheers, Ralph

Share this post


Link to post
  • 0

Just a quick update - I have reported this as a bug and it is currently being investigated. Apparently it had not been reported by anyone before.

Additionally, I installed Evernote v7.9.9 on my tablet, and wouldn't you know it, the buttons do appear on the toolbar, right where they're meant to be.

So this bug is specific to certain devices (in my case, two different model LG phones) which will no doubt make the devs work hard for their money ;-)

Share this post


Link to post
  • 0

Pleased to report that after MUCH persistence on my part to keep this bug on the agenda in the EN Beta Testing Google+ group over the last 5 months, it has now been squashed, as of v7.14! I was requested by EN tech support to join the group so that I could give feedback.

It eventually turned out that unbeknown to many of the developers, evidently when the 'Share' button was added to the top toolbar, a programming instruction was given to not display the Undo/Redo buttons on the toolbar - but only for devices below a certain screen resolution. The intention was that this would declutter the toolbar for devices that risked the possibility of not having sufficient room to display all of the buttons. The flaw in this was that even in landscape mode, when there is arguably plenty of room, the Undo/Redo buttons still wouldn't appear.

The relatively simple solution (in the end) was to remove the Share button from the toolbar while the note is in edit mode - after all, no-one wants to share a note while in the middle of editing it! Voila.

Off topic: there is also now a neat feature that allows you to delete an unsaved note. Check the dropdown menu while in edit mode. Previously, if you wanted to delete a note you were working on but hadn't saved, you needed to save it first.

  • Thanks 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...